Android Native Development Tools (Missing Requirement)


  1. nyu

    nyu Member

    Good day everybody...

    i am installing Android ADT to my Eclipes Juno (manually/Offline) using ADT-20.0.3.zip
    during installation everything went fine except this message


    Cannot complete the install because one or more required items could not be found. Software being installed: Android Native Development Tools 20.0.3.v201208082019-427395 (com.android.ide.eclipse.ndk.feature.group 20.0.3.v201208082019-427395) Missing requirement: Android Native Development Tools 20.0.3.v201208082019-427395 (com.android.ide.eclipse.ndk.feature.group 20.0.3.v201208082019-427395) requires 'org.eclipse.cdt.feature.group 0.0.0' but it could not be found


    ive search the internet for answers but...
    some say that i have to uncheck the Android Native Development Tools check box...
    but i already did that.. and still the message is there and there's no way i can continue.. the "next" button is still disabled...


    can you suggest any.. exept online solution.. because i have no internet connection at all at home...

    ive already tried online installing and it work fine but i want something offline... thanks in advance...

    Advertisement
  2. jonbonazza

    jonbonazza Well-Known Member

    Moved to Dev 101.

    First of all, I am not sure why you are trying to install ADT for eclipse manually from a zip file. it's much easier to just let eclipse handle it (Look here).

    Either way, to answer your question, the error message tells you exactly what is wrong. In order to install the native development tools, you need to install the Eclipse CDT plugin. If you follow the instructions in the link I provieded instead of trying to do it manually, eclipse will calculate and install the dependancies automatically.
  3. nyu

    nyu Member

    thanks for the response sir...
    well im installing ADT manually so that i can know how to do it even without an internet connection...
    another is to have my own collection of complete plugins, add-ons, android platforms etc.
    yes you are right that is so easy to just paste the link and hit "ok"
    but i want it to be more detailed for me to really understand what i am doing....(to educate me well)

    anyway ill download the Eclipse CDT plugin that you said....
  4. nyu

    nyu Member

    good day sir...

    i have downloaded and installed Eclipese CDT plugin
    and here is what ive got...

    [​IMG]

    the finish button is disabled.... cant finish...
    what do you think is the problem again?
  5. jonbonazza

    jonbonazza Well-Known Member

    Unfortunately, I haven't worked much with Eclipse Juno, as it is still an early release and as a result is still rather buggy. In fact, Google still recommends using Eclipse Indigo, so until they say otherwise, I plan to keep Indigo installed on my machine. You might try reverting to that version and see if it doesn't help.
  6. nyu

    nyu Member

    you think it doesn't conflict if i had multiple eclipes with different versions?
    because you say so... ill try downgrading ^^ thanks a lot you keep replying
    im a bit busy this pass few days in my work....

    btw... what version of ADT works fine in your indigo?
  7. jonbonazza

    jonbonazza Well-Known Member

    Eclipse instances and their configurations are kept entirely separate on disk and, at least from Indigo to Juno, no changes were made to the project file structure, so no, there shouldn't be any conflicts.

    As for what ADT version I use, I always use the latest ADT available, however it should be noted that, at least on linux (I haven't encountered this problem on Windows, but that's not to say it's not possible), sometimes updating the ADT will cause eclipse to freak out and it will merit a fresh install. Still haven't figured out what, exactly causes this, but it definitely seems to be something to do with the native tools and the Eclipse CDT. At any rate, if this ever occurs, the only true solution I have found is to uninstall eclipse and remove the hidden configuration directory for that particular instance. This config directory can be found on linux at ~/.eclipse/<your eclipse version>

    Once you have done that, you will need to reinstall that particular eclipse version, as well as all of the plugins that you had installed for it.
  8. nyu

    nyu Member

    woah!! thats a lot of work to do "reinstall" hehehe
    anyway for the sake of solving this problem ill do what you said
    => but.. i just remember previously i did some "uninstall eclipes, SDK. etc" that is related to this
    (baam!!) they are all gone...
    but when i reinstall all of it...(it must be as new as possible) but what did happened is somehow it says (this "plugin , etc" is already installed "i think it happens when im installing ADT")

    - i think there still left on the registry or somewhere in my computer when i uninstalled it (i dont know where to look)
    --> my question is how can i totally clean all the tracks of what ive installed? so that when i re-install all of my application it will flow like ive never been installed any android making application....
  9. jonbonazza

    jonbonazza Well-Known Member

    Like I mentioned above, you need to remove the .eclipse directory from your home directory (~/.eclipse). All of your plugins and config files are stored here.

    EDIT: It should be noted that the presence of the '.' at the beginning of the directory name means that it is hidden. easiest way to remove it is to open the terminal and type:
    Code:
    rm -rf ~/.eclipse
    

Share This Page