1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

Android TV Stick - Problems


  1. nbuuifx

    nbuuifx Member

    I have a MK809 android stick.

    If I use it fairly basically as just the stick with wifi and the airmouse plugged in then it functions fine.

    My first problem is I seem a little limited by the wifi. No matter which TV I try it on (3 separate areas in the house) I get about 1.8mbps download and 2.1mbps upload.

    I've downloaded the speedtest.net app which is where I got those results from.

    My android phone or tablet both get around 15mbps from the same app for download and about the same 2.1mbps on the upload.

    My main purpose is to use it as a media player, and it is OK with most avi files from my NAS but takes quite a while to start each film. With some it will start stuttering after 5 minutes or so.

    So I thought I'd try a USB Ethernet adapter, so I got a powered USB hub and plugged the airmouse dongle and the ethernet adapter in. Like this it works but as soon as I try to do anything major it just crashes. From reading this is normal if it runs out of power.

    I am powering the mk809 from my nexus 7 charger which is 2A and the powered hub is 2A. The only thing I have noticed is that if I turn either power supply off the other device carries on working. ie the hub stays lit up and functioning even if I remove it's power supply, and vice versa the mk809 stays powered via the hub if I turn off the power supply to the mk809.

    So it should have 4A available but I'm worried that it doesn't quite work like that and that it is only using one of the power supplies at once?

    Even the speedtest app crashes, it does however shoot up before crashing!


    Any ideas to make it work?!

    Advertisement
  2. Unforgiven

    Unforgiven ~Shoveling Snow~ Moderator

    I moved this to the Google TV forum so you get some better eyes on it.:)
  3. nbuuifx

    nbuuifx Member

    I think I sorted the power problem but it made no difference! I didn't like the way the hub was back powering the mk809. I found an article about hubs doing this with the pi and people just snip the red wire either in the lead or in the hub, I peeled a little bit of the lead insulation back and snipped the red wire. It all works still as before but now neither device powers the other.

    It still crashes as soon as I use the network though :(

    I can however unplug the hub which tends to unfreeze the android stick.

    I'm guessing either the hub or the ethernet adapter is not compatible but I'm not sure which!

    The ethernet adapter is recognised by android and it obtains an IP etc, but as soon as anything really uses it it will only do a small amount before crashing.

    I did try using the mk802 remote app so I could control it with my nexus and plug the ethernet adapter straight in but I can only get that to work over the wireless :( So it stops working when I switch to ethernet, and I can't find it in the list of devices.

    Any thoughts or suggestions for testing?

    Edit forgot to mention that my connection is a 30mb Virgin media
  4. nbuuifx

    nbuuifx Member

    I've also tried a non powered USB hub, same result.

    It seems to be after so many packets have passed through or something like that! If I go on to firefox and browse the web on the wired network it will freeze after a few mins (mouse won't move etc)

    If I do something more demanding like the speed test it shoots up but then freezes after a few seconds.

    It is all fine on wireless - just not fast enough for my streaming!

    Also still can't quite figure out why download is 1.8mbps out of a possible 30mbps and upload is 2mbps out of a possible 2mbps!
  5. mikedt

    mikedt 你好 Guide

    It's probably faulty, or quite possibly all the MK809s are like that. R&D, testing, assembly and QC can be quite abysmal with these things. The MK809 is a cheapo thing of unknown Chinese manufacture. Crappy/fluky WiFi and general instability is often an issue with them. Probably best to RMA and return it for replacement or refund.

    It's not an official "Google TV", it's basically just a cheapo Android tablet in a HDMI dongle form.
  6. nbuuifx

    nbuuifx Member

    Yeah I realise what it is, but it works really well when on wireless (other than the wireless being a bit rubbish) it's just when the hub / lan is plaugged in that it goes unstable. Just hoping someone had found a solution.

    I'm going to try installing a different ROM to see if that fixes/changes anything. I'd seen one rom that was rated highly but had the one problem that wifi didn't work at all with it - that would still be fine if the LAN works!

Share This Page