Anker 2x 1900mAh battery problem/questionSupport


Last Updated:

  1. ilovecoffee

    ilovecoffee New Member

    I just purchased the battery mentioned above from Amazon. I bought it off a direct link in this forum, though since I am new and cannot post it. Anyway, I have fully charged both with the included charger and when I insert either one into the phone I get the greyed out exclamation point for the battery monitor. The phone does not recognize the battery, but everything else seems to function fine. Has anyone else had this problem or know of a fix? My phone is not rooted. Thanks.

    Advertisement
  2. KryptoNyte

    KryptoNyte Well-Known Member

    Sounds like you got a bad battery(s).

    Can you post an android screenshot with the grayed out exclamation icon? Thanks.

    I've been using a pair of these Anker batteries now for over a month now with no issues.
  3. qu4ttro

    qu4ttro Well-Known Member

    What happens if you put the stock battery back in? Then does the battery meter read correctly?
  4. ilovecoffee

    ilovecoffee New Member

    I have no issues at all with the stock battery.
  5. Austrie

    Austrie Well-Known Member

    Try this, charge your anker battery to 100%(with the external charger, don't use the phone to charge it), put the battery in your phone then go into recovery and wipe battery stats. Afterwards drain the battery(using the phone a lot), then charge the battery to 100% with the phone off.

    If the phone still doesn't read the battery, then you have a bad battery; but the method listed above should work if it isn't a bad battery.
  6. ilovecoffee

    ilovecoffee New Member

    Does my phone need to be rooted in order for the recovery mode to work? I was able to get to the hboot screen, but when I chose recovery it takes me to the red triangle of death. I don't mind rooting (though I have never done it before) as this is a new phone and I don't really care about losing anything at this point. My contacts are synced with google and have 0 info besides a handful of apps. Please advise. Thanks.
  7. gary93

    gary93 Well-Known Member

    I think you do need to be rooted because it is a different recovery. Look at the how to root post, and I think it has to done with the CWM (4ext or other recovery system). Btw, I ordered this battery and should get it soon. I'm thinking turning on all bluetooth, gps, 3/4g, wifi, anything that use battery a lot in order to get it fast for the first 4 cycle. Does that healthy to both the phone and the battery? Should I or shouldn't I do that? If not, what is the fastest way?
  8. ilovecoffee

    ilovecoffee New Member

    I rooted the phone last night, wiped the battery stats and am waiting to kill the battery. As of now, it's still not registering. Thanks.

Share This Page