Another Frustrated N7 userSupport


  1. ziggy4477

    ziggy4477 Member

    I have to say that I loved my Nexus while it worked. I too recently had the battery run dead. I was (or thought) I was charging but when I went to use it it was totally dead. I tried all the tricks and gimicks I read on line (and really should you have to go through all that to charge a device?) Nothing worked...Just totally black screen. I finally decided to get a new battery....easier said than done! All of the places I tried to order from were either out of stock or on back order...Hummm that's kind of tells me that a lot of users are looking for a new battery...(do ya think there's a problem here?) I finally found a used battery on e-bay, got it put it in and it worked great...while the battery lasted. I keep trying to charge the battery and it says the battery is not charging. I pulled the battery out because by now I have only 12% left and I really can't afford to keep buying new batteries every time I want to use my tablet. Well as you can tell I'm frustrated and very disappointed. Holy Crap you google Nexus battery won't charge and you more stuff than you can read in a life time.
    Anyway back to the problem, does anyone know why my nexus won't charge? I'm using the charger that came with the device. Any help would be appreciated.
    Thank you from one frustrated, disappointed and not real tech savey person.

    Advertisement
  2. lunatic59

    lunatic59 Moderati ergo sum Moderator

    There was a bug with the 4.2 update that affected a lot of users. Try this:

    1. Plug-in your dead N7 to a wall charger. (Jump immediately to step 2.)
    2. Immediately after plugging it in, press Volume Down and Power at the same time.

    *This should get you into the bootloader menu. You may have to try this with different chargers or test out the timing in order to get it to work.

    3. Once in the bootloader menu, use Volume Down until you see
  3. ziggy4477

    ziggy4477 Member

    My fingers are sore from holding down so many different combinations of buttons...BUT I finally did get the google logo to come on went to the menu and choose the power off option then pluged it back in and the battery charging icon did appear and it appeard to be charging, then the screen went black again. Do you think the battery is still charging even though I can't see the battery icon on the screen?
  4. Hook

    Hook Ever since DU... ;-) VIP Member

    Yes, the screen blanks while charging. If you press the power button quickly (don't hold), the charge animation should reappear and then it will go blank again. If you do this periodically, you should see that the "fill line" is geting higher and higher.
    lunatic59 and ziggy4477 like this.
  5. ziggy4477

    ziggy4477 Member

    Wondering if you had any advice. I'm back to the same problem. My N7 started to run down at about 50% so I tried to charge it and it won't charge. Do I have to go through all that button pushing, with multiple tries before it finally connects and charges every time I need to charge the thing?
    And this time I get to the point of getting the battery logo and I think it's charging, but no.....it's not charging so I go back through the whole stupid process again get the battery charging logo ....but when I check it's not charging.
  6. scribley9

    scribley9 Active Member

    Any chance you have a faulty charger? (Or you are using an adaptor for your charger that is not making good contact). If you can't borrow one from a friend to test then try using the same cable and connecting to a PC USB socket instead. Does it charge then ?
  7. lunatic59

    lunatic59 Moderati ergo sum Moderator

    The last time this happened, did you perform a factory reset? or did you simply get it to power on and keep going from there?
  8. ziggy4477

    ziggy4477 Member

    I just got it to charge with no reset. I've seen something about a factory reset in the information I have read. Should I do that and if so, how do I do it?
    thanks
  9. ziggy4477

    ziggy4477 Member

    I'm trying to charge hooked up to a USB on my computer, it worked last time but now I can't get it to work.
  10. John Bean

    John Bean Happy Wanderer Guide

    I think your Nexus 7 is faulty, maybe a bad connection at the USB port.

    I assume it's under warranty? If so the remedy seems obvious.
    El Presidente likes this.
  11. lunatic59

    lunatic59 Moderati ergo sum Moderator

    At this point a factory reset couldn't hurt. You find that under settings >privacy. Remember to back up everything because it will write out all user data and settings.
  12. jnarciso

    jnarciso Member


    you may want to try the wall charger that came with the unit. I belive that is a 1A charger. Most PC USB ports will only provide .5A.

    Not saying the PC shouldn't work but since you are having trouble it is worth trying the AC adapter.
  13. ziggy4477

    ziggy4477 Member

    Having the same stupid problem, can't get N7 to charge. Sometimes after several tries it will charge but this time I can't get it to charge. You said try a factory reset I"m going to try that and I hope it works. At this point I have to say I HATE THIS PRODUCT. As many of my friends have said, ""you should have paid another hundred bucks and got something that works". Sorry to say I agree with them.
  14. El Presidente

    El Presidente Beware The Milky Pirate! VIP Member

    Why don't you call in your warranty? It's not been out a year yet, Asus/Google should repair or replace free of charge.
  15. jhsrennie

    jhsrennie Well-Known Member

    scribley9 likes this.

Share This Page