Another Possible Battery KillerTips


Last Updated:

  1. powerpack

    powerpack Member This Topic's Starter

    Joined:
    May 23, 2010
    Messages:
    6
    Likes Received:
    2
    I have experimented with different tips here and my battery has been really
    good. I have actually never had a smart phone battery last so long. I work from my home office. Yesterday I took my phone off the charger at 7:15AM. During work hours I do not use the phone very often. It mainly sets on my desk. I do check out the market a few times a day and tinker a little. At 7PM last night when I picked up the phone to really use it my battery was still at 82%. This is with the GPS on, Wifi on, bluetooth off, and no 4G here. Also I have an Airave which gives me 5 bars of signal. My previous phone was a Treo 800w and under the same conditions it would be at about 55% for the same time frame.

    I did the GSM phone change. I also have signed off of GTalk and have it set to not automatically sign me in. I use battery indicator to show battery % and I do not use a task killer. I use exchange for my email and I also have a gmail account using the gmail app. No friend feed and I have facebook to update every hour. Weather is updating every hour. News is set to manual update as is stocks. Sports Tap is installed and set to update every hour.

    My battery has been this good for the past two or three days. This mourning I pulled it off the charger at 7Am and didn't look at it again until 9:30 and the battery was down to 68%. I looked to see what might be different today and the only thing I could find was I had a notification for facebook that had been in the notification area since 6:30 this mourning. I went into the facebook widget setting and turned off notifications. I recharged the phone and pulled it off the charger at about 10:30AM.

    The first thing I noticed was that I didn't get the usual quick battery drop. Thirty minutes later it was still at 100%. The battery has even been better than before. Normally the indicator would drop 7 to 8% in the first couple of hours but would level out after that. Today it is 6PM and my battery is at 94%. Granted I have not done much with the phone but just pick it up and play with it a few times but losing on 6% in 7 hours in almost unbelievable.

    I think this proves (to me at least) that wifi and gps are very efficient and that you don't have to cripple the phone to get good battery life.

    For those who have had terrible battery life you might try and turn off notifications in the facebook widget. That also stopped my quick first 10% battery drain.
     

    Advertisement
    codered78 and B-Ran like this.
  2. MisterEd

    MisterEd Well-Known Member

    Joined:
    Apr 15, 2010
    Messages:
    773
    Likes Received:
    117
  3. JerryG

    JerryG Member

    Joined:
    Jun 7, 2010
    Messages:
    20
    Likes Received:
    3
    What's the "GSM phone change"? I searched the forums, but this is the only thread with that phrase in it.

    Thanks,
    -Jerry
     
  4. powerpack

    powerpack Member This Topic's Starter

    Joined:
    May 23, 2010
    Messages:
    6
    Likes Received:
    2

    Sorry I didn't explain it better. Here is the post from the XDA forums.

    [How-To] Better battery life, reduce Time Without Signal. Alright, I don't remember who it was, but first off, I would like to thank the person that figured out how to check the radio mode.

    Pictures coming soon!


    First things first, I have personally tested this with DamageControl 1.0, with Flipz's .03 radio, and found it increased my battery life by 30-40%. I am using the stock 1500mAh battery. Please note that the option to change the preferred network type is not available in 1.5 ROMs, as 1.5 is GSM only. (HTC hacked in CDMA support)

    NOTE: when you first open the testing menu, it will show it as CDMA auto (prl). This is a visual glitch, in reality, it is set to GSM auto (prl). If your TWS is around 50%, it means it's GSM auto (prl)

    First things first, go into Settings> About Phone> Battery> Battery Use> Cell Standby. Assuming your phone has been on, or off the charger for ~10 minutes, it should show Time Without Signal at around 50%.

    Next thing, press HOME, and bring up the dialer. Dial *#*#4636#*#* (Do not press "Call"). After a second, it should bring up the "Testing" menu.

    Go into Phone Information, press MENU, and tap "select radio band." You should experience a Force Close, don't panic, this was supposed to happen. Scrolling down shows that the preferred network type is GSM auto (prl).

    What this means is that even though you are connected to a CDMA network, your phone is trying to find a GSM network, preventing the radio from sleeping, and causing excessive battery drain.

    Remedy this by tapping GSM auto (prl), and changing it to CDMA auto (prl).


    Now your done, your TWS should drop dramatically, and you should experience much better battery life!

    Note: You need to do this every time you reboot.
     
  5. Elganja

    Elganja Member

    Joined:
    Jun 15, 2010
    Messages:
    8
    Likes Received:
    0
    interesting... i don't for my phone
     
  6. JerryG

    JerryG Member

    Joined:
    Jun 7, 2010
    Messages:
    20
    Likes Received:
    3
    I installed the Network app, and it showed CDMA auto PRL, and my TWS was 11% when I checked.

    Going into test mode though, showed it set at GSM, or is it possible that it's just the default setting when you go to change this?

    Thanks and regards,
    -Jerry
     
  7. TampaShooters

    TampaShooters Well-Known Member

    Joined:
    Apr 11, 2010
    Messages:
    106
    Likes Received:
    14
    Mine was aleady defaulted on CDMA Auto
     
  8. JerryG

    JerryG Member

    Joined:
    Jun 7, 2010
    Messages:
    20
    Likes Received:
    3
    When going into test mode, or using the Network app?

    Thanks,
    -Jerry
     
  9. TampaShooters

    TampaShooters Well-Known Member

    Joined:
    Apr 11, 2010
    Messages:
    106
    Likes Received:
    14
    Test mode.
     

Share This Page

Loading...