Another thread about Micro SD Card issue re: playing video filesSupport


  1. Knightmare69

    Knightmare69 Active Member

    I searched our Tab2 forum and seems most of the threads were either unresolved or not the same issue as mine. I was running a normal SanDisk Micro SD 32gb card. It crapped out so I decided to swap over to a SanDisk Ultra 64gb card as I have the 32gb version in my S3 with no issues. I read about the formatting issue and needing to change it to Fat32 which I have.

    Prior to this I did not format using Fat32 and instead formatted with the Tab2 instead. I thought this was the cause of my headaches but seems even after formatting with Fat32 it still hasn't been resolved.

    I transferred video files from my pc that work perfectly fine to my sd card since I travel alot for work. I use MX player but also tried Mobo during this period to see if it was a player issue as well as the stock player.

    One of the first issues is that the Tab2 sometimes won't see my card or won't see the available memory I have on it, or read it wrong entirely ie says I have 128mb free when I know I have over 30gb free.

    So now I've formatted using Fat32 and haven't had enough time to see if that problem still comes up but the other issue is that my video's don't play. Or they play on one try but won't play again on the next.

    I bought my SD card from the Samsung store so I'm assuming it's not fake. So can anyone shed any light on the matter?

    Advertisement
  2. dragonballz

    dragonballz New Member

    I have the issue as yours. I assume you have a class 10 sd card. I have a sandisk class 10 32gb which also gives me the same problem. I think it is the tablet, nothing to do with the card. So I keep on unmount and mount the card to avoid the problem.
  3. Knightmare69

    Knightmare69 Active Member

    Well I brought my card back to Samsung (it's the ultra card btw, not sure if that's the class 10) and they swapped it for another 64gb card. At the same time I've been in contact with SanDisk support about my issue (more on that).

    Based on all my research, I formatted the card on my pc first to fat32, then formatted again on my tab as many ppl have noted this works. Well it didn't work for me. Then I tried formatting the card in my S3 as some ppl have noted this works also because supposedly the S3 formats in Fat32. Still no go, card is still flaky.

    Now at this time I've been emailing SanDisk support about my issue and they told me that in fact the 64gb cards DO NOT support Fat32 and must use Exfat and that formatting in Fat32 would actually damage the card. So I've gone and reformatted my card to Exfat and then formatted it again with the Tab and am now testing it. Hopefully this works.
  4. Knightmare69

    Knightmare69 Active Member

    So the 64gb Ultra is still unstable even after following SanDisk's advice and I've already started the process with them on replacing it. SanDisk is certain my replacement Ultra is also defective. Guess we'll see what happens.

Share This Page