Another Transformer prime that won't power onSupport


  1. stang9779

    stang9779 Member

    DOA out of the box. I purchased mine from Best Buy.com. I called the online number they told me I could get my money back that's all they could do for me. I want a working unit.

    2nd I called Asus and they want me to pay to have it shipped to Texas for repair. I didn't order a refurbished unit. I just want a new working Transformer Prime now. lol

    Do you guys think that I would get anywhere taking it to the Best Buy store?

    Advertisement
    :
  2. speedygonzo

    speedygonzo Well-Known Member

    Happened to mine too.
    Just charge it for a while and then turn it on.
    Fixed my issue.
  3. JAy3001

    JAy3001 Well-Known Member

    What speedygonzo said. From what I have read some units shipped without any charge and will need charging before you switch on. Some people say at least 45 mins before switching on and the device should start to come to life. (Lights and feedback vibration)

    I believe they need an 8 hour charge for a full battery.
  4. UNSCleric

    UNSCleric Active Member

    Since you didn't mention it, I kinda assume you didn't try charging it first? You probably tried that, but if not, you're supposed to charge it for eight hours before even attempting to turn it on for ideal long-term battery health. It's going to need a little charging though to turn on in some cases.
  5. ryguy5254

    ryguy5254 Well-Known Member

    I'm going to guess that he took it out of the box, tried to turn it on, and didn't try to charge it before complaining.

    If he says otherwise, he'd be lying at this point. He would've mentioned charging it in his first post if he did.
  6. stang9779

    stang9779 Member

    I tried both. I charged it for around 4 hours. The power light is now green. It still only vibrates. No display and sometime I get a sound from it.
  7. wynand32

    wynand32 Well-Known Member

    Just a note: the Prime turns on automatically the second you plug it in (assuming it has any charge at all; it would presumably turn on automatically once it gets to a certain level from a completely dead state). So, NOBODY can just charge it without turning it on first.

    Also, I think the whole "charge for 8 hours thing" is boilerplate ASUS stuff probably meant to ensure that people get it to a full charge state initially. I can see no good reason to charge it past 100%, because we should assume that there's a cutoff at 100% and that the thing doesn't continue to get stressed/heated past it's theoretical limits.
  8. stang9779

    stang9779 Member

    On that note I've given up and am returning it. I think it's DOA.

    I have ordered one from officedepot.com. This time i will plug in and charge it first thing. I hope this curves the issue on my replacement.
  9. jubb

    jubb Active Member

    Mine won't turn on! After a week of debating the whole switching from Champagne to Amethyst Grey, I opened it, plugged it in, it vibrated, the screen flashed and went black. Now when I hold down the power button, nothing happens. Except the red light that is on the power button will flash twice after I hold it down. That's the only response I get from it. Tried the Hard Reset with no luck. Gonna let it charge for a while and then try it again.

    SOOOO FRUSTRATED!!!
  10. jubb

    jubb Active Member

    Ok, so the batter was just really really dead. After it was plugged in for a 1/2 hour it actually attempted turning on again. Still failed and I had to let it sit a little more.
  11. alki

    alki New Member

    Got mine today, and it won't power on. 2 hours on the charger now and still nothing.
  12. alki

    alki New Member

    update: green light. still won't power on.
  13. dblhelx

    dblhelx Active Member

    Alki.......did It ever power on? I just got mine. Dead out of box. Has the little organge light that links when I depress the power button for a couple of seconds. I'll charge it for awhile and see how it goes....just curious if It cleared up for you and others.
  14. Patsfan

    Patsfan New Member

    Ordered my from BB. Charge it overnight. 14 hrs charging. Won't turn on. Something is definitely wrong with this tablet. Too many issues with it. Called Asus and they want me to pay for shipping and send it back. Pigs as$$. Going back to BB.
  15. kronie

    kronie Well-Known Member

    Wow. That's BAD QC!! Makes me nervous!
  16. BadderBrad

    BadderBrad New Member

    I finally received my Transformer Prime today after waiting for my pre-order since November 23rd. I already owned a TF101 so I was somewhat familiar with what to expect. I unpacked everything and expected the tablet to start but even after plugging it in all I saw was the battery symbol showing it was empty. I was immediately nervous as I had a problem with my original Transformer after 40 days of use and had to ship it to Asus for replacement (just short of the 30 return policy by NCIX).

    I read a couple of posted in this thread so I plugged it in and hope for the best. I waited around 30 minutes and it still did the same thing. Then I waited around an hour and the amazing thing came to life! The best part is that it looks like the ICS update has been delivered at the exact time I received my tablet. I am still a bit nervous to effect the battery at this point as my replacement TF101 did not seem to have the same juice that my first one had. I want this to last as long as possible, so I am waiting to make sure it is fully charged before playing with it for too long.

    More to come.
  17. austinmills

    austinmills New Member

    Same thing happened to me -- got it today from Best Buy (32Gb Grey), let it charge 8 hours (power button light was green), tried to turn it on... nothing. Not once did the display ever flicker.

    Tried all of the following:
    • Regular power on
    • Hold power button for 30 seconds
    • Hold power for 30 seconds then release then 3 seconds
    • Paper-clip reset
    • VolDown and Power for 12 second reset

    None of it worked, the display never showed -anything-. I suspect either the display itself is bad or the connecting cable isn't connected. 2nd returned TFP in less than a week.
  18. Spyridou

    Spyridou New Member

    I had the same issue with my new Prime TF201 32 g today. Got it 2 days ago, charged a full eight hrs as directed, played with it a while, plugged it back into the charger, and when I went to turn it on today, NOTHING. I had a green light, but nothing worked (not even the reset). I called the support #, and a very nice tech had me do the following:

    Press the volume down button first, and hold it, then press the power button, and hold it also. I held them about 10 seconds before it booted up in what looked like a DOS screen. I let the buttons go, then he had me push the volume UP button, and viola..........it started right up.

    The tech said I should not have any more problems with it.

    I've been on it all day now with no issues.

    Hope this helps !!!
    Richman21, ocnbrze, andygu3 and 2 others like this.
  19. Clairissa79

    Clairissa79 New Member

    You tooottallly fixed my problem!!! Thank you so much for the clear instruction you received!!! Excellent! Thank you again!
  20. Spyridou

    Spyridou New Member

    So glad this helped someone else !!! :)
    ocnbrze and andygu3 like this.
  21. mekko

    mekko New Member

    Thanks Spyridou for the detailed instructions! ... your post solved my boot problem. I was worried because I knew my TF201 was fully charged before I powered it down yesterday, so I was fairly confident it wasn't due to a low battery. Thanks again!
    andygu3 likes this.
  22. andygu3

    andygu3 Well-Known Member

    Welcome to the forums!!!!!!!!!!!!!!!!!!!!!!:D:D:D:D:D:D:D


    Thanks for the help:)
  23. VoodooReload

    VoodooReload New Member

    I tried this methode but still nothing......
    bnanna likes this.
  24. cowgirlaround

    cowgirlaround New Member

    thank you thank you thank you. Your method worked for me too!!:p
    ocnbrze likes this.
  25. lpaq

    lpaq New Member



    This worked for me 2, thanks for the info!
Loading...

Share This Page