Tips Answers for USB connection issues


  1. bind00

    bind00 Well-Known Member

    Thanks for this great post. Shame on somebody that it should be this difficult. My brain's a bit fried but I'll try to make sense. I just want to connect a Galaxy S as mass storage. Got your point about setting the USB mode and mounting. But my Windows XP 32-bit says there's a problem with the driver, and indeed there appears to be no driver assigned to the device. I have the latest version of [spit]Kies[/spit] and downloaded the latest USB drivers through it. But in the Samsung/USB Drivers folder there are all sorts of weird names mostly starting with S, Simmental, Siberian, Swallowtail. Which one do I need? Thanks for any help.
  2. ogami_ito

    ogami_ito Active Member

    Hi,

    What are you able to do in debug mode? Can Kies flash in this mode? I know you can attach Panda PC Suite (which sucks but hey...it works) in debug mode. You cannot use Odin though. So...what good is this?
  3. ogami_ito

    ogami_ito Active Member

    YOu seem to have problem worse than me. I can at least connect in mass storage mode.

    BTW, you don't need Kies, or the Samsung drivers AT ALL for mass storage mode. YOu need some sort of USB Mass Storage Device driver that works on your system. But that is not specific to the SGS. So if none of the drivers are working, I would offer this generic advice:


    1. Use this tool that I found out about yesterday: CCleaner registry cleaner.
    2. Go into install software, and get of all non-used USB device programs like Nokia PC Suite (which is only slightly better than Kies BTW)
    3 Reinstall Windows. Sorry... it sucks.
  4. bind00

    bind00 Well-Known Member

    Argh! :eek:
    That's not what I wanted to hear!

    It was working with Kies a couple of days ago but then it went into this crazy repeating MTP crash thing yesterday. I tried deleting Kies, just using the driver installation but no dice. I'll have a go at clearing out any registry residue. Should be OK as I have another mass storage device working right now.

    Thanks for your reply.
  5. DroidRick

    DroidRick Well-Known Member

    Bind, you don't have to do anything as extreme as Ogami is recommending (re-installing Windows).
    Scroll back up to my solution and find the driver that I mentioned.

    Uninstall Kies first. It's a disk hog and not necessary.
    Then install the driver I mentioned.

    For the first time you can go into Mass Storage mode while in debug mode.
    Since making my first connection I have turned off debug mode and it's working fine.

    It took a long time for me to figure everything out, but it's working now.

    Good luck!
  6. philu

    philu Active Member

    I dont know if this has been mentioned before but:-

    Kies doesnt find my phone if my default Home app is LauncherPro. I have to revert to the suppled Home app, TwLauncher, and Kies finds the phone no problem
  7. bind00

    bind00 Well-Known Member

    Thanks DroidRick

    That advanced the cause some way (although never underestimate your correspondent's ignorance. It took another half an hour to figure out how to put the damn thing into debug mode (Settings->Applications->Development->USB debuging, in case anyone else is listening)).

    This at least meant that Windows acknowledged that the device was connected. Before it was completely ignoring it. But it's still saying that there's a driver error. The drivers you quote are installed without Kies (which I agree, at 216MB, is a hog).

    If I follow the driver update pop-ups and choose to select the location myself I come back to my earlier question. Which driver should I chose? Under Program Files/Samsung/USB Drivers there are 19 folders named Simmertal, etc. Which of this obscure names am I supposed to choose? And how the hell am I supposed to know?:confused:

    It just goes to show how much I take for granted my PC knowledge when I get so horribly lost on a new system.

    I don't really understand what you're saying but it sounds like this is something for a new thread.
  8. bind00

    bind00 Well-Known Member

    OK, I get it. Don't choose the driver location myself. Let Windows do it - just this once. That worked. :rolleyes:

    I don't quite understand where it found the driver though. From the list of folders I mentioned. Or from somewhere else altogether, in which case what's the point of installing the drivers in the first (17th, actually) place.

    Main thing is, it works.
    Thanks all.
  9. Cyb3r5c4r

    Cyb3r5c4r Well-Known Member

    Hey i have a problem along the same lines.

    First time i install kies and connect my galaxy it will connect, but next time i connect it kies says connecting but never connects. so i looked in device manger and my galaxy appears there as GT I9000. I decided close kies and to uninstall the drivers and disconect my usb, i start kies again plug in the phone, drivers install and kies connects.

    i know i can keep doing this but its a pain in ass

    any idea?
  10. DroidRick

    DroidRick Well-Known Member

    You're welcome!

    I did the full Kies install and it was more than 2G, (yes you read that right).
    I ended up re-formatting my hard drive to get rid of all of it. :(
  11. Sanciman

    Sanciman New Member

    As I see - regarding the mentioned problems with connecting your SGS to XP - putting your phone in debug mode if there is a problem, the software tries to find what is wrong and correct the mistakes.
    Anyway, I spent hours to find out, why my SGS is not connecting to my pc, and right after I enabled debug mode, found it immediately and works fine since then.
    Thats all I need and wanted to solve.

    Sanci
  12. philu

    philu Active Member

    I dony really understand what you dont understand so I will re-phrase it:-
    I cant connect my SGS and Kies when i'm using LauncherPro. But so long as I revert to TwLauncher then I dont have this problem. I would guess this applies to all SGS's
  13. LateNiteMike

    LateNiteMike Well-Known Member

    @ ogami_ito
    Thank you for explaining all the necessary steps for USB connection in mass storage with a PC. I did just as you sated....and it worked PERFECTLY !!!
    Just so others will now know.....THIS is the way to do it properly !

    You said....."2. How to connect in mass storage mode.
    This will allow you to connect in such a way that your computer will see the Galaxy as a USB storage device, so you could put (or take from) music and pictures on the device. Some people have problems with this, but I suspect that most of the time, people just don't know the steps. To connect this way, connect with USB cable to PC. If you set the USB mode to "Ask", then it should have a pop-up in the home screen where you select "Mass Storage". Now here is a step I think some people may miss. Go to the status bar. There will be a message saying USB Connected. In THAT message (if you connected in mass storage mode, it will say "Select to Copy Files to/from computer". You need t oselect this. Then push the button that says "Mount". Then wait 5 seconds."
  14. psychocandy

    psychocandy Well-Known Member

    I downloaded something called automount and this works too.
  15. DroidRick

    DroidRick Well-Known Member

    Glad you got yours working Mike.
    I assume you are using Win7 or installed some USB drivers?
    Because if you don't, Ogami's steps won't work. You NEED the USB drivers.

    I tried his steps and they didn't work (Win XP). It wasn't until I installed the correct USB drivers, that I could get it to work as Mass Storage.
  16. LateNiteMike

    LateNiteMike Well-Known Member

    Getting back to you DroidRick....with an in-depth follow up.

    It seems like you did manage to get things to work for you...and that's great.
    However I'm not sure you needed to install any drivers...because I'm using Win XP also and didn't install any.
    My XP version is (old) 2002, with Service pack 2. That's it.

    Now....I'm going to detail...step by step....what I did that worked for me without installing any (new) drivers. Here goes....
    With your Device (SGS smartphone) turned on....and your PC turned on and using XP...perform these steps.


    The following steps are done on your device...
    1.) In 'Settings' open 'About Phone'.
    2.) In 'About Phone' press on 'USB settings'.
    3.) Select 'Ask on connection'.
    4.) Hit 'Back key' twice to go back to 'Settings'.
    5.) Connect your device to the PC with the USB cable that came with your device.
    6.) A window will pop up on your device screen.
    7.) Select 'Mass storage'.
    8.) Pull the Notifications screen down and...Press on 'USB connected'.
    9.) A pop up will appear.
    10.) Choose 'Mount'.
    11.) In 'Settings' select 'SD card and phone storage'....and then down in 'Internal SD card' select 'Mount SD card'.
    12.) On your computer (in XP)...open 'My Computer'.
    13.) In 'My computer' double left click on 'Removable Disk (G).
    You will then see all of your files that are on the Internal SD card of your device. You can then drag and drop files to your PC.

    When you are finished transferring your files then go back to your SGS...into 'SD card and phone storage'...and Press on 'Unmount SD card'.
    Then pull down the Notifications screen and Press on 'Turn off USB storage'.
    A pop up window will appear. Select 'Turn Off'.
    Done.....
    Whew !!! I know this works because I just followed my own instructions and IT WORKED...again.
    So, I worked through making this list and checking that it works...and it's 3am. So, that's all folks....I'm going to bed !
    I hope this set of specific instructions works for all who try it on their SGS. It should,...and will perhaps work on other Andriods as well.
    Cheers !
  17. DroidRick

    DroidRick Well-Known Member

    Thanks for getting back to me finally Mike.

    When I connect now I just basically need to:
    1. Connect the cable from SGS to PC
    2. Pull down menu on home screen and mount the USB connection.
    (I have the settings set, not to ask on connection, just do USB)

    That's it!
    When I'm finished, I do it in reverse.

    Your steps are basically the ones people should follow when trying to connect to a PC with WinXP for the first time.
    Having said that, I am sure some will need to install USB drivers for the Android as I did.

    The reason I say this is because I followed your procedure when I was trying to make a connection and it didn't work (on two WinXP PC's).
  18. LateNiteMike

    LateNiteMike Well-Known Member

    You're absolutely correct regarding your short steps to setup a USB connection to a PC (with XP). I thought surely there must be a quicker way to perform this task...and you have it. I tried it and it works.
    My hat's off to you DroidRick, good work !
    :)

    Hopefully we've boiled this down to the point to where any newbie can now get their USB setup and going with minimum hassle.
  19. maxx8

    maxx8 New Member

    how do i revert backk??? im using LauncherPro and i cant find touchwiz anywhere
  20. ogami_ito

    ogami_ito Active Member

    Hey,

    Download Home switcher. Makes switching between launchers very very easy. Its a little program, but is very necessary for anyone , for whatever reason, who uses or wants to try out multiple launcher programs.

    On another note, I'm now at my parents home. I'm going to download kies onto their computer and see if I can connect in Kies mode, as I was not able to do this at all on my computer. I really was hoping someone would have expert advice on how to troubleshoot the driver situation for my phone on this computer (and what I'm having is a serious driver issue)
  21. maxx8

    maxx8 New Member

    thank youuuuuu!!! i reconnected to kias on tw and it works now. with launcherpro not so much. as for the kias issue, i havent had a problem yet.. but i did get a brand new computer w/ windows7 and it kinda installed everything for me.
  22. edie209

    edie209 Member

    Hi I have been having the same problem as many others getting into Kies.

    Here is what I did (Windows 7 32 bit)

    Uninstalled Kies

    Downloaded a new version of Kies and installed it.

    Turned on USB degging mode and connected the phone

    All drivwers were then installed but I got a message that Kies could not connect in debugging mode.

    Switched off debugging mode.

    Then reconnected however I still got the "Connecting" and I never actually connected.

    So I downloaded and installed the drivers from here Samsung Galaxy S Windows Driver - download tag - Softpedia as posted by ogami_ito

    I reconnected and everything works :D
  23. ArmadaTattoo

    ArmadaTattoo Well-Known Member

    I am hoping someone will have some insight for me.

    I have always been able to connect to Kies without problem. I found it slow and awkward but I always worked for me. I presumed I was one of the lucky ones.

    Yesterday all that changed. Having read that FroYo could be available to me any day now (I am in Ireland) I plugged it in to check if the update was available. The problem I am facing is that when I plug the phone in and select Kies usb mode the phone starts trying to connect but never does. It seems to continually restart the MTP application.

    I tried resetting TwLauncher as my default home launcher as I was trying out both LauncherPro and ADWLauncher.

    In fact, installing the above launchers are the only major changes I have made to the phone since I was last able to connect ( maybe 4 weeks ago)

    My Kies version is 1.5.1.10074_75 - I have read that this version should work.

    Perhaps I should uninstall Launcher Pro and ADW Launcher Pro?
  24. ArmadaTattoo

    ArmadaTattoo Well-Known Member

  25. NoOneSpecific

    NoOneSpecific New Member

    2. How to connect in mass storage mode.
    This will allow you to connect in such a way that your computer will see the Galaxy as a USB storage device, so you could put (or take from) music and pictures on the device. Some people have problems with this, but I suspect that most of the time, people just don't know the steps. To connect this way, connect with USB cable to PC. If you set the USB mode to "Ask", then it should have a pop-up in the home screen where you select "Mass Storage". Now here is a step I think some people may miss. Go to the status bar. There will be a message saying USB Connected. In THAT message (if you connected in mass storage mode, it will say "Select to Copy Files to/from computer". You need to select this. Then push the button that says "Mount". Then wait 5 seconds.



    You, Sir, are a freakin' GENIUS!

    Thank-you!
    Thank-you!
    Thank-you!

    :)

Share This Page