any instructions to root a Mezmerize?


Last Updated:

  1. broberts

    broberts New Member

    I was hoping for some simple instructions.

    Can anyone point me in the right direction?

    Advertisement
  2. phidelt82

    phidelt82 Member


    go to the market and download z4root. it's the simplest way to root the mesmerize that i've found. if it hangs up for more than a couple of minutes, which i've heard of but not seen, pull the battery and run the program again. it worked the first time on mine, though.
  3. drummerboy42

    drummerboy42 New Member

    That worked for me too. I have root, but now what? I haven't found a recovery yet because clockwork only has the Fascinate listed for the i500. Obviously having Bing installed, its different than the Mesmerize. Try it out on your Mez and let me know how it went. :D
  4. broberts

    broberts New Member

    Thanks for the quick reply.

    I don't have the phone yet, I'm waiting for the Black Friday sale.

    my goal is to do wi-fi or bluetoth teathering.
  5. tkoden

    tkoden Member

    I have only had my samsung for a few days so I am a complete noob, but whats the advantage of rooting? Aren't these platforms pretty open already? I jailbroke my iphone because it was locked down tighter than a nun but don't understand why you would need to do it for an android phone. I am also in the market for wi-fi tethering as so far that's the only think this phone can't yet do that my iphone could.
  6. phidelt82

    phidelt82 Member


    Wifi Modem is pre-installed on the Mesmerize to do wi-fi tethering. It's a quick and easy setup. I did it driving down the hiway (no I didn't mr. officer) lol....

    As for Android being a pretty open platform that is yes and no. Android itself is. Each company building a phone locks down their particular ROM to some extent as a safety precaution basically. As for how locked down each phone is, it's different for most types.

    Anyway, rooting isn't for everyone. The advantages are different for each person. So far, for me, the only advantages have been that I've been able to install apps that need root access, and being able to dig around in the files to see what things look like on the inside. There are no custom ROMs or recoveries yet, but hopefully they are on the way.

    Hopefully this helped you a little.
  7. Tonitz

    Tonitz Active Member

    You have to enable USB debugging to get the app to root the phone, but should you turn debugging off immediately after rooting the phone?
  8. androidphiltn

    androidphiltn Active Member

    @ phidelt82... I notice you are using the stock wireless modem feature on the phone. I would be interesting to see if us cellular charges you that extra $25-$30 a month for use of that feature. I have a work around if they do... I didn't really want to chance the extra charges, so I am using the wireless tether for root users that is in the market... Flawlessly. Look at my post on the main page to see. AndroidPhil's Mesmerize Thread. Anyway, let us know if you have any surprises on your bill. Hopefully not...
  9. phidelt82

    phidelt82 Member


    I won't have any surprises on my bill for two reasons. First, USCC isn't going to charge you for using an app that is on the phone from the factory. This has already been stated elsewhere, if I remember correctly. I've also seen the app posted on the USCC intraweb pages, so it's known that it's there and what it does. Just don't go over your cap and you're ok. Second, I'm a field tech for USCC so my bill is quite a bit different than a regular customer's bill. Since mine is mainly for business use, it's subsidized.

    My suggestion is, use what works for you. I chose to root the minute I pulled my phone out of the box so that I could use my phone the way that I want. There are some people that will say using tethering apps is stealing service. Personally, I feel that since the Mesmerize already has a tethering app on it, you are still fine if you choose to use another app because of your preferences.
  10. androidphiltn

    androidphiltn Active Member

    I really don't know for sure... Have had two different answers from two different uscc reps. Lol. Just using a different app untill I Know for sure. I'm just a regular customer. :)
  11. ladybadger2007

    ladybadger2007 Well-Known Member

    Ok I got a phone replacement today and I can't find z4root in the market now. It was there yesterday aaaahhhh someone help. The only one in there has crazy asian symbols
  12. androidphiltn

    androidphiltn Active Member

    100% WRONG - Just ask a Verizon customer if they dare to use the built in "hot spot" feature on some of there phones.

    I'm sure it is... Think you may be the only one on here who's phone bill is paid for by USCC. Therefore, why would you tell people that they won't be charged???

    Look... All I'm saying is... Built in wireless tether is 100000000% NOT A FREE SERVICE. So, don't pretend it is. And, just because your phone has a feature "built-in"... Doesn't mean it's "free"...user beware.:cool:
  13. phidelt82

    phidelt82 Member

    First off, I don't really know what Verizon has to do with a USCC app. Secondly, I don't make a dime off of giving anyone advice on what apps to use or not use, and I said my bill is subsidized, not paid for. My bill is still $60 every month, and I don't get the luxury of cheap or phones. I pay full price for my phones so that I can carry what the customer carries so when they have questions or I get a trouble ticket I have some knowledge about them.

    Like I said in my previous post, use what works for you. If you're worried that you'll get charged for using what's on the phone already and you choose to use something else to circumvent the system, that's fine. It doesn't affect my pay. I'm just saying that from what I understand from talking to the people that I know, that the app on the phone doesn't sign you up for the tethering service that USCC charges you for. I'm also not a sales person. I'm a Field Engineer and have been for the past 14 years. I get paid to make sure you have the service to use your phone, not to sell you the features and definitely not to con you into using something that's going to charge you extra money every month.

    -Just to check with a higher source, I called a supervisor in the CS dept. She said that the tethering feature isn't supposed to work until you activate it with the company. She also said that if the app works already, the only way that they can tell if you are tethering is by "excessive" usage. So if you don't go over your cap, they can't tell/don't care. Also, no matter what app you use, if you do go over your cap, they will assume that you are tethering anyway.
    Zebulon, LaTuFu and cwe909 like this.
  14. cwe909

    cwe909 Member

    sing it brother. stupid me i thought the wi-fi option was for what i now know is tethering . my bad. but anyhow i did the wifi linked to my encrypted wifi setup in my house. i thought this was to access internet in house. but i saw my home computer name popped up. is this to access my other computers on my network or to access internet? and i will accept a reasonable duhhhhhh!
  15. BoppinMidge

    BoppinMidge Active Member

    yeah im on my third mesmerize, and i just got it today and went to get 4 and its... not there. not even the asian one. i found it on xda forums but my phone cant download a file of the type (its an apk, wtf, i sshould be able to download that, yes?)
  16. BoppinMidge

    BoppinMidge Active Member

    well ok, it wont download it from xda for some reason, so i emailed it to myself and now it worked. rooting <3
  17. hxadecmel

    hxadecmel New Member

    Hi all, great thread, just want to double check something. When i went-a-hunting for the z4root.apk, i found it, and many references to how easy it was to use it to root your Fascinate with Froyo. Are there more than one version of z4root? I dont have a lot of interest in risking a 2.2. upgrade, i will just wait with the rest of the world for US "Snaillular*" to release Froyo. Can anyone email me the version that they have seen work on a 2.1 Mesmerize? Thanks a bunch! I also have some other general questions.


    1) I just got this beauty of a phone, and i am concerned that if i have a hardware issue, and i send it in to Samsung, they will not honor the warranty because i messed with the software (even though rooting the phone to remove some bloatware and use titanium seems extremely unlikely to cause hardware failure). Is there a way to "Un-Root" it in case i need to send it in? Also, will this z4root do a temporary, or permanent root?

    2) did anyone get the LED to work? I tried "NoLED" and a couple other apps but they do not do what i want.

    3) anyone figure out how to get the annoying "Roaming" beep to stop?

    * I can hate on USCC, i been a customer for 10 years, and i worked for them for a long while. They are the best around, but i have to give them a jab in the ribs for taking sooooooo long with 2.2, especially when they just released an LG with Froyo, and have the Galaxy tab shipping with Froyo. I mean heck, a guy at my work came in with a (heavily modified) iPhone 3GS running 2.2, just to get me mad :)
  18. androidphiltn

    androidphiltn Active Member

    z4root can also unroot if you want. And yeah, 2.2 will be nice, but this phone has more than enough internal memory to get ya through. Froyo will be here soon enough. Doesn't bother me and I'm a huge Android freak. Lol.
  19. Gigglephart

    Gigglephart Member

    Z4Root Is One Click Root App For Samsung Galaxy S / Android Phones

    I just did mine with instructions from this site.
    Gave me a little scare it did as I installed and ran it, it seemed to have hung and thought the worst for a minute. Could not turn phone off so did a battery pull and it booted back fine.

    Ran again and

    I can now has RooT. (Sorry for the lolcat reference just seemed appropriate.)

    Will be installing a BACKUP TOOL immediately and getting a image.. BRING ON THE ROMS ..
  20. Vader01

    Vader01 Member

    I tried rooting my Mez the other day using the link above and Z4root. It kept hanging up on me. Had to do several battery pulls, and it ended up not working. Not sure what else to try? Any help would be great,
  21. Vader01

    Vader01 Member

    Thanks, I will definitely give this a try
  22. LaTuFu

    LaTuFu Well-Known Member Contributor

    It didn't work for me, but I am fairly confident I am not doing something properly. I will update once I complete the process successfully.
  23. Vader01

    Vader01 Member

    I'll also post after I give it a try to let you know how it goes
  24. LaTuFu

    LaTuFu Well-Known Member Contributor

    I have tried super one click and z4root, both to no avail. I'm not saying they don't work, but I will say that the threads I used that said "follow these steps exactly" definitely didn't work for me.

Share This Page