Any news on root for the Stratosphere?


  1. SolidOrange

    SolidOrange Well-Known Member

    My roommate just picked one of these up and is dieing to get rid of the VZ bloatware. I saw that the GS2 was finally rooted today, and was wondering if there is any progress being made on the stratosphere. I know it will be awhile for custom ROMs, but rooting for battery life alone would be worth it; it helped my thunderbolt deal with the 4G drain tremendously.

    Advertisement
    :
  2. darthbubba

    darthbubba New Member

    Not that I've been able to find. Considering that this phone is basically a Fascinate with 4G and a keyboard, I'm a little surprised and disappointed that no progress has been made.

    I'm told that this phone has a new bootloader that has thrown everyone for a loop. I don't know how different it is from the one in the Fascinate or Droid Charge, but apparently it's a big enough difference to break all the common rooting methods out there.
    SolidOrange likes this.
  3. KnightCrusader

    KnightCrusader Well-Known Member

    I'm not a dev, but I am working on giving it a shot. There are a few angles I am looking at based on the kernel source being available to us. I have been trying to contact some of the people that know some about how the SG2 was rooted and see if I can adapt those methods for this phone, since the bootloaders seem to be similar.

    If I figure out anything, I'll make sure to let the world know. :)
  4. KnightCrusader

    KnightCrusader Well-Known Member

    I got root! (with support from the Droid Charge irc channel)

    I'll be posting howto's tomorrow, after I get some rest. Never knew building a kernel could be so tiring! :)
    darthbubba, p_025 and wewantutopia like this.
  5. Johnny Langton

    Johnny Langton Well-Known Member

    Excellent news!
    JL
  6. KnightCrusader

    KnightCrusader Well-Known Member

    SolidOrange likes this.
  7. SolidOrange

    SolidOrange Well-Known Member

  8. p_025

    p_025 Well-Known Member

    Oh wow, that's good news. Did you get busybox on there too?

    EDIT: Stupid question. Well, is this going to be the only way to root the phone, to use a custom kernel? That's not at all how it was for my poor Moto Devour…
  9. KnightCrusader

    KnightCrusader Well-Known Member

    I included it in the zip download, and you can push it to the system when you root it if you want.

    The root is not "automatic" yet, as in, su and busybox baked into the kernel itself. I haven't gotten that far, but its on my list for the next kernel I cook up. I just wanted to give people a straight up stock kernel that just has the flag set to insecure and let them do as they wish with it. :)
  10. darthbubba

    darthbubba New Member

    You can also get busybox from the market.

    This is great news! One giant step towards CM7 for the Stratosphere!! :)
  11. Maximillian

    Maximillian Member

    Fellow Rooters,

    I am unable to get around this problem in Win7 Ultimate x64, when trying to run the "heimdall flash --kernel flashfile" command. The preceding "detect" command comes back "Device detected", but when I run the command to flash, I get the following.

    Initialising connection...
    Detecting device...
    ERROR: Failed to access device. libusb error: -12

    Someone else in another forum where you posted your steps also complained about this -12 error, but I couldn't find any replies to that person's post. I cannot for the life of me find any reference to a -12 error for libusb... the closest I can get is a list of the libusb_error enum values at libusb: Miscellaneous, but there are no codes associated. If I count the error list starting at 1, however, then 12 would be "LIBUSB_ERROR_NOT_SUPPORTED", meaning "Operation not supported or unimplemented on this platform." Has anyone successfully rooted a Samsung Stratosphere (or any Samsung device) yet using heimdall on Win7 x64?

    I wanted to try odin, but I can't find instructions on how to properly do the flash with odin instead of heimdall. Does anyone either a) know this error and how to get around it, or b) know how to use odin instead of heimdall to root the Stratosphere? Thanks!

    Regards,

    Maximillian C.
  12. KnightCrusader

    KnightCrusader Well-Known Member

    I have used my workstation at work to flash images using heimdall, and its Win7 Pro x64 and it works fine. The only thing I remember that was weird about it was it wouldn't take the driver installation the first time I tried it. Then I rebooted the machine, tried to install the driver again, and it took. I had to restart the computer a few times and replug the phone a few times too. It was really odd, but after it finally said it was installed, everything worked fine.
  13. p_025

    p_025 Well-Known Member

    Yeah, one very important thing is to make sure you've installed the drivers and ADB is also working properly. If ADB won't work or gives a similar error then it's probably a driver problem, but that's if Heimdall uses the same drivers ADB does.
  14. KnightCrusader

    KnightCrusader Well-Known Member

    Actually it does not, download mode has its own USB "device" that Windows sees separately.

    The Windows version of heimdall comes with the driver package bundled with it in the driver/ directory. You have to run the exe file in there while the phone is connected and in download mode, and it will give a list of USB devices (sometimes you have to go in the menu and select 'Show All Devices') and you make sure 'Gadget Serial' is selected and click install.

    When your phone boots up normally, it will show back up as a regular android device and adb will work.
  15. dcooterfrog

    dcooterfrog Well-Known Member

    I had the same problem.
    I powered down the phone
    rebooted powered down again
    reentered down load mode
    reinstalled the zadig grivers with gadget serial (after showing all devices in zdig)
    and redid the guide. this time it worked.
    Maximillian likes this.
  16. KnightCrusader

    KnightCrusader Well-Known Member

    Yeah a couple of reboots are required for both devices. Its wacky but it will work eventually.
    Maximillian likes this.
  17. Maximillian

    Maximillian Member

    Thanks, you guys! You were exactly right! I think I had just mistakenly not installed the driver properly the first time around. I hadn't seen the "libusb devices" node in the Device Manager until I repeated the "install drivers" process just now. Looks like the root worked! My backup program successfully got root privileges. Thanks again!!
  18. jmar

    jmar Nexican VIP Member

    Can't get this script through heilman to work. Getting the same libusb error, too. Multiple reboots haven't helped. ADB and drivers seem to be fine. What am I missing?

    jmar
  19. Maximillian

    Maximillian Member

    JMar,

    Have you checked in Windows Device Manager to see if the "libusb devices" node exists? If not, try re-installing the drivers. That's what worked for me.

  20. jmar

    jmar Nexican VIP Member


    It doesn't exsist. And now when I try to reinstall the drivers, after selecting view all devices, the Google gadget drivers don't appear. It shows android USB modem and unknown device???
  21. icebear8

    icebear8 Active Member

    hey guys i just got my strat today and been trying to root it alll day and i cant get it to work so far i have went thru download mod and install that image file and now im at the part where i need to push the super user, busybox and su over cmd

    i put my phone in usb debug mode and then went into cmd and copy and paste and used this command F:\Downloads\heimdall-suite-1.3.1-win32>adb devices

    and every time i hit enter it keeps saying device is not ready sooo that is where i am stuck at

    i downloaded android sdk, and let it download the google usb drivers and still nothing

    and i know the image that i put on installed right because i get the little yellow ! under the samsung logo on boot

    im running windows 7 64bit
  22. icebear8

    icebear8 Active Member

    i tried to follow this guide http://androidforums.com/evo-4g-tips-tricks/90418-how-install-android-sdk.html in order to set up the path to sdk but when i go into environment varibles it only list 2 things temp and tmp, there is no path so far i installed android sdk and let it install all those updates and then went back to cmd to see if F:\Downloads\heimdall-suite-1.3.1-win32>adb devices would work yet and still says device not ready sooo im still lost on this
  23. icebear8

    icebear8 Active Member

    anyone?
  24. icebear8

    icebear8 Active Member

    redid the WHOLE walkthrough went and reinstalled adk, and re doing the kernel file to the phone and now im back at the same part but now i get this, there is no disk in the drive please insert a disk into the drive /device/harddisk2/DR2.

    and all i get is cancel try again and continue and when i do it again its the same thing..... it seems this is just a simple thing but being stupid
  25. jmar

    jmar Nexican VIP Member

    I have been having different problems. Keep getting a libusb error. It was addressed in an earlier post by other users but I can't get past it.
Loading...

Share This Page