Anybody Out There??General


  1. GreyCelt

    GreyCelt Well-Known Member

    Has anyone gotten they're hot little hands on one of these numbers yet? I ordered one for my wife to replace her aging and ailing VM Blackberry and it's supposed to arrive on 03/22.

    I'm happy to see that the Site Admins here started a section for it already and it gives me some hope that the great Devs here will support this phone!

    Advertisement
    :
  2. lizm

    lizm Well-Known Member

    I am debating this vs. Intercept for my son's birthday.
  3. GreyCelt

    GreyCelt Well-Known Member

    I would stay far far away from the Intercept! I had that phone for about a year and it was nothing but headaches! Spec-wise, the Venture doesn't look much better than the Intercept but the Intercept is only running stock Froyo and the Venture is running Gingerbread. The Venture has yet to prove itself as a good device but the Intercept has definitely proven itself to be a horrible device, in my opinion anyway.
  4. GreyCelt

    GreyCelt Well-Known Member

    Oh! We got my wife's Venture on the 21st and she has been playing with it trying to figure out how to do stuff. She came from a BlackBerry so the OS is completely different. So far she likes it. I messed with it a bit and it's OK. I didn't experience any major flaws or problems. The screen isn't great but I've seen a lot worse. I watched about 5 minutes of a movie on Netflix and the screen was a little jumpy here and there but it played the movie with sound no problem. I haven't tried taking pics or video yet.
    As far as rooting, I am BY FAR no expert here but I tried z4root temp root and the app just force closes and won't re-open unless I re-booted the phone. I took that as a "does not work" and uninstalled it. Coming from the MotoTriumph, I thought I would see if we were lucky and try the su command in Terminal Emulator and also a no go. So, someone that actually knows something will have to step-up and see if they can figure it out.
  5. b_randon14

    b_randon14 Well-Known Member Developer

    Try gingerbreak. It should get you rooted. I'm waiting to buy my wife one as soon as its in stock. But uid say gingerbreak should root it. But a custom recovery is what is needed for serious Modding so if you mess up its easy to fix. Depending on how the internal memory is setup, it may not be too hard to make a recovery. Hopefully the bootloader is unlocked so we can get a recovery on there!
  6. GreyCelt

    GreyCelt Well-Known Member

    Hey b_randon! Good to hear from you! I was over on the SDX forums for the Intercept if you remember me. I'll try gingerbreak tomorrow when I get some sleep after work (I work nights). I didn't have a lot of time yesterday before I had to be at work so I was just trying some quick methods that I knew.
    I'm gonna spend some more time with the phone over the weekend too so I can get a better idea of how well or how bad it works.
    Good to see you on here b_randon. Hopfully you'll get one for your wife and give us a little taste of some dev work for it...if she let's you get your hands on it!:p
  7. GreyCelt

    GreyCelt Well-Known Member

    Hey b_randon, is there an easy way for a non-dev such as myself to figure out if the bootloader is locked or not?

    Also, Gingerbreak doesn't work. The Venture is running 2.3.5 and the only Gingerbreak I found over on XDA was version 1.2 which doesn't work on anything higher than 2.3.3. Is there another Gingerbreak out there that you know of that will work with 2.3.5?
  8. b_randon14

    b_randon14 Well-Known Member Developer

    Not that I know of. I'll have to look into it. And I don't know really. On the Triumph it was easy but I would have to play around with the Venutre because I don't know how it is set up at all, what filesystems it uses, the partition structure, etc.
  9. AlexJGonzalez

    AlexJGonzalez Member

    Would be cool if someone were able to root it. I myself have a venture. And a few other people have it as well. My triumph screen got smashed after a few hits. Lol gorilla glass helped a few times before its leap of faith.
    GreyCelt likes this.
  10. GreyCelt

    GreyCelt Well-Known Member

    Yes, please someone figure out how to root this phone so we can at least get rid of the bloatware!
  11. b_randon14

    b_randon14 Well-Known Member Developer

    I'm going to try a newer root exploit called zergRush. It will only give me shell root through advanced, but then I can mount system as read/write and copy over su and superuser.apk then ill have root. Should be able to try it this weekend hopefully!
  12. GreyCelt

    GreyCelt Well-Known Member

    Sounds great! Let me know how that goes. Do you just push those over using ABD or what?
  13. b_randon14

    b_randon14 Well-Known Member Developer

    Yeah you can push zergrush to /data/local/tmp and chmod it to 0755, then exectue it. If it works you should have root and then you can rempunt system with read write access and push su to system/bin and symlink it to system/xbin then push superuser.apk to /system/app amd you should be rooted!
  14. GreyCelt

    GreyCelt Well-Known Member

    Could I use terminal emulator or would it need to be through ABD?

    So would I just type the command: chmod 0755 zergrush
    and hit enter?

    Sorry, I haven't worked with ABD that much and it was waaaayyy back when I rooted the Intercept o_O and I think I've blacked-out most of that nightmare from my memory.
  15. b_randon14

    b_randon14 Well-Known Member Developer

    First you would need to copy the file to data/local/tmp.
    I'm not sure if it works through the terminal emulator. To try it that way do this:

    Have the zergrush binary on the root of your sdcard, along with the su binary and superuser.apk and busybox. You can get all those files out of my latest bROM zip.

    After that open up a terminal on the phone and type:

    cp /sdcard/zergRush /data/local/tmp/zergRush

    Then type:
    chmod 0755 /data/local/tmp/zergRush

    That will give the file the permission to execute.

    Then type:

    /data/local/tmp/zergRush

    And that will execute the file. If it works it should tell you it worked a d you should have root(a# should be there instead of a $)

    Then if you have root you need to: mount -o remount,rw /dev/block/mtdblock1 /system

    Then type:
    cp /sdcard/su /system/bin/su
    cp /sdcard/Superuser.apk /system/app/Superuser.apk

    Then:
    ln -s /system/bin/su /system/xbin/su
    chmod 06755 /system/bin/su
    chmod 0644 /system/app/Superuser.apk

    Then you should be rooted perminently!
    GreyCelt likes this.
  16. GreyCelt

    GreyCelt Well-Known Member

    Thanks! I'll try that in the next couple of days. Now we just need someone to build a CWM Recovery for this phone.
  17. b_randon14

    b_randon14 Well-Known Member Developer

    Yeah I'm gonna see what I can do. I AI t promising nothing but I have read alot of guides and I may be able to get one working! Just need to get it rooted first. Have you got adb to pick it up on windows?
  18. AlexJGonzalez

    AlexJGonzalez Member

    I have a Mac I'd like to try it out if it works. Btw I'm a noob so help would be great.
  19. markzombie82

    markzombie82 Well-Known Member

    I just posted in an other thread did this work with nothing but a terminal emulater? Eazy root would be a plus. Also unrelated would running zurg rush on your htc wfs FROM THE PHONE ONLY work im in a hard spot with the wfs and i could still jump ship.
  20. edthebear

    edthebear Member

    It doesn't work. I got ADB to work on a Linux box - if there are drivers for Windows, I haven't found them and I've googled like crazy - and I ran Zergrush. It failed.
  21. varenHjames

    varenHjames Well-Known Member

  22. divinebovine

    divinebovine Well-Known Member Contributor

    Since this thread is already bumped, and I saw it in google results before while looking for ADB drivers for Windows...
    ...installing PDANet provides the necessary drivers.
Loading...

Share This Page