Anyone else have their external SD unexpectedly dismount?


Last Updated:

  1. baddress

    baddress Well-Known Member This Topic's Starter

    Joined:
    Jul 23, 2010
    Messages:
    202
    Likes Received:
    20
    This has happened to me twice now. I get a red warning triangle that the external SD has dismounted itself improperly. I take off the back of the phone, and sure enough, the microSD is most of the way out of the slot like it got ejected. I push it back in and all is well. And I only have to push it in once. The slot actually ejected the card like something tripped the spring in there. Anyone have this happen?
     

    Advertisement
  2. TDQuiksilver

    TDQuiksilver Well-Known Member

    Joined:
    Jul 15, 2010
    Messages:
    185
    Likes Received:
    16
    Mine seats perfectly. Haven't had it pop out. Continue to monitor it over the next few days. Could be a mechanical issue with the holding pin that snaps it in place when pressed. If it continues - exchange it.
     
  3. baddress

    baddress Well-Known Member This Topic's Starter

    Joined:
    Jul 23, 2010
    Messages:
    202
    Likes Received:
    20
    LOL - I'm already on my fourth phone. If I exchange any more of these lemons they'll have to add another assembly line to the factory.
     
  4. Chromag

    Chromag Well-Known Member

    Joined:
    Jul 20, 2010
    Messages:
    149
    Likes Received:
    6
    Perhaps you didn't seat the card properly. I've never had this problem.
     
  5. Jiggles

    Jiggles Member

    Joined:
    Jul 31, 2010
    Messages:
    24
    Likes Received:
    0
    Remember that the card inserts with a spring. Push in and it clicks, push it again and it comes out. Make sure you're pushing it in all the way.

    Sounds like maybe your spring is jacked or the piece of plastic is broken
     
  6. omgitsoop

    omgitsoop Well-Known Member

    Joined:
    Aug 2, 2010
    Messages:
    47
    Likes Received:
    3
    i do the push in push out click and everything, but lately ive been getting a "unable to mount sd card" when i insert it. ive mounted many an sd card, i know what im doing, funny thing is if i reboot my phone, it seems fine. :(
     
  7. gump

    gump New Member

    Joined:
    Dec 20, 2010
    Messages:
    1
    Likes Received:
    0
    I'm getting the same error. SD Card unexpectedly removed, even when the phone is sitting on my desk, doing nothing.
    The card is and mechanism is fine.
    I even replaced the card, based on what I saw in another thread, and that seemed to work for a week, but now the problem is back.
    I also get a warning about the card needing to be formatted, which I do, but the error comes back.:mad:
    Frustrating. I am worried that I might lose my pictures.
     

Share This Page

Loading...