1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

Anyone else having GPS issues since Gingerbread?


  1. Vinny454

    Vinny454 Member

    My GPS worked ok with Eclaire and actually performed even better with Froyo. Ever since I upgraded both mine and my wifes phone to Gingerbread, I can't seem to get a GPS lock any more on either phone. I went to check all of the settings, but the #*#* code does nothing now. Anyone else having similar issues?

    Advertisement
  2. Crimson13

    Crimson13 Well-Known Member

    Which phone do you have?
  3. Vinny454

    Vinny454 Member

    Sorry, I am so used to being in the Samsung Captivate forum, which BTW is my phone.
  4. Crimson13

    Crimson13 Well-Known Member

    After updating my wife's captivate (a painful processes itself thanks to kies) she hasn't reported any GPS issues. I'll make a point if asking her tonight.
  5. jimrebello

    jimrebello Well-Known Member

    I updated mine and had GPS issues as well. Factory reset fixed it for a few days, but then it came back. Called Rogers and was told if Factory Reset doesn't fix it, then I have to put it in for service, so I did that.

    Something tells me this is a firmware issue, not hardware, but either way, if it comes back from repairs and it's working, I won't complain.

    Really sucks because Gingerbread was such a huge improvement for me in most other areas, but I use the GPS daily, and can't put up with it malfunctioning.

    Someone on the Rogers Community forums claimed Samsung is aware of the issue and will issue a software update to fix, but when I asked Rogers, they said no such update is planned. (not that you can trust either of them)
  6. Vinny454

    Vinny454 Member

    UPDATE:

    I bit the bullet and did a factory reset on both mine and my wifes phone over the weekend. As of today, the GPS is working on both phones again. Actually the whole phone in itself is working better. Just like a good old fashion quarterly format I used to do on my old Win 98 machine when it started to slow down.
  7. jimrebello

    jimrebello Well-Known Member

    Keep us updated if it continues to work. Mine worked for about a week. After that, Factory Reset didn't fix it again. I also didn't plan on doing a reset every other week.

    Thanks
  8. outcastrc

    outcastrc Well-Known Member

    Mines terrible after the update... It can see them but it has a heck of a time locking on to them. I have never had a issue before and now I can get 1/2 way to work before an app does something... :mad:

    For all the things that make this upgrade worth it, there's some issues with this update that drives me nuts. :(
  9. jimrebello

    jimrebello Well-Known Member

    I sent mine for repairs and had the mainboard replaced, GPS works fine now.

    However, I have the official captivate car dock and since updating the audio out doesn't work anymore. I contacted samsung and they told me that I'm SOL unless they decide to do a further update.
  10. outcastrc

    outcastrc Well-Known Member

    Last time I called them I was told Samsung Canada didn't carry nor support the docks.
  11. jimrebello

    jimrebello Well-Known Member

    Yes, that's what I was told too, it's a US product. But regardless, it's the same phone.

    Hopefully we'll see another Firmware update, if not, my warranty is up in January anyway so I might just try to root and put a custom ROM that will actually work on it.
  12. Vinny454

    Vinny454 Member

    It's been a couple of weeks and it still works. It locked on very fast with Froyo, and actually it locked on in 5 sec immediately after the reset. Now it takes about 30-45 sec and I have had a few times where it wouldn't lock on at all. I don't know if i am going to bother sending it in. I have a stand alone GPS and really don't use the phone one that often. I have a a little more than a week worth of warranty, so I have to make a decision quick.
  13. jimrebello

    jimrebello Well-Known Member

    Yours sounds about normal. Mine was taking 30-45 Minutes to lock on. I have found if it won't lock, sometimes running GPSTest and updating aGPS in there fixes it.

    Sending it for repairs is a pain in the ass, take like 2-3 weeks to get it back. But you get a 90 day warranty on the repair..

Share This Page