Anyone else's browser crash 20+ times a day on Evil Eris?


Last Updated:

  1. NotThe1YerLookN4

    NotThe1YerLookN4 Well-Known Member This Topic's Starter

    Joined:
    Dec 28, 2009
    Messages:
    49
    Likes Received:
    0
    This is an improvement?
     

    Advertisement
  2. erisuser1

    erisuser1 Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    1,644
    Likes Received:
    759
    I'm not sure what the genealogy of the different browsers in different ROMs are (and you didn't say *which* EE you were using), but I came to expect that the stock browser in both the HTC 1.5 and 2.1 official releases would crash on me at least that many times per day if I was using it heavily.

    So, I would say that that is no worse than the stock browser.

    I will say, though, that I was very surprised by the browser in Aloysius V12 - I used pretty much the same sort of browsing habits (same sites, same impatience with clicking on links or resizing before pages are fully loaded), and I can't remember it crashing on me even a single time. Aloysius is a Sprint-derived ROM iirc.

    Right now I'm giving tazzpatriot's CM6/Froyo/ "V5" ROM a spin - it's browser seems noticeably faster at page rendering, but it is too soon to know whether it is as stable - but no crashes after a pretty full day of using it.

    So, anyway, YMMV with different ROMs; but I can't imagine that the browsers in any of the dev ROMs are worse than the one that was in the stock HTC OS (either 1.5 or 2.1)

    There was someone on this forum that hypothesized that disabling flash solved all of his browser crash problems (on OTA-2.1 pre July) - I tried that but it made no difference in the way that I was crashing the browser, so I disregarded it.

    Sorry I'm not more help.

    eu1
     
  3. NotThe1YerLookN4

    NotThe1YerLookN4 Well-Known Member This Topic's Starter

    Joined:
    Dec 28, 2009
    Messages:
    49
    Likes Received:
    0
    Its using EE3.0 and the browser crashes way way more than it did stock. Pretty much everytime I use it in fact.
     
  4. micronut

    micronut Member

    Joined:
    Jan 4, 2010
    Messages:
    24
    Likes Received:
    0
    Mine too. Ever since 2.1 ota, my browser crashes every single time I use it. Usually within 5 minutes. Never happened before 2.1.

    Dolphin browser works fine, but I am used to stock and don't like dolphin.

    Also, extreme lag in every last function of every app. I hate this pos. I threw it against the wall today because I was so frustrated with the browser. I was disappointed that it didn't break.:(
     
  5. Hypo Luxa

    Hypo Luxa Well-Known Member

    Joined:
    May 12, 2010
    Messages:
    464
    Likes Received:
    32
    I assume your not rooted nor OC? Rooting and OCing would fix that for you
     
  6. dirtmouth

    dirtmouth Well-Known Member

    Joined:
    Feb 14, 2010
    Messages:
    361
    Likes Received:
    6
    same here, but mms works
     
  7. micronut

    micronut Member

    Joined:
    Jan 4, 2010
    Messages:
    24
    Likes Received:
    0
    I apologize, but I'm not sure what rooted or OC means. I guess I'll look around. Frankly, I'm afraid to try anything because of the countless problems I've had with this thing.
     
  8. erisuser1

    erisuser1 Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    1,644
    Likes Received:
    759
    It's an inanimate object. It doesn't care what you think, and is unlikely to be impressed by, or improved upon, by smashing it into a wall.

    Reading the thread in which you posted, and attempting to understand the implications, might however improve the behavior of the inanimate object.

    Might.


    eu1
     
  9. NotThe1YerLookN4

    NotThe1YerLookN4 Well-Known Member This Topic's Starter

    Joined:
    Dec 28, 2009
    Messages:
    49
    Likes Received:
    0
    Man this sucks the browser crashes almost every time i open it now.
     
  10. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Joined:
    Jan 19, 2010
    Messages:
    22,479
    Likes Received:
    9,225
    Why keep an app that crashes?

    If you otherwise like the ROM, perhaps Dolphin or Opera? ;)

    I'm puzzled by reports of browser crashes.. but I admit to never going back to EE after a bad experience with it at version 3, my second ROM after rooting a few months ago. That bad experience was a shocker to me, being new to rooting; it was slow.. slower than 1.5 or 2.1 OTA, not to mention force closes in the menus all day.

    Anyway, the only browser anomaly I've noticed since the EE days has been the occasional force close while using the bookmarks in one of the Froyos, and I can't remember which one, although I know it was one of the earlier ones.
     
  11. doogald

    doogald Guides Guide

    Joined:
    Jan 7, 2010
    Messages:
    6,620
    Likes Received:
    1,896
    I've read that turning off location services in the browser helps with FCs on the HTC browser. You may also want to clear cache.
     
  12. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Joined:
    Jan 19, 2010
    Messages:
    22,479
    Likes Received:
    9,225
    Those sorts of remedies irk me in a way. We should not have to disable stock features of our device in an effort to make other stock feature function as they are intended to function.

    I'm all for temporary work-arounds, but failing a permanent solution, it may be time to move on to another ROM.
     
  13. NotThe1YerLookN4

    NotThe1YerLookN4 Well-Known Member This Topic's Starter

    Joined:
    Dec 28, 2009
    Messages:
    49
    Likes Received:
    0
    Ok so now I installed the Dolphin Browser and this one refuses to load webpages when I click on a link in an email. When I do it goes to the browser but just sits there with the current page loaded in it. :confused:
     
  14. doogald

    doogald Guides Guide

    Joined:
    Jan 7, 2010
    Messages:
    6,620
    Likes Received:
    1,896
    I agree, but this is apparently as issue in the stock HTC browser app. It used to always FC for me on first run after running a while, both stock and in xtrROM, and it stopped doing so when I turned off location. The good thing about it is that it is a setting - if you need location at a particular time, you can always turn it back on in settings and proceed.

    Dolphin and xScope never had this problem, but, unfortunately - and this is a very minor unfortunately - they use their own bookmarks and it's hard to use other apps that manage bookmarks to manage them.
     

Share This Page

Loading...