1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

apk files as zip files?Support

Last Updated:

  1. I'm trying to download the SMS app from XDA and the guy has it up as a zip file. I download it and extract it, and it's a folder with random crap in it. No apk.

    Then I read that I just change the file name. I'm on a Mac, so I change the filename and it verifies if I want to change it from .zip to .apk and I say "yes." Put it on my card and Astro still doesn't recognize it. It's list, but it's an icon with a window and a gear in front of it.

    I installed the Vanilla email app, no problem. Not sure what the deal is with this one.

    dariush86 likes this.
  2. cableguynoe

    cableguynoe Well-Known Member

    Keep it as zip and open it with Astro.
    Don't extract it. Just put it on the card.

    ... i think
    smacky likes this.
  3. andrizoid

    andrizoid Well-Known Member

    im also i=on a mac and have had this issue. put it on your sd card as a zip, then use astro to change the name to .apk instead of .zip

    that alsways has worked for me
    smacky likes this.
  4. erisuser1

    erisuser1 Well-Known Member

    .apk files are (java) .jar files which are actually .zip archives. The fact that they are named ".apk" reflects the fact that they always contain certain folders and files (including, but not limited to the manifest signature files and public key of the signer) - not "random crap"

    Take one of your other .apk files from a different app, and rename it with a .zip extension (on your mac) and unpack it and see if "random crap" from the first one looks anything like the "random crap" from a known app. A valid app will contain folders named META-INF (always), res (usually), and some files with extensions of either .dex or .odex. The latter ones are the Java code which have been "compiled" for running by the dalvik engine on the phone.

    I know this doesn't solve your problem, but at least it will give you a clue if things are wildly wrong with the original .zip file. (Also, there is the option of running the logger from the SDK while you attempt to do the .apk install - the logger might show you some more detail on any errors that are thrown.)

    I suppose you've toggled the Settings...Applications...Unknown sources to On already.

    I haven't used Astro for non-market installs (EStrongs File Explorer works, though).

    smacky likes this.
  5. Thanks for the replies, guys. That meta-inf file is there. I dunno why I keep opening files to see the same icon over again.

    Would one of you go to xda and see the sms app there and see if it's giving you the same issue? The OP never responded to people's questions, similar to mine, about the zip apk issue.

    Or post the damn apk. :D. I dunno why people post it like this.....
  6. andrizoid

    andrizoid Well-Known Member

    post up the link and ill gladly try and get it working for you
    if nothing else i can always extract it, repackage and resign it and post it up
  7. Sure man. Hope it freaking works this time. I've always wanted the little icon, and I wanna see what the app is like.

    xda-developers - View Single Post - Could Someone....

    Renaming it does not work.
  8. Papadroid

    Papadroid VIP Member VIP Member

    I believe all you have to do is put it on your sd card and rename the file. From the link you provided the name is SMS.apk.zip. When you rename it just delete the .zip and you should be fine.

  9. I have tried that. Renaming on the computer and then putting it on there, renaming using ASTRO. Renaming simply won't work.

    Third party apps installation is enabled. It's always been enabled. I've been installing betas and such since I got the phone.

    This is just the first time I have ever seen labeled as a zip file. I realize people can't post apks in some places, but....this is kinda dumb.

    Andrizoid, let me know how it goes. ;)
  10. Messed around with it for a bit more. Still nothing. Andrizoid, can you just make it into an .apk instead of just renaming it, please?
  11. Papadroid

    Papadroid VIP Member VIP Member

    Yeah I tried just about everything I could do and it won't install.
  12. That sucks. I was really looking forward to using it. :(
  13. I hope Andrizoid isn't passed out from recent ganj episode. :(
    hattrick likes this.
  14. Edited the link.
  15. Jloui

    Jloui New Member

    I found how to open an apk.zip file on android...the way I was able to do it was by putting the .zip file on the sd card...this is what made it work...On the phone I long pressed on the zip file with astro file manager chose edit and then rename...I took off the .zip at the end of the name and it worked...it turned in to an .apk file:D
  16. Jmtegra

    Jmtegra Well-Known Member

  17. dariush86

    dariush86 New Member

    yep!!!!!on astro file manager, long press on zip file..then press edit ...them rename and rename it to .apk .then pres on it and open file browser.....i hope it work!!!! it work fine for me..
  18. lcf1

    lcf1 Member

    I am trying to download and install Adobe Flash 10.3 for Froyo 2.2

    Although it downloads from the Adobe archive site (as a apk file), when I click to install it says "installing" then the line install graphic shows followed by "Application not installed" and the Done button is the only one that appears.

    The file downloads to my Android tablet, not an SD card.

    Is there any reason anybody can think of as to why it does not install? Does it need to be downloaded on to an SD card? I have enabled plugs in and java and non market apps etc etc. (The old 10.3 Flash stopped working, so I uninstalled it.)

  19. lcf1

    lcf1 Member

    If this is the wrong place to ask the above question, please direct me to where I can start a thread or ask it. Thanks.

    (I think I am right in saying Adobe Flash 11.1 won't work on my device or Froyo, so I need 10.3. Marketplace no longer has either version btw!, Google Play has just 11)

    did a factory reset and erase local disk (format)
    - although it brought Adobe Flash 10.1 pre-installed back in to the Applications list, it still does not work, yes I have made sure Settings activates Plugins and JS
  20. doogald

    doogald Guides Guide

    Adobe Flash cannot install on the Eris. It requires a better processor than the Eris has. There is nothing you can do about it, unfortunately.

Share This Page