APN settingsSupport


  1. clicker

    clicker Active Member

    when I had 1.5 on my phone, the internet and MMS settings were there by default, now that I have 2.1, the settings are not there..I called my service provider and asked for settings(as everyone does, and as I used to do with my Nokia), but no settings are recieved, I tried several times...pls. tell me what to do.......( I live in Saudi Arabia, Service Provider: Sawa(STC))

    Advertisement
    :
  2. Beerkan

    Beerkan Well-Known Member

    Try these settings

    Menu
    Settings
    Wireless & Networks
    Mobile Networks
    Access Point Names
    Create new one

    Name: STC
    APN: jawalnet.com.sa
    Proxy: <not set>
    Port: <not set>
    Username: <not set>
    Password: <not set>
    Server: <not set>
    APN Type: Internet & MMS
    Save.


    Your phones default APN settings are stored on the phone in a file here :-

    \system\etc\apns-conf.xml

    Most Firmwares just carry the main phone providers, and I've checked for STC settings in my apns-conf.xml file.

    Here's the entry for STC.

    Code (Text):
    1. <apn carrier="STC" apn="jawalnet.com.sa" user="" password=""  server="" mmsc="" mcc="420" mnc="01" type="default,supl"/>
    2.  
    3. <apn carrier="STC MMS" apn="mms.net.sa" user="" password="" server=""  mmsc="http://mms.net.sa" mmsproxy="10.1.1.1" mmsport="8080" mcc="420"  mnc="01" type="mms"/>
    There is also a complete list of ALL carriers APN settings here.

    Wiki Service Providers APN Settings List

    Of course you could always hope another STC user posts his settings, or even google
    "STC APN Settings".

    good luck.
  3. clicker

    clicker Active Member

    Its not working :(
  4. Beerkan

    Beerkan Well-Known Member

    Friend. All the google searching point to these being the correct setting for your provider.

    See Here

    See Here

    See Here

    And here

    Try searching for yourself.

    Re-read my above post.

    Create a new APN, and use the new settings I posted. After you save the settings you will need to enable them. Press the name STC (o) to see Green beside the name.

    If it still fails, contact your provider. Ask them to email you settings, or provide a link on the web.
  5. clicker

    clicker Active Member

    tried everything :(...... is there any other setting that could have been changed ?
  6. *Centurion

    *Centurion Member

    It looks like the proxy and port are missing
  7. Beerkan

    Beerkan Well-Known Member

    Any settings I can find for STC, the proxy and port settings are <not set>
    Check out the links I provided.
  8. Beerkan

    Beerkan Well-Known Member

    Any settings I can find for STC, the proxy and port settings are <not set>

    Try restoring default APN settings.

    Menu
    Settings
    Wireless & Networks
    Mobile Networks
    Access Point Names
    Press Restore Default.
  9. clicker

    clicker Active Member

    It worked !!
    I used these settings:

    Name: Jawalnet
    APN: jawalnet.cam.sa
    Proxy: <Not set>
    Port: 8080
    Username: <Not set>
    Password: <Not set>
    Server: <Not set>
    MMSC: mms.net.sa
    MMS proxy: 10.1.1.1
    MMS port: 8080
    MCC: 420
    MNC: 01
    Authentication Type: PAP
    APN type:Internet(doesn't work on 'Intrnet+MMS')(I dont need MMS anyways)
    testking likes this.
  10. jadihussain

    jadihussain New Member

    Hi,

    I live in Riyadh, Saudi Arabia (Middle East) and using Samsung i9000 Galaxy S.

    I was searching the APN Settings of STC Network. I found it at samsungmobile.com website.

    my MMS settings are working.

    Please follow line by line carefully.

    ok, click the link below
    Configure Phone - Support - Samsung Mobile Middle East

    accept terms and condition
    Select your desired model of your mobile phone
    now WAP, MMS and Internet settings are available
    click for instance MMS
    choose your country from the list
    select your network (Mobily, Zain, STC)
    follow the setup
    and enjoy

    Configure Phone - Support - Samsung Mobile Middle East

    dont forget to leave the comments here

    Junaid Hussain
  11. adlhc

    adlhc Member

    I live in Portugal and i'm having problems with the MMS.
    can any one help? :confused:
  12. Beerkan

    Beerkan Well-Known Member

    Have you tried restoring default APN settings.

    Menu
    Settings
    Wireless & Networks
    Mobile Networks
    Access Point Names
    Press Restore Default.

    Who's your carrier.

    Here's a list of most (if not all) carriers APN settings.

    Big APN List
  13. adlhc

    adlhc Member

    Yeah, i did try to restore, didn't work.

    ehm, Vodafone. my carrier is Vodafone.
    helps ?
  14. Beerkan

    Beerkan Well-Known Member

    Ask your provider to txt you your MMS settings. Should be a simple case of calling their (hopefully free) helpline.
  15. shihabva

    shihabva Member

    Dear Beercan ,

    You really saved my ass by providing the link of detailed list.

    I am in Saudi Arabia and i wasnt able to get connected to STC network in my Desire,which was really heart breaking.

    Please follow this steps for getting connected (for Saudi STC guys)

    Name - "AL JA WAL" (All Without Quotes Please)
    mcc="420"
    mnc="01"
    apn="jawalnet.com.sa"
    type="default,supl"

    Please enter everything inside Quotes exactly the same - and here we gooo.....:)
  16. testking

    testking New Member

    It worked !!
    I used these settings:

    Hi Buddies,

    I worked for me too, thanks to clicker

    Name: Jawalnet (can be any name)
    APN: jawalnet.cam.sa
    Proxy: <Not set>
    Port: 8080
    Username: <Not set>
    Password: <Not set>
    Server: <Not set>
    MMSC: mms.net.sa
    MMS proxy: 10.1.1.1
    MMS port: 8080
    MCC: 420
    MNC: 01
    Authentication Type: PAP
    APN type:Internet (I used internet)
    baderfgt, The Tulip and Fadiz like this.
  17. ot3pch4n

    ot3pch4n New Member

    Hi guys! Newbie here. I'm a LG Optimus One P500 user in the KSA.

    I tried emailing STC's customer service & they were pretty much useless. After reading this post & some tweaking, I have successfully configured the APN settings of my phone for internet & MMS.

    Internet
    Name: jawalnet or anything you want
    APN: jawalnet.com.sa
    Proxy: <Not set>
    Port: <Not set>
    Username: <Not set>
    Password: <Not set>
    Server: <Not set>
    MMSC: <Not set>
    MMS proxy: <Not set>
    MMS port: <Not set>
    MCC: 420
    MNC: 01
    Authentication Type: <Not set>
    APN type: <Not set>

    MMS
    Name: jawalmms or anything you want
    APN: mms.net.sa
    Proxy: <Not set>
    Port: <Not set>
    Username: <Not set>
    Password: <Not set>
    Server: <Not set>
    MMSC: http://mms.net.sa
    MMS proxy: 010.001.001.001
    MMS port: 8080
    MCC: 420
    MNC: 01
    Authentication Type: <Not set>
    APN type: mms

    I tried sending an international MMS & it was received successfully. I'd like to hear your feedback guys. Cheers!
    Fadiz likes this.
  18. Fadiz

    Fadiz New Member

    Thaaaaaaaaaaaank you ot3pch.. Actually I tried all the proxies and ports listed above and nothing worked with my htc desire!! till I finally found you :D the settings u posted are quite useful and working properly on my phone. I appreciate ur kind initiative to help my friend. Unlike the Stc's customer service they are agonizingly useless I called them more than once and realized they thought my htc is a banana!!
  19. Fadiz

    Fadiz New Member

    Many thanks for all the previous users for trying! :)
  20. Fadiz

    Fadiz New Member

    it's too slow baby!! Mobily used to be hell faster!!
  21. Fadiz

    Fadiz New Member

    baby.. are u there??
  22. akussad

    akussad Member

  23. ansari7001

    ansari7001 New Member

    I have successfully configured the APN settings of my phone for internet (Android) hope it should work for all types

    Internet
    Name: jawalnet or anything you want
    APN: jawalnet.com.sa
    Proxy: <Not set>
    Port: 8080
    Username: <Not set>
    Password: <Not set>
    Server: <Not set>
    MMSC: <Not set>
    MMS proxy: <Not set>
    MMS port: <Not set>
    MCC: 420
    MNC: 01
    Authentication Type: <Not set>
    APN type: <Not set>
  24. SawaMobily

    SawaMobily New Member

    I know this an android phone forum but may be somebody can help me.


    I use Huawei now & also have Siemens C55. I live in Saudi Arabia & trying to connect to internet through Siemens C55.


    In WAP Paramters it&#8217;s asking a 12 digit ip address, then port & linger time. In GPRS settings it requires APN, login & password.


    Kindly tell me how to connect. I have both sawa & mobily.
  25. happylouie

    happylouie New Member

    Hey guys I believe you got the APN wrong it should be "jawalnet.com.sa and not jawalnet.cam.sa the word "cam" it should be "com" instead. And the APN name I used for android jellybean phone is "JawalNet" which means the letter "J" should be capital and the letter "N" as well. Moreover in android jelly bean in the APN type the selection are: default, mms, supl, wap and in my phone I choose "default,mms,supl" and tadaaaaaaaaaaa it works perfectly.

    Lastly, aside from the corrections I mentioned here the rest of your tips are fine and I used them, thank you anyway :) even though I lost some of my prepaid load while I tried yours and the other threads here...:(
Loading...
Similar Threads
  1. phamduyhun87
    Replies:
    1
    Views:
    2,293
  2. Gavin James
    Replies:
    21
    Views:
    23,935

Share This Page