[APP] GrooVe IP - Google Voice VoIP


Last Updated: 2014-12-24 00:59:41
  1. Pinan

    Pinan Well-Known Member

    Why not just use the Google Voice app? Works great for texting and receiving VM's over wifi or 3G.

    Advertisement
    tEA-TiME likes this.
  2. Pinan

    Pinan Well-Known Member

    No. Wifi works fine with phone asleep/screen off, as I get calls over GV and GrooveIP with no problem.

    I did just confirm though that the transition between cellular (maybe 3G too) to wifi only works after waking the screen, and not unlocking the phone. On the Optimus V the screen will wake for a few seconds so that you can check notifications, but does not unlock.

    Hope this makes sense.

    I know this has been gone over before a bit, but GrooveIP only shows up for the first ring or two, then the Virgin Phone app pops up in the way. It would be great if it was easier going back and forth between dialers, or it could be set to stay on GrooveIP for wifi/3G calls.
  3. tEA-TiME

    tEA-TiME Member

    I'm an idiot, that's why!!! I don't think I ever even opened the Google voice app, or I might have noticed you could do it straight from there.

    Thanks!
  4. Pinan

    Pinan Well-Known Member

    LOL. I have the widget on my desktop and use it all the time. Works seemlessly with GV. And It's great having VM's come right to the phone, and not an email. I just had to install an app (Remote Wave, free) to play them. :)
  5. GabrialDestrui

    GabrialDestrui New Member

    Started running into this problem with Groove IP again.

    When I can make calls and it's connected it appears to just drop neither person can hear each other.

    When it crashes it comes up with a FC then afterwards restarting the app it refuses to show the dialpad or respond at all. Hardware buttons are frozen too. This also seems to happen when I exit the program to try and restart it. Is there anything I should be looking at specifically that might cause this?

    Also I'm noticing a lot of disconnect/reconnects of Groove could this have anything to do with it?

    This time 3G Watchdog isn't installed
  6. conchchowder

    conchchowder Member

    I'm a new Samsung Galaxy Tab P-1000 owner who is new to Android. One of the functions missing in entirety is the use of the phone functions so I was browsing these forums to learn about Android OS and features of it.

    I was going through this thread and was truly amazed that in all of the forums I have been reading, especially the XDA forum where people are hungry for methods to get phone functionality, that solutions to this issue were virtually non-existent.

    Then I come here.

    I find a community here where the developer is an intimate member of the community and is passionately interactive with others in searching for methods to enhance and perfect the program he has worked on. I see concerns immediately responded to and features added constantly. I am amazed at how everyone is working together to get this program perfected...until this post.

    Frankly, this post disgusted me.

    The tone was so out of balance with the entire thread, it stuck out like a shipwreck in a swimming pool.

    I've lost more money than that in the sofa.

    Your money has helped to further the development of this program and I'm sure that if you had approached the issue differently, that a solution would have been found and if not, the refunding of the gargantuan sum of $3.99 would have been donated by the members here to not only satisfy the grave financial crisis caused by your payment, but for you to simply go away.

    The tone of your post has really ruffled my feathers.

    You treated this man so poorly by your post; he deserves an apology.
  7. conchchowder

    conchchowder Member

    This app is worth $9.99 and is terribly undervalued. There are video games out which are priced higher and don't enhance anything other than wasting time. This is truly an app which is rare and worthy of its price.
    Behr and lagman like this.
  8. lagman

    lagman Member

    I'm still seeing registration issues with the latest version when on 3g. The indicator goes red green red green. Sometimes it never recovers so I have to restart the app. I can reproduce the problem 100% of the time. It always unregisters when I open the google market app.

    Call quality is great.. Keep up the good work! The app will be a perfect solution in my opinion once the registration issue gets fixed.
  9. Behr

    Behr New Member

    Hey there. Sorry it took me so long to respond, but I've e-mailed you the information you've requested!

    - Behr
  10. snrb

    snrb Well-Known Member

    Hey, sorry everyone. I never got any notification that there were new posts in this thread. I noticed a few people referencing text messages. We are working on adding text capability into GrooVe IP.

    If you're having registration problems and you've moved the app to the sdcard, move it back to the phone.
  11. snrb

    snrb Well-Known Member

    Have you moved the app to your sdcard by any chance? I've noticed that that can cause problems.
  12. snrb

    snrb Well-Known Member

    Hey, normally I wouldn't address this. But we did work things out over PM. Later on I found the solution to her problem. Believe it's been posted in an earlier post. Apparently it's something screwy in google chat if you've invited people to gmail/google chat.
  13. lagman

    lagman Member

    nope, I never moved it to SD.
  14. snrb

    snrb Well-Known Member

    What kind of phone do you have?

    Seems like even with our last change android still kills our service when it needs resources. The last update should have increased our priority so it happens less often. But there's really no way to prevent android from stopping the service when it needs resources and scheduling it for restart. Anytime that happens GrooVe IP will re-register, which will flip your icon from green to red and back to green.

    I can just not change the icon if the service restarts...but there will be a short window when it happens where you won't be able to make calls. Not sure what's worse, a slim chance of trying to make a call when you think your registered and not having it go through. Or seeing the app re-register.
  15. lagman

    lagman Member

    I have a Dell Streak.

    I guess I'm less concerned about the times it re-registers right away and more concerned about the times when I'm on 3g and it just stays red until I restart the app..
  16. lagman

    lagman Member

    The only other thing I've noticed is that I never hear the people I call say "hello". It always seems to drop the first few seconds of audio. I've gotten around that by just assuming they have already said "hello" as soon as the call is connected and I hear dead air. I think people who call me do not hear the first few seconds of my audio as well. I have both process incoming and outgoing audio checked.
  17. Pinan

    Pinan Well-Known Member

    At times I have this happen as well.
  18. javlinsharp

    javlinsharp Member

    Excellent work on this app. In the short time Ive had it, its proving to be everything Ive been searching for months, indeed the first Ive ever purchased:D Im cheap...what can I say?

    Just a bit of feedback, and please forgive me if these questions are answered.

    1. Sometimes it can be slow on re-registering, especially when switching between 3G and wifi. Might be nice to have a re-reg now button, at least then I can tell if its trying, or otherwise, see an error. Red Dot is a bit disconcerting when you cant do anything about it.

    2. (stupid question alert) With regards to txt. The client does not offer a compose TXT button. Can I assume my usage of official Google Voice app for txt is indeed going over VOIP?

    3. I must say, was expecting moderate to terrible battery impact, yet GVIP doesnt even show up on my to 10 batt consumers. BIG win.

    Thx again.
  19. avatar0716

    avatar0716 New Member

    I keep getting "try again" when i dial I have a thunderbolt i have logged off goggle voice I even tried to shut off 3g and use wifi and the other way around same issue I can recieve just not call out.
  20. snrb

    snrb Well-Known Member

    I believe the official Google Voice app does send texts over data. I'm not 100% sure, never really confirmed that.

    We're trying to figure out the issue with switching networks, but having a button sounds like a quick work around. It actually should try and sign-in immediately if you open the app from the notification icon.
  21. snrb

    snrb Well-Known Member

    That's a generic google voice error. It can happen temporarily and just go away by itself. Or it can indicate an issue with your google voice account. Few things to check in your google voice account

    1) The language preference should be English.
    2) You should have a checkbox in the voice settings page to forward calls to Google Chat.
    3) The email address associated with your google voice account should be a gmail address. We've noticed other types of emails can cause random problems.
    4) Someone also reported having an old gizmo number listed in their account caused that error to happen.
  22. Beeray

    Beeray Well-Known Member

    The app refuses to show registered today. I checked my google user number and it is fine. Cannot figure out what is wrong.


    Restarted the phone and that did the trick. Go figure!


    Beeray
  23. snrb

    snrb Well-Known Member

    Have you tried restarting the app? You can close it with menu->exit or force close from the phones settings->applications.
  24. Beeray

    Beeray Well-Known Member

    I'll try that if it ever happens again. Thanks for the quick reply, I love the app

    Rochelle
  25. sethgoldstein

    sethgoldstein Well-Known Member

    Hi

    I just bought your app. It's going to be perfect for when I go to Italy in September. I have a Droid X running rooted and on 2.3.3.

    I have my Google Account on 2 factor authentication so I'm thinking I have to give this app the alternate generated pw, right? I tried both ways and it's not working? Will I have to turn off 2 factor auth to have this work?

    Please let me know. Thanks

Share This Page