[APP] GrooVe IP - Google Voice VoIP


  1. snrb

    snrb Well-Known Member

    The app connects through Google Chat. So in order to receive calls you have to go into your google voice account and forward calls to Google Chat. It should be one of the options in the voice settings. Other than that you really only have to enter your username and password. The rest of the options customize the app behavior or troubleshoot specific issues.

    I believe you can purchase the app from the market on your pc and then download it on your phone from the market app. The purchase is tied to the gmail account your phone sync's with, so you likely have to log in with that when you purchase from the pc. Alternatively you can purchase from the amazon app store. And I know that lets you purchase from a pc and download on your phone.
  2. snrb

    snrb Well-Known Member

    Recipient will see the Google Voice phone number as the caller id.

    Are you having echo? You can reduce it by lowering both the speaker volume and mic gain. We should also have another update over the weekend with an echo canceling option.
    EVU likes this.
  3. EVU

    EVU Well-Known Member

    Thank you for the update!!!

    Also - 1 other question:

    Is the app purchase tied to only one device (my Father's EVO 4G) or can he use it also on his Moto Xoom tablet also?
  4. snrb

    snrb Well-Known Member

    Purchases from the android market are tied to the gmail account the device you purchase on sync's with. So as long as both sync to the same gmail account the app will work on both.
    EVU likes this.
  5. z3N#

    z3N# Active Member

    Hello SNRB
    Thanks for the follow up.
    I have no Google chat option in my GV account.
    Is it disabled by default perhaps?
    Thx
    z3
  6. ric5141

    ric5141 New Member

    In you google voice account click the phone number at the top right of the first screen

    You should see the items

    Phone number

    Then Google Chat
    then The cell phone number...only check the google chat option

    This is all on the phone tab
  7. TnTWalter

    TnTWalter Member

    I have Optimus V and got Groove IP. It doesn't work. I've read that I have to do google chat. I am able to click the box forwarding to google chat and click off my cell phone number but cannot call out. Someone said you had to call from google chat first. But I can't cannot figure out at all how to access / use google chat to make the call. Can somone walk me through it step by step. Website or app or whatever. Then click or whatever. I feel like an idiot but hubby couldn't do it either.

    ok..update i just called hubby through google voice...it asked if i wanted to use groove ip...and it worked...did not do anything google chat....

    my minutes didn't change!!!
    so i just needed to check the box...that was the 'google chat'...woohoo
    Trish
  8. snrb

    snrb Well-Known Member

    Sounds like you got it working. Do you still need any help with anything?
  9. z3N#

    z3N# Active Member

    OK I finally got Chat to appear in the GV dashboard...you have to go into Gmail - Settings - Chat - Select radio button "Enable outbound calls etc' (I read Gmail in a separate email client)
    Turn Chat on in GV sidebar...refresh everything then it appears.
    So far so good...

    I downloaded the app and installed it.
    I can call out but no speaker option
    Calling in, it shows up on the phone screen but no ring tone, and no speaker option again.

    OK got the ring tone turned on...but no speaker option
    ------------------------------------------------------------------
    Got the speaker option to work both ways now.
    Thanks for a great app.
  10. cal47

    cal47 New Member

    Hi I was wondering if this change is part of the version 1.1.8 release.

    On incoming calls my phone will show the GrooVeIP incoming call screen for about 2 rings and then switches over to the native dialer.

    Currently using a OptimusV with bumblebee2.4.
  11. z3N#

    z3N# Active Member

    I have the green icon light, I've turned off Chat in Gmail as suggested, allowed 3G/4G calling, turned off Wifi, all troubleshooting preferences unchecked, mobile device number unchecked,
    but minutes are still being burned.

    If I have Wifi running at the same time as 3/4G enabled, what effect does that have ?
    What other config should I implement to avoid min usage?
    Thx
    z3
  12. snrb

    snrb Well-Known Member

    Make sure calls are made through the app. The in-call screen is different than your native one. Has 5 buttons, hangup and dialpad on the top row and then bluetooth mute and speaker on the bottom row. Also, for incoming calls people have to call your google voice number not your cell number.
  13. z3N#

    z3N# Active Member

    Yes I noted the difference between the dialers.
    Cell number never issued, always GV number from day one.

    I had an incoming call last night that burned mins...I could swear the app in-call screen displayed.

    When I used the native out call dialer, it asks me if I want to route the call through GrooveIP...so I DON'T use the native dialer at all?

    I noticed just now the icon went red, I went to Gmail on my laptop and enabled Chat and it reverted to green after toggling airplane mode - So do I leave Chat on or off?

    I just turned it off again to check GVIP status.
    Oh, I think GrooveIp had just signed out... its not Chat on/off dependent?

    Sorry I am in learning curve....maybe I am getting confused.

    This is interesting: A call just came in - the icon went to Red.
    The native in-call screen showed up - The call ended, the icon went to Green...


    Many thx
    z3
  14. FarmerOak

    FarmerOak Member

    Have GrooveIP installed on my Optimus V, it works great when I have fast 3G or Wifi access. The problem I have, however, is how to forward calls to GrooveIP AND my mobile and be able to choose which to answer with. I've done some experimenting, and here's what I've found:

    When you have data access and someone calls with:

    1. Google Voice forwarding to Google Chat only, you get the call on GrooveIP
    2. Google Voice forwarding to mobile only, you get the call on your native dialer only
    3. Google Voice forwarding to BOTH, you first get GrooveIP for 1-2 seconds, THEN native dialer ON TOP of GrooveIP. Two ring tones simultaneously, with native dialer on top. <--- want to be able to CHOOSE which to answer with.
    When you have NO data access and someone calls with:

    1. Google Voice forwarding to Google Chat only, you get NOTHING**
    2. Google Voice forwarding to mobile only, you get the call on your native dialer only
    3. Google Voice forwarding to BOTH, you get the call on your native dialer only

    The scenario I don't want is "#1 w/no data". If I don't have data access for whatever reason, no one can call me! (Unless they call my real mobile #, which I don't want to use). So I need "#3 w/data" above to give the OPTION to pick up through GrooveIP or native when both are going off. Therefore, if I have no data access, my mobile will still ring fine since GrooveIP just won't activate at all. This would be a great feature, too, if you really wanted great call clarity for a particular phone call.

    Is this possible?
  15. snrb

    snrb Well-Known Member


    For incoming calls you have to go into your google voice account and forward calls to Google Chat. It sounds like your calls are still forwarded to your cell number. That will use your minutes.
  16. snrb

    snrb Well-Known Member

    We'll be posting an update tomorrow (Friday). One of the changes is that the GrooVe IP incoming call screen will come back on top of the native one. So right now what happens is you'll get 1-2 rings with GrooVe IP then the native incoming call takes over and you get double ring. In the new update what will happen is GrooVe IP will ring for 1-2 rings, then the native dialer will come up very briefly, then GrooVe IP will come back on top (as long as you have a data connection). The app will mute it's ring and use the native ringtone so you don't get the double ring.
    FarmerOak likes this.
  17. FarmerOak

    FarmerOak Member

    PERFECT, thank you! This app is so close to being flawless. Any chance we'd get an option to choose in the future?

    Now if only we could choose to compress the outbound data loads more to help with low data transmit rates. I know you've addressed this before and there are limitations with Google's own compression standards, but I can dream :)
  18. snrb

    snrb Well-Known Member

    Who knows, maybe they'll adopt a new codec. I mean we could stick a server in the middle and use compression to that and then g711 from there to Google Voice. But I think we prefer to maintain the direct Google Voice connection.

    Oh and if you like the app, please help us out and give us a 5-star review :)
  19. FarmerOak

    FarmerOak Member

    Just did, and happy to do so.

    Maybe in the next update, you could pop up a menu to give the option to display the native or GroovIP dialer (like when calling out), instead of just defaulting to GrooveIP. There's times I might REALLY need to answer a call and don't want to risk spotty quality, you know? Thanks for your great work
  20. snrb

    snrb Well-Known Member

    I *think* (haven't tried it) if you press the home button when our incoming call screen is showing it'll go back to the native one. We're already pretty far into testing for this update but will definitely take a look for the next one.
  21. z3N#

    z3N# Active Member

  22. Whyzor

    Whyzor Well-Known Member

    I thought on CDMA networks, data & native phone voice can't be on at the same time? Thus why groove IP will ring first, but then the incoming cellphone call will override it. Or is this not an issue with 3G CDMA now?

    I too would love to see a more efficient codec, especially on spotty VM networks. Maybe if we all pester Google Voice about it, they'll upgrade. G722 is so old & inefficient by today's standards.
  23. TnTWalter

    TnTWalter Member

    I'm having trouble with calls not going through...i end up having to use my mobile minutes. It will either ring or not ring and then go right back to the dial pad....

    Can you help me troubleshoot? Thanks.

    Trish
  24. snrb

    snrb Well-Known Member

    On CDMA networks where you can't have data and voice at the same time, you'll need to be connected to WiFi. Otherwise the native incoming call will drop your data connection.
  25. z3N#

    z3N# Active Member

    snrb

    Thanks for assistance.
    I can get it working pretty well now.
    I had the echo, low volume issues but adjusted the settings according to your web site FAQ.

    I am using Wifi at my location as 3g is spotty and probably causing my prior problems.

    My remaining problem now is
    The phone will not ring on in-calling
    thx
    z3
Loading...

Share This Page