[APP] GrooVe IP - Google Voice VoIP


  1. snrb

    snrb Well-Known Member

    Do you see the incoming call screen there is just no ringtone? Or nothing happens at all for incoming calls?

    Does the caller hear ringing? Or does it go straight to voicemail?
  2. z3N#

    z3N# Active Member

    I didn't see, and don't know about the VM.
    Let me have someone call me and I'll post back.
  3. z3N#

    z3N# Active Member

    Dang - It worked fine just now - phone rang....caller and I could hear each other fine, no echo.
    I am heading out so I'll test it using 3G only.

    Do the phones native volume settings over-ride the apps settings, or are they totally independant?
    Thanks snrb
    We really appreciate your author input.
  4. snrb

    snrb Well-Known Member

    If you haven't done it already, update to 1.2.0. Just posted it like half an hour ago.

    The volume is a combination of the native and in-app setting.
  5. z3N#

    z3N# Active Member

    How do I do that?
    I went to the app on the phone but don't see any update functionality.
    Thx
    z3
  6. snrb

    snrb Well-Known Member

    Updates are through whichever market you purchased from. The update is live on the android market right now. Amazon has it but they do a review before posting it. Just go into either app and there should be a menu for 'my apps' which will list the apps you have and whether updates are available.
  7. z3N#

    z3N# Active Member

    I logged onto the A Market, 'My Apps' but not showing update available.

    I am still getting mins used. Had an in-call. GrooveIP dialer showed up like it should, I clicked through to 'Press one to answer'....can that process revert the call to the native dialer? It didn't show up if it did.
    I finished the call hitting 'Hang up' on the APP dialer that was still displaying.
    So how can this be?
  8. lgmayka

    lgmayka Active Member

    Has anyone gotten this to work well on the Samsung Moment running stock firmware (Android 2.1)? My nephew tried it, but incoming voice always comes through the speaker. He has tried various combinations of settings, including the one that is supposed to fix this.
  9. bukzin

    bukzin Active Member


    I purchased thru Android Market and also have a ipad2,
    both using the same @gmail account.

    Will my account work on both? Is there a way
    to get the GrooveIP icon on my ipad?


    Thanks and keep up the good work!
  10. lgmayka

    lgmayka Active Member

    Is this true of the Samsung Moment also (running the stock Android 2.1 firmware)?
  11. z3N#

    z3N# Active Member

    Unable to locate update.
    Absolutely not at Android Forum in my account.

    An update alert showed on the phone briefly when I booted, but now is gone.
    Reboot does not redisplay the alert.
  12. rfb813

    rfb813 Member

    Using the GrooVe IP dialer when I hold down the 0 key the + for international call does not function. I have to dial 011 to make the international call. Am I doing something wrong? How do you get the + to appear?
  13. and_rosh

    and_rosh Member

    Question1:

    My GVIP was working great on Froyo with no issue. However after the update its disconnecting sometimes automatically, which i havent had before.

    Question2: (i had this problem from previous versions)
    Im using Samsung GS4G and with no gvip i can run the phone (on froyo or gb) about 2 days. However when i run with gvip ON, froyo runs almost the same time and GB doesnt run even a day.

    Also noticed with the battery graph:
    The battery drain is less when gvip is on for the first time. Once you make a call draining is faster and after the call it keeps the same draining level, without going back to before. So apparently GVIP doesnt go back from WiFi performance mode to normal mode after a call.

    in summery. (on gingerbread)
    1. GVIP off - low battery drain
    2. Turn GVIP on - low battery drain
    3. Make/receive a call via GVIP - high battery drain
    3. The call is over - still on high battery drain mode.

    Any fixes/comments on these, please?
  14. FarmerOak

    FarmerOak Member

    double post
  15. FarmerOak

    FarmerOak Member

    I can confirm this. With wifi on, nothing else on, plus GrooveIP I use about 28ma/h on my optimus V. After a while or a call (I'm not sure exactly when), it rises to 48ma/h. Both measurements were steady for hours. After restarting GIP, it falls back to 28ma/h.

    Edit: Also seeing your first point too. Every so often, GrooveIP will log out for 10 seconds, then log back in. This is on a steady wifi connection, and I didn't notice it before. I suppose it could have been doing it before too, but I just didn't see it. But I've seen it a few times since the update.
  16. snrb

    snrb Well-Known Member

    Don't have an iOS version yet. Only android.
  17. snrb

    snrb Well-Known Member

    Nothing in the connection logic changed in this last update. Will take a look at the battery drain you noticed. Didn't get any reports of that from any of the beta testers. What kind of device do you have?

    Just checked the code and it does look like the lock is released when a call is ended. If you can email me at snrb.labs@gmail.com I'll send you a version that does not obtain the lock at all. That will at least tell us if it is the lock causing the issue.
  18. snrb

    snrb Well-Known Member

    In case you haven't already purchased the app, tomorrow we plan on increasing the price. If you've been planning to purchase the app, may want to do it tonight.
  19. and_rosh

    and_rosh Member

    what app you use to measure ma/h?, i can use the same as a comparison.
  20. and_rosh

    and_rosh Member

    My device is Samsung Galaxy S 4G (tmobile). Not sure how the code affect here. The problem arise only on gingerbread it seems. There is no draining issue on Froyo.
  21. Whyzor

    Whyzor Well-Known Member

    I'm on LG Optimus V using IHO CM7.1 build. I've noticed this behavior with GPS as well, turning it on & then off puts it in a higher drain mode even after turning it off & closing the app that used it. Not sure if it's a Gingerbread issue, or just battery somehow "loosening" after it's being exercised. That battery graph is a very useful tool, maybe now that we have it, it's pointing to all these small problems that were hard to notice before.
  22. snrb

    snrb Well-Known Member

    Should have posted this on Friday when the update actually came out. But change log for 1.2.0 is below.

    1.2.0:
    - Echo canceler option
    - Config to disable updating the native call log
    - Obtain high perf wifi lock only during a call. Option to always obtain while app is running
    - Add call filtering options (include number, exclude numbers, exclude prefix)
    - Fix GT-P1010 and Samsung Galaxy I9003. Requires Synchronize Voice option enabled
    - Show GrooVe IP incoming call screen on top of native incoming call screen as long as device maintains data connection
    - Bug fixes
    eezip likes this.
  23. jting0193

    jting0193 Member

    anyone having login issues? just happened today and it says no valid network or something. im on a wifi connection

    edit: i believe my app is still on the 1.18 version since i bought it from amazon (i had a gift card lol) and it takes forever for them to update if that matters at all.
  24. snrb

    snrb Well-Known Member

    Amazon has 1.2.0. They actually processed the update in a few hours this time.

    Check your phone's wifi settings. Is it stuck at obtaining ip address?
  25. eezip

    eezip Member

    The shipping (Android 2.2.2) firmware for the Droid X2 didn't allow GrooVe IP to work. After installing the X2's Gingerbread (2.3.3) update, I'm now able to successfully make calls with GrooVe IP 1.2.0 over WiFi and 3G. :D

    I still can't receive calls, but I haven't explored all the options yet.

    Are there any other X2 owners out there?

Share This Page