[APP] GrooVe IP - Google Voice VoIP


Last Updated: 2014-12-24 00:59:41
  1. Shuttle

    Shuttle Member

    Has anyone gotten the update 1.2.1 from amazon? They sure seem to be very slow on releasing updates.

    Advertisement
  2. snrb

    snrb Well-Known Member

    Amazon has had 1.2.1 for a while. If you aren't seeing the update try uninstalling and redownloading the app from Amazon. That should give you 1.2.1
  3. Shuttle

    Shuttle Member

    Thanks snrb did what you said uninstall and re-installed and its now 1.2.1

    Shuttle
  4. dtrayers

    dtrayers New Member

    New user here...

    I purchased GrooveIP to use on my AT&T Atrix while traveling in Mexico on business. I'll have access to free Wifi a lot. Yesterday everything worked, except the person I was calling got a lot of echos. Today, we were going to experiment with the echo reduction settings, but I found I can't place any outgoing calls using Groove. I can receive calls when I call my Google Voice number, and I went to the GV web page and was able to initiate a call as described in the FAQ (it did some kind of call-back thing).

    But when I try to *make* a call using Groove all I get is silence. It worked yesterday, and when I called my office phone it would ring almost immediately. Now, nothing. And I don't think I changed anything. Wifi is on with a good signal, and the GV status icon is green. Tried rebooting.

    Tried enabling the 'Allow 3G' setting and shutting off wifi. Got a green GV icon again, but still no outgoing calls (can receive on 3G, though). Incoming texts work, so GV seems to be working ok.

    Tried adding a 1 and a +1 to the area code.

    I'm stumped. I'm about to try to uninstall and reinstall, but before I do that, since I can *receive* calls, I'm thinking this must be a configuration problem.

    Suggestions?

    -Dave-
  5. DarkJedi

    DarkJedi Well-Known Member

    It isn't just you. Something is preventing GrooVe IP from making outgoing calls. Hopefully it is just a temporary problem on Google's end and not them blocking 3rd party apps from using Google Chat to make calls.
  6. snrb

    snrb Well-Known Member

    Hi,

    That issue started affecting people this morning. It appears that either there is a problem on the Google servers or Google may have modified the calling specification slightly. Incoming calls appear to still work. We're looking into it and should have more answers or a solution soon.
  7. dtrayers

    dtrayers New Member

    Glad to know it's not just me!

    Thanks!
  8. okieopie

    okieopie New Member

    Appreciate you being on top of things snrb. I was having trouble getting calls to go out today so thought I'd check on the forum - there was your answer. Looking forward to a fix - but know that it is in good hands!
  9. s0nicfreak

    s0nicfreak Member

    I rebooted the phone since I was having that problem, and now Groove IP can't sign back in...
  10. Pinan

    Pinan Well-Known Member

    Yup. Here too.
  11. snrb

    snrb Well-Known Member

  12. whelanbdubs

    whelanbdubs New Member

    Same problem here...I really hope this is temporary and not the beginning of the end.
  13. snrb

    snrb Well-Known Member

    Looks like Google changed their namespaces. We're making the change in the app, will have a new verison
    Beeray, DarkJedi, Pinan and 1 other person like this.
  14. whelanbdubs

    whelanbdubs New Member

    snrb,
    thanks for all your help. About how long should I expect it to take. I appreciate all your hard work.
    thanks,
    bdubs.
  15. snrb

    snrb Well-Known Member

    Version 1.2.2

    - Fix outgoing calls due to new Google Voice namespace
    - Add support for contact specific ringtones
    - Change notification icon to indicate in-call state
    - Add 'Next' and 'Go' to login screen keyboard
    - Make license check more tollerant of Android license server errors
  16. Beeray

    Beeray Well-Known Member

    I can't say thanks enough times.

    Beeray
  17. Pinan

    Pinan Well-Known Member

    Seems to work fine. The echo test (909-390-0003) now works again as well, which has not for awhile. Maybe something to do with Google?

    Thanks for the quick fix and the extras, snrb. :)
  18. whelanbdubs

    whelanbdubs New Member

    great job!!!!!
  19. eezip

    eezip Member

    Just a quick tip for those who may have been befuddled like me.

    The problem: I wasn't able to accept any calls.

    When calling my GV number, there was no ringing. You went straight to voicemail.

    This was after disabling forwarding to all but Google Chat. I could make calls from GrooVe IP or any other Chat instance (like Gmail), but I couldn't receive a call.

    The solution: Disable and re-enable Chat.

    I had another VoIP client enabled in GV, which I turned on after initially setting up Chat. Apparently, unchecking the box next to that VoIP client didn't work. I needed to uncheck and re-check the Chat box to get GV to forward calls to Chat.

    Thanks to snrb Labs for such a great app!
  20. sailorcanfly

    sailorcanfly New Member

    I installed 1.2.1 version of Groove ip. it can't make a call outside and can't receive any call in. it seems that the software is calling from the screen. but calling voice could be heard and the called phone device did not ring at all. please help. I already do all the possible step such as uncheck phone device from google voice setting, sign out from gmail..........
  21. Shuttle

    Shuttle Member

    No to see how long it takes amazon app store to have the update?
  22. snrb

    snrb Well-Known Member

    You need version 1.2.2. Google made a change to their servers Friday morning. Any version before 1.2.2 will not be able to make outgoing calls.
  23. az_r2d1

    az_r2d1 Well-Known Member

    Amazon is still on 1.2.1
    ugh
  24. cottongin

    cottongin New Member

    I have the latest version, but whenever I shut the screen off I consistently miss incoming calls. I have wifi sleep set to never and have also enabled the wifi perf lock but nothing. If I am calling my gv number and then turn the screen on, it immediately goes through and starts ringing.

    HTC Thunderbolt
    CM7 Slayer's RC 1.6.1
  25. eezip

    eezip Member

    Hi cottongin,

    I was struggling with this same problem too.

    The issue is that GV does in fact call your phone, via Chat, but the call only comes through when your phone wakes up and polls the WiFi service. This might happen on the first ring, maybe the second ring, or it might not happen until after your GV voicemail has picked up. There's no way to know how many rings you'll get.

    It sounds like you suspect this too, which is why you've disabled WiFi sleep. Are you sure it's working and WiFi is never sleeping? Have you tried an app like Advanced WiFi Lock, just to be sure?

    As you probably know, not letting the WiFi service sleep eats up your battery life. Unfortunately, it's a tradeoff between possibly (probably?) missing calls, or drastically shorter battery life.

    While we're on the subject, is there an app that lets you set the WiFi polling/waking time? I haven't seen one, but if such as app exists that might allow you to find a balance between the tradeoffs I mentioned below.

Share This Page