Apple MAC OS X drivers for Captivate?Support


  1. vpcocco

    vpcocco Member

    Anybody come across MAC OS 10 drivers for Captivate?

    I tried setting device to 'mass storage' in USB Settings but Mac doesn't see device at all.

    Advertisement
    :
  2. macshield

    macshield Active Member

    Somone suggested putting the phone in debugging mode. Worked for me
    vpcocco likes this.
  3. vpcocco

    vpcocco Member

    so putting it in Debug mode allows the Mac to see it as a connected device?
  4. macshield

    macshield Active Member

    Yup. Put it in debug mode, plug it in then go to the notification bar and click usb connected then select mount. After that you should see the drive on your desktop.
  5. danbee46

    danbee46 Member

    I had the same question so I followed your advice. However, the "USB Connected" message only stayed on for about a second, then switched to "USB Debugging Connected" for another second, then switched to an icon. Pressing any of them only took me back to the window where I turned on the debugging to begin.
  6. ardyer

    ardyer Well-Known Member

    Make sure to go to Settings->Applications->USB settings and set it to mass storage. You'll have to turn USB debugging on again afterwards.
  7. danbee46

    danbee46 Member

    Thanks, that did it. A little confusing, but it works.
  8. breeox

    breeox New Member

    i followed this to the letter and can't get my iMac to recognize phone...i have USB debugging on and have mounted the drive but it doesn't show as a device on my machine...what could i be doing wrong? Should it REALLY be this difficult!?!? :)
  9. heavy73

    heavy73 Well-Known Member

    I have the same problem...does anyone have any ideas on how to fix this?
  10. dld2517

    dld2517 Member

    I have the same problem. Even when selecting USB Debugging and Mass Storage, no dice. Here is what I found. My problem is a VERIZON WIRELESS PROBLEM. Apparenlty, when you format a SD Card in the Fascinate, it creates some fake partition with a Verizon Wireless driver CD on it. Every time you format it in the phone this is done. For some reason Verizon decided to save a couple bucks and instead of printing CD's, just shoved a piece of code on the phone that adds this partition onto the card that looks like a CD to the mac.

    My mac will allow me to see this, and open it in Finder. What I find is a windows usb driver. Then about 10 seconds later, it disappears as it is unmounted and I get the message "The Disk You Inserted Was Not Readable By This Computer".

    SO.... who knows what file to delete when you rootkit the phone, so that this useless waste of a VZW CD Image, doesn't get put on there?

    Thanks,
    Dan.
  11. rmcusc

    rmcusc New Member

    Try downloading Titanium backup from the market. Click on "menu" while it is open and click "preferences" and activate "chuck norris mode" (seriously). Then use Titanium backup to either "freeze" or delete every app with Verizon in the name. This might get help get rid of the CD.
  12. dld2517

    dld2517 Member

    my computer actually mounted the SD Card... ONE TIME. and one TIME ONLY Since. Here is how it happened:

    I plugged it in last night at some point, and all of the sudden, ADB saw a device. Usually ./adb devices will show nothing connected, although System Profiler / USB shows the Samsung Android.

    So I messed around with ADB, pushed and pulled a file to the sdcard. Success.

    Still no dice on the mount.

    I ran mount_msdos -o nodev /dev/disk1 (because disk1 was the identifier shown in Profiler) and received this error:

    mount_msdos: Unsupported sector size (0)

    Ran gpt show /dev/disk1 and it gave another error. But then, and all of the sudden, the disk shows up and Aperture starts, trying to import photos. And the sdcard partition shows up on my desktop and it's called NO NAME

    And all my files are there.

    I have not been able to reproduce this. I have restarted, trashed USBMassStorage and Image Capture preferences, plugged and unplugged, and replugged, and replugged. Did it with USB Debugging on and USB Debugging off. Tried it telling to Mount and telling the phone Not to Mount.

    This is the most frustrating, piece of junk. And something tells me that it's all related to the Verizon Wireless CD partition that it tries to mount first. But maybe not, who knows.

    Titanium Backup requires Root Privileges.

    I have not had the chance, obviously, to get root on the phone.

    So Mr. Norris isn't going to be able to help me here.

    Can anybody think of something I'm overlooking?

    Thanks,
    Dan.

    PS - Better yet, can ANYBODY confirm reproduction of what I'm seeing? I have and parts and pieces of all of this on other forums, but not the type of intermittent behavior. The only thing I haven't done, is use a different cable between the phone and the USB Hub. Best Buy was out of USB A-USB Micro cables.
  13. dld2517

    dld2517 Member

    It was the cable.

    The Samsung supplied USB A to USB Micro cable was JUNK.

    Replaced it with a model from Radio Shack (at the high price of $27).

    Success!

    Now I have two partitions on my desktop. The Phone root directory and the SC Card partition.

    Thanks a lot SAMSUNG. Way to screw a person's weekend.

    -D.
  14. dld2517

    dld2517 Member

    So last night I plugged in my brand new cable and instantly two volumes showed up, as I said in the previous post.

    Well I get home today, fire up the PC, and the same thing happens as before. "The media is unreadable (Initialize, Ignore, Eject)" that is after the Verizon Wireless CD comes up and goes away.

    I am COMPLETELY FRAZZLED. Should I take this phone back? Is it defective? I wonder if I should keep on unplugging and plugging and see if the drives show up...

    Any thoughts?

    Still COMPLETELY CONFUSED
    -Dan.
  15. dld2517

    dld2517 Member

    I got it to come up again.... but I had to nudge it. It did not come up automatically.
    On the phone:
    USB Debugging: ON
    USb Connected -> Mount

    On the computer:
    1. Plug in the phone.
    2. Verizon CD Comes up
    3. Verizon CD Goes away
    4. Open Terminal
    Here is my terminal info:

    localhost:$ sudo mount -a
    Password:

    localhost:dev$ mount_msdos /dev/disk1 /Users/dandarden/sdcard
    mount_msdos: Unsupported sector size (0)

    localhost:dev$ gpt show /dev/disk1
    gpt show: error: bogus map
    gpt show: unable to open device '/dev/disk1': Unknown error: 0
    localhost:dev dandarden$

    THEN BAM! The No Name Partition pops up.
    It has the contents of the SD Card.

    WTF IS GOING ON HERE?

    -Dan.
  16. dld2517

    dld2517 Member

    Ok I have SUCCESSFULLY and REPEATEDLY achieved mounting of the SD Card over 12 times in a row without failure by following the below procedure.

    Look in About This Mac / More Info / System Profiler / USB and see the node point of your phone's SD Card. Mine is /dev/disk1

    Have a terminal window open with the following command ready to execute:
    gpt show /dev/disk1

    Connect the Phone
    In the Notifications screen, repeatedly, about five times do:
    1. USB Connection -> MOUNT
    2. Turn Off USB Storage -> TURN OFF
    Repeat x 5 quickly

    At some point when the Mac is confused as to what the hey is going on (after about the fifth time of mounting and un-mounting the card, Mount it ONE MORE TIME and immediately EXECUTE the command in the terminal window.

    You should see your Memory card appear with Read/Write access.

    I do not understand why this works, but it does. Something about probing the USB Interface.

    Any one of you Mac pros want to tell me what is going on here and why this works? So far this is the ONLY method that I have been able to reproduce OVER and OVER again successfully.

    This has made me SO mad.

    Thanks,
    Dan D.

    OS X 10.6.6, iMac Intel, 3.33 GHz, 4 GB Ram
  17. sremick

    sremick Well-Known Member

    Ouch. You can get them for as cheap as $0.85 from Monoprice (or $1.02 for heavier-duty and gold-plated).
  18. fgmart

    fgmart New Member

    Hi all, it is much simpler than some of the earlier posts. You don't have to buy a better USB cable. You don't have to do anything 5x and hope that it happens.

    Here is how I solved it.

    1. Turn on USB Debugging.

    2. Plug your phone into your computer.

    3. In your phone's notification area at the top of the screen, it will say "USB Connected" and then "USB Debugging Connected."

    4. Go to your phone's home screen and pull down the notification bar. There will be a row that says "USB Connected -- Select to copy files to/from your computer." Click there.

    5. A dialog will appear with two buttons: Mount and Don't Mount. Click Mount.

    6. The Mass Storage will appear on your computer. Whew!

    --fgmart
Loading...

Share This Page