Application settings reset


Last Updated:

  1. weakref

    weakref New Member This Topic's Starter

    Joined:
    Jun 28, 2011
    Messages:
    1
    Likes Received:
    0
    Hi all,

    I have a strange problem with my Samsung Infuse (rooted). For some of the applications, the configuration somehow just does not stick. In other words, when I install and configure an application, if I start it again some time afterwards, it starts as if on the first launch (e.g., welcome screen pops up and settings are all reset to defaults).

    Yes, cleaned up the cache
    Yes, un-installed and re-installed apps in question
    Yes, did factory reset
    Yes, tried different ROMs (stock 2.2, OTA 2.3 and Zeus)

    I have traced the issue down to /dbdata/databases/<package>/shared_prefs/<package>_preferences.xml. The scenario:
    1. Install an app
    2. Configure the app
    3. Go to the xml file and check that settings are what they supposed to be
    4. [Optional] Change file permissions to rw-rw-rw, just in case
    5. Wiggle the thumbs for a while (no pattern here, in some cases a forced kill of the app does, in other times, does not have the described effect. Sometimes the app stays configured for few hours and through resets, sometimes it is back to the virgin state in seconds)
    6. Restart the app
    7. Go back to the xml
     

    Advertisement
  2. Rush

    Rush {<>}~{<>}

    Joined:
    Jan 31, 2011
    Messages:
    18,742
    Likes Received:
    3,140
    Hello and welcome aboard.. I've moved your thread over to its device specific forum..hopefully to get it some faster responses.
     
  3. Mr. Lucky

    Mr. Lucky Well-Known Member Contributor

    Joined:
    Oct 27, 2011
    Messages:
    2,087
    Likes Received:
    508
    I had that problem happen once, but attributed it to having uninstalled a version from the (then) Market, and replacing it with an earlier, sideloaded version that I liked better. Configuring the app settings, deleting /dbdata/databases/<package>, and then rebooting solved it.
     

Share This Page

Loading...