Apps Disappearing On Restart


Last Updated:

  1. justinwah

    justinwah New Member This Topic's Starter

    Joined:
    Apr 16, 2010
    Messages:
    1
    Likes Received:
    0
    Sorry if this is a Noob question, I've searched but can't seem to find anything. I got my phone 3 days ago and noticed that when I restart my phone with a battery pull of regular shutdown some of my apps are uninstalled. There is a generic icon where it was on my home screen and its icon in my app drawer is completely gone.

    I can't run it even though the market says its installed. I have to redownload which isn't a big deal but its annoying.

    Also, I noticed that some of the disappearing apps are also not on the "my Downloads" list on the google market.

    Any help is appreciated. Thanks in advance.
     

    Advertisement
  2. Mastermind278

    Mastermind278 Well-Known Member

    Joined:
    Dec 11, 2009
    Messages:
    283
    Likes Received:
    97
    I had the same problem with my phone, as well as a few other board members. T-Mobile kept telling me it wasn't a 'known' issue, however I feel that they are incorrect about it. I even fought with T-Mobile to get my phone exchanged due to this. I got the new phone and the problem did not exist for a few weeks. Now it is back.

    Nonetheless, if you were to install one of BH_MAN's roms with a2sd (apps 2 sd) it should fix this problem.
     
  3. ps255

    ps255 Active Member

    Joined:
    Apr 16, 2010
    Messages:
    27
    Likes Received:
    0
    I was having the same problem for awhile.. so I talked to t-mobile and they had me go into the browser, and clear my cookies and so on, and then I had to shut off my phone and take out the battery for like 2 minutes and I haven't had the problem ever since.
     
  4. Exaqtion

    Exaqtion Well-Known Member

    Joined:
    Mar 2, 2010
    Messages:
    139
    Likes Received:
    6
    Actually no it won't...

    http://androidforums.com/all-things-root-behold-2/64090-another-small-r8-problem.html

    Im on BH_MAN's rom and it having the same problem. Didn't have the problem until I went to his rom. It will be worst actually because his roms based off the sd card, in which it seems is causing the problem.
     
  5. ScrumHalf

    ScrumHalf Active Member

    Joined:
    Mar 5, 2010
    Messages:
    35
    Likes Received:
    11
  6. Exaqtion

    Exaqtion Well-Known Member

    Joined:
    Mar 2, 2010
    Messages:
    139
    Likes Received:
    6
    How do I disable apps2sd? I already wiped the ext2.
     
  7. BH_MAN

    BH_MAN Well-Known Member

    Joined:
    Feb 17, 2010
    Messages:
    1,381
    Likes Received:
    1,667
    Sorry to Chime in here as I normally Don't Do this......

    But, You have No Clue what A2SD does based off that Comment....
    This is a Rom ( Samsung ) Issue that Has always poked it's head up here or there...

    With A2SD the App's are installed to the SDCARD and not to the Phone's Memory, Most time when an App has Dis-appeared it's due to Corruption or Stale Class found in the App ( Stale class = odex / dex ) and will not load the app...

    Down fall to A2SD, Slower loading at boot / Access time pending if your Running a Class 2 /4 /6 SDcard on your Phone...
     
    Mastermind278 likes this.
  8. Exaqtion

    Exaqtion Well-Known Member

    Joined:
    Mar 2, 2010
    Messages:
    139
    Likes Received:
    6
    I appreciate what your saying and I agree that I know nothing about A2SD, but I was just saying that I am on your rom and It didn't solve the problem because it happened to me. I also figured out that alot of my problems was because of my corrupted sd card but I again flashed your rom and ran it with no sd card, and again had my apps not there once I installed them and then rebooted. Just sharing my experience.
     
  9. BH_MAN

    BH_MAN Well-Known Member

    Joined:
    Feb 17, 2010
    Messages:
    1,381
    Likes Received:
    1,667
    That's no Problem at all, but like I had said... It's a Samsung issue & Not with a2sd.
    I've had better luck running a2sd regarding the issue, as the apps are saved to the sd... But, you could always do a Factory reset & the App should appear again on boot.. If not, then there is an issue like you had said regarding the sd & corruption.
     

Share This Page

Loading...