Apps downloaded but wont installSupport


  1. TheSpork

    TheSpork Member

    Over the last 6 months, I've bought several applications through the market without any problems. Yesterday, I bought Camera Zoom FX which downloaded just fine. But after downloading, it's been stuck at "Installing..." in the Download-section of my Market. It sais "Purchased" in the upper right corner (as usual) and I've received the receipt through e-mail. I tried to install another app afterwards, and that worked just fine. :confused:

    Its about 24 hours since I purchased the app now, but it's still trying to install. I've rebooted the phone at least 5 times, cleared the Market-cache before and after rebooting. I've even tried to remove my SD-card just in case.

    If I click and hold the application in the Market-app, the only choice I get is "Details", not "Uninstall" and the other options I usually get. When I go to the apps details, the button at the bottom is greyed out and says "Installing..". This means I can't cancel the installation or choose uninstall.

    My Hero has the official 2.1 version (fully updated) without root or other modifications.

    I've looked through the forum several times, including what seems to be relevant posts, but I can't seem to find any real solution for this problem. Anyone know how I can fix this? I think it's really strange that Android doesn't have any form of time-out or something for this..

    Advertisement
    :
  2. Slug

    Slug Check six! Moderator

    If you tap the "Installing..." entry at the top of the Downloads tab in the Market app, it should give you the "cancel download" option. :confused:
  3. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Perhaps you could temporarily remove your gmail account from the Accounts and Sync page in the settings? Hopefully that would stop it.
  4. nedamdam

    nedamdam Well-Known Member

    Or you could try to erase the downloaded file. To let it download again.
  5. TheSpork

    TheSpork Member

    @Slug: The problem is that the market-app has downloaded everything (the download finished a few seconds after I bought the app), so there is no download to cancel... It's the installation-process that never starts (even now after about 35-40 hours)

    @Xyro: I can't remove the account since it's in use (most likely by the market-app), so all I can do is a factory reset..

    @nedamdam: My sdcard/downloads-directory is empty.. I thought that was where the app put the downloads! Does it put it somewhere else? Do you know?
  6. nedamdam

    nedamdam Well-Known Member

    Force close market and erase cache (and data)
  7. TheSpork

    TheSpork Member

    @nedamdam: The force stop-button in settings - applications - manage applications - market is greyed out.. Tried Advanced Task Killer to kill Market, then clear the cache, but still same old...

    Does anyone know where market puts its downloaded files? I thought it was in /sdcard/downloads/, but that folder is empty.. That might be what causes the problem?! But still annoying that I can't stop the installation-process for the app..
  8. nedamdam

    nedamdam Well-Known Member

    If its not on the SD and its ont installed you wont have access to it I guess. I believe you are not rooted right? :)

    I think on mine its download (without the S). And you could just try to install a free app, what that will do.
  9. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    You can't get to the apps without root access as they're saved in the /system/ part of the internal memory (not the sdcard).

    How about installing the app with another app? Like 'Astro' for example.

    Obviously if you can't download astro from the market you'll have to hunt down the .apk for it (or any installer app) online and install it manually.
  10. TheSpork

    TheSpork Member

    @nedamdam: Nope.. No root! :( I wanted to give Android a chance running as supposed before I'd root the phone.. but now I see I might have to! If I wanted a mobile with restricted access and programs that just hangs 24/7, I'd buy a Windows mobile! ;)

    @Xyro: I did install Advanced Task Killer to kill the Market-app, and that worked like a charm. I think I've installed about 5 programs through the Market-app after this one froze. So if I could get the apk, I could install through Astro or something..

    I did hope I could fix this without a factory reset.. But now I'm not even sure that a reset would fix this problem! :cool:

    Edit: Spelling error
  11. nedamdam

    nedamdam Well-Known Member

  12. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    I don't mean killing any app. I mean uninstalling the app that froze mid update.

    So you already have astro installed? If you go to astro, hit menu and then tools you should get an application manager. If the problem app is listed in there you could try uninstalling it from there.
  13. TheSpork

    TheSpork Member

    @nedamdam: Everything is just as usual on checkout...

    Main page:

    Oct 6, 2010 androidSlide - Camera ZOOM FX View Order
  14. TheSpork

    TheSpork Member

    @Xyro: It doesn't show up on the list over running applications.. My problem is that it's downloaded but not installed..

    I'll paste a picture of the mobile with the problem.. Easier to explain with a photo than just text! This is how it's been for more than 36 hours now!!

    [​IMG]

    As you can see, the app is purchased and downloaded, but the install-process never started.. The button at the bottom (Installing...) is greyed out, so nothing to do there.. :confused:
  15. nedamdam

    nedamdam Well-Known Member

    Hmmm hmmmmm, what about disconnect all net. Data and wifi, and reboot. You should get a an error when opening the market. I kinda am not sure its really downloaded still :p . Btw, you could do a quick root maybe and stop the market, erase cache and data. Not sure if just root is enough.
  16. TheSpork

    TheSpork Member

    @nedamdam: If I disconnect, reboot and start the market it can't connect and then closes the app.. unfortunately, this didn't help!

    Maybe I just have to root my phone to see if I can find a fix..

    Still can't understand why they haven't put a time-out on apps / processes that hangs.. Would be kinda logical!
  17. nedamdam

    nedamdam Well-Known Member

    Hmm, what about taking out the SIM? And maybe put some other in. This I think if iirc that it wanted to me to sign on again. That could kinda erase the history of downloading. And when you put your old inside. And your old account. It should start downloading again.
  18. TheSpork

    TheSpork Member

    No luck there.. :(

    I switched off, used a UK SIM-card, started the phone and used it for a bit.. Even updated a few paid and free apps through the market! Then I switched back to my norwegian SIM, started the phone and no difference! :(

    Really don't know why this installation has stopped, and why there's no way to cancel / force it to stop it!!

    Do you have a rooted phone? any chance you could check if an installation through the market has it's own (individual) PID (process ID).. If so I should be able to root the phone and then kill the process..
  19. nedamdam

    nedamdam Well-Known Member

    Why dont you do it now ? There is no harm done in killing of processes :D. You have a 2.1 and you should be able to kill almost all. So kill all of what you know what is. Then kill of what you suspect might be it. And then kill all others off. :p You might have to then take out battery if you kill somehting and then phone hangs. But you could try.

    btw, as you changed the sim, you changed the gmail account right? I mean you didnt use the one you had before? (as you said updated payed apps , you had on the second account payed apps too?)
    TheSpork likes this.
  20. TheSpork

    TheSpork Member

    I can't kill the processes I want.. Needs root to do that! :( Tried to kill all I could, but not enough..

    I think I'll try to do a factory reset tomorrow.. Just need a backup-program first!

    Btw.. Do I lose anything if I root my phone? Will it do a reset or something, or is the data kept?
  21. nedamdam

    nedamdam Well-Known Member

    Rooting it takes 3 seconds with installing the APP doing it. If you use the one click root apps.(universal androot I think) you shouldnt loose any data. It will just say you are rooted.

    not sure it will help you though. but you could check if you cant erase the market data after.
  22. TheSpork

    TheSpork Member

    Maybe I can access the folder where the downloaded apps are.. And if it's there, I might be able to delete it to see if that helps.. As of now, I don't find the file on the system, and that's probably because of permissions..

    Do you know where the files are downloaded to? I don't have an app that can search other than sdcard...
  23. nedamdam

    nedamdam Well-Known Member

    Didnt Xyro said it up? (And I was always thinking its on the SD :( ) I think I have it on the SD :p . I mean before installing. Oh, that brings me to . Did you try to remove the SD and boot without it.

    After you root you could install file explorers that can explore the root partitions :p . Like the root explorer. Great app :D . but expensive.
  24. TheSpork

    TheSpork Member

    Xyro said it's in the /system folder, but there are 10 sub-folders or something there.. I've looked through it, so guess I can't see it without root! I can't find it on the SD-card either, so maybe that's the problem.. The market-app thinks it has downloaded the file, but in reality it hasn't.. And now it's trying to install a file that doesn't exist..

    Again.. Why no time-out!?

    But I'll have to look more into this tomorrow!! I'll see if I try rooting or a reset first! Either way I hope at least one of them can fix the problem!!


    I'll probably post more here tomorrow.. ;)
  25. nedamdam

    nedamdam Well-Known Member

    take the SD out before you sleep and reboot :) . And you should see it without ROOT. But you wouldnt have acces to it I guess . not sure. factory reset >>> all data and apps gone . Anyway waiting for the posts :)
Loading...

Share This Page