apps not downloading gs2 tmobileSupport

Last Updated:

  1. evilomen1027

    evilomen1027 New Member

    So I have a s2 with Ics I rooted it and installed aokp 4.1 ROM after updating clockworkmod It crashed my phone once I got it working again and back to stock I can no longer download apps from goggle play all it does it say downloading but that's it I am still searching threads but I don't have a lot of time to look so I want to post this to be a little faster so if anyone can tell me what's wrong or can point me in the right threads


  2. Atma

    Atma Well-Known Member

    Welcome to AF evilomen :ciao:

    Try going to settings > applications, tap on the 'all' tab at the top. Scroll down to Google Services Framework. Clear data and reboot your phone. See if that helps.
  3. evilomen1027

    evilomen1027 New Member

    I just tried that still doesn't work
  4. Atma

    Atma Well-Known Member

    Have you tried going to the Play Store from your computer and downloading an app?
  5. evilomen1027

    evilomen1027 New Member

    I don't have a PC right now but I did try from the browser on my phone with the same result
  6. Atma

    Atma Well-Known Member

    Try these suggestions I found at Google.

    • Try your download(s) using both wireless and cellular network connections, and ensure firewalls aren’t blocking access to ports required for Google Play (TCP and UDP 5228).
    • Make sure you've cleared the cache and data of both the Google Play Store app and the Download manager. Here's how:
      1. Visit Menu > Settings > Applications > Manage applications
      2. Tab over to "All"
      3. Select the Google Play Store app, and then tap "Clear data" and "Clear cache;" then, select Download manager and tap "Clear data" and "Clear cache"
    • You must be able to successfully sign into Google Talk to download Android apps on Google Play. Make sure your device is signed into Google Talk by following these steps:
      1. Go to your phone’s app launcher, and press the Talk app.
      2. If you’re already signed into Talk, press Menu, and then touch Sign out.
      3. Launch Talk again to sign in.

    If that doesn't help, I can only suggest a factory reset. If that doesn't help, I don't know what else to try except to reinstall your OS with Odin.

Share This Page