Apps rotation will lag - why?Support


Last Updated:

  1. Sim-X

    Sim-X Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    83
    Likes Received:
    24
    So this has been driving me nuts ever since froyo. I don't recall my phone ever doing this before 2.2

    I use Handscent for sms and lets say I open it up and are going through messages while in landscape mode. Once I am done I will hit home and set the phone back down. Then when a message comes in I will pick up the phone and check it and it opens handscent back in up Landscape mode even though I am holding the phone upright. There is at least a second lag before the phone switches it back to the correct position.

    This is not just with handscent but any other program that supports landscape. It's really annoying and I have hard reset more than once since froyo. The app remembers what position it was in rather than just dected the correct position in the first place. I have also tried calibrating but the phone knows what to rotate so the rotation works fine it's just the app likes to remember the last position it was in rather than the current. I don't recall this being a problem on 2.1

    Is there a way to fix it? It's trying me nuts
     

    Advertisement
  2. Sim-X

    Sim-X Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    83
    Likes Received:
    24
    Anyone?
     
  3. Sim-X

    Sim-X Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    83
    Likes Received:
    24
    Does this not bother anyone else but me?
     
  4. Sim-X

    Sim-X Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    83
    Likes Received:
    24
    Will someone please at least tell me if if there phone does the same as mine or not, jesus
     
  5. 84guy

    84guy Well-Known Member

    Joined:
    Feb 25, 2010
    Messages:
    126
    Likes Received:
    46
    http://androidforums.com/htc-evo-4g/140906-home-back-out-apps-landscape-2-2-a.html

    i had that same problem with the leaked .3 build. i ran the ruu for the .6 and it has sped up the rotation from 3-5 seconds to almost instant. i can still notice the rotation when entering an app but 1/2 second is better then 3-5. i also havent calibrated my gsensor with .6 and i did with .3 and noticed many problems(causing my android system to show 95%+ battery use)

    still scared to calibrate the gsensor as i dont know if its because i calibrated it or it was a problem with .3

    if you are on .6(the official evo 2.2) try doing a hard reset and dont calibrate the gsensor and see if that fixes it

    http://androidforums.com/support-troubleshooting-evo-4g/141369-how-fix-froyo.html

    if its the 1/2 second that bugs you then youll have to live with it. seems like with 2.2 they pause everything in the background, even the rotation, maybe to save power?
     
    Sim-X likes this.
  6. Mr. Ed

    Mr. Ed Well-Known Member

    Joined:
    Jun 27, 2010
    Messages:
    6,675
    Likes Received:
    1,464
    I am on .6

    I calibrated the g sensor with no issues, and ran spare parts and changed everything to "fast" and it fixed my issues with laggy lanscape to normal
     
    Sim-X and EarlyMon like this.
  7. Sim-X

    Sim-X Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    83
    Likes Received:
    24
    Thanks for the posts guys - what's odd is I am on the .6 build (never even tried the .3 build) - after that I have hard reset at least twice. I have even calibrated a few times now. I still have the lag - it's very fast if I am lets say in the handscent ap rotating the phone, the lag is only there when I back out of an app and go back in.

    I sure wish they would get rid of this, 2.1 never did this. It's really annoying

    Guess I don't know what to do, I could try hard resetting again but that doesn't seem to help any. I will look into spare parts.
     
  8. Mr. Ed

    Mr. Ed Well-Known Member

    Joined:
    Jun 27, 2010
    Messages:
    6,675
    Likes Received:
    1,464
    I take what I said back...my laggy swap is back :(
     
  9. dabigcheezze

    dabigcheezze Well-Known Member

    Joined:
    Jun 10, 2010
    Messages:
    49
    Likes Received:
    38
    Been doin this to mine too since 2.2..... This is bugging the hell outta me....c'mon HTC....do SOMETHING...
     
  10. Sim-X

    Sim-X Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    83
    Likes Received:
    24
    Well I thought I would post an update - I ended up doing a hard reset. The odd thing is I have hard reset twice since I got the froyo update. However the first 2 times (both times I had the problem with rotation lag) I reset using the settings under SD & phone storage.

    When I reset last night I used the bootloader to reset it. The lag is now gone (you can still see it rotate but it's fast now where as before it would take up to 5 seconds to kick in only when going back into an app though)

    So anyone else having this problem I would just hard reset using the key combination. I have not recalibrate the g-sensor. I am also keeping an eye on what I install to see if a certain app brings the lag back but so far everything I have installed it seems fine. Not sure what was stuck in the phone or what was going on, I never used a task killer or anything. It was driving me crazy since a lot of time I would back out of an app in landscape and go back in there portrait and it would lag.

    So anyway I will report back if it comes back but hopefully it stays gone.

    Hope this helps some of you having the issue, it is something I really couldn't find any solution for until now.

    The only thing this does prove is that it does not have anything to do with the build # (I never used an unofficial froyo update) and my hardware version is 3. Must be something in the software. Like I said before the lag only really happened when going back into an app that I left in landscape when I backed out. Just rotating the phone it was always fine. Still it drove me nuts enough to hard reset as I backed out of handcent a lot in landscape and would go back in portrait and would have to rotate the phone or wait 5 seconds for it to kick in.
     
    novox77 and EarlyMon like this.
  11. novox77

    novox77 Leeeroy Jennnkinnns! VIP Member

    Joined:
    Jul 7, 2010
    Messages:
    3,965
    Likes Received:
    3,256
    Hey EarlyMon:

    you might want to add that to your 'how to fix froyo' thread. wipe from recovery, not from the Android Settings > .... menu.
     
  12. EarlyMon

    EarlyMon The PearlyMon Moderator

    Joined:
    Jun 10, 2010
    Messages:
    57,614
    Likes Received:
    70,271
    Done and done!

    Thanks Sim-X!

    (Cracks me up that a guy in another thread said that advice worked for a half-dozen very minor, unimportant issues.)

    Wish we all knew about this one earlier. Typical user contamination on my part - we were used to this from root...
     
  13. Sim-X

    Sim-X Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    83
    Likes Received:
    24
    You know I'm not sure how common this is but I couldn't really find any help on it. I wish there was a better way or it would be nice to know what actually causes it so you don't have to hard reset. For me it was worth hard resetting even though it takes forever for me to set my phone up again. It drove me just bonkers, only reason I put it off cause I wasn't sure if it was going to work.
     
  14. EarlyMon

    EarlyMon The PearlyMon Moderator

    Joined:
    Jun 10, 2010
    Messages:
    57,614
    Likes Received:
    70,271
    That's exactly the way it's been for all of us:

    1. Put it off not believing it could make a difference.

    2. Try to convince others to not put it off when you see them suffering the same thing.
     

Share This Page

Loading...