Arc won't connect to PC in mass storage modeSupport


  1. WC_EEND

    WC_EEND Member

    Hello everyone, I (well, more likely my PC) seem to have developed an issue, causing me to be unable to access the SD card in my phone (see picture below). I tried plugging my Arc in different USB ports, which made no difference at all. I then tried with my sister's HTC Desire and my other sister's HTC wildfire which yielded the same result. Connecting the phone via fastboot and flashing things using fastboot works fine, but when I plug any android phone in using mass-storage mode then it no longer works. As you can see in the picture below, it's there, but I cannot access it.

    [​IMG]

    the prompt says "please place a disk or other suited media in Removable disk (I: )" by the way (translated from Dutch)

    any help would be greatly appreciated.

    Advertisement
    :
  2. joemonkey

    joemonkey Well-Known Member

    i have a mac and i hardly connect using USB. have you try using bluetooth to connect as a work around. if you try to move files between your computer and phone, try bluetooth.
  3. WC_EEND

    WC_EEND Member

    Bluetooth is ok for moving fairly small files, but for moving things like 3GB worth of games (ScummVM emulator), USB is more convenient, and that's why I would like to have my USB working again.
  4. Pottertons

    Pottertons Active Member

    I too, all of a sudden, am having the same problems with my arc. It's annoying, because i use my phone so much, that I just extract .rar files right to it. Now the drive can't be accessed.
    Instead, i now have to extract or save to the desktop, and then drag the file over. makes no sense.
  5. Josh-SonyXperia

    Josh-SonyXperia Well-Known Member

    One question, do you guys have PC Companion installed on your computers? (with the exception of joemonkey who has a mac)
  6. Pottertons

    Pottertons Active Member

    Yes i do. I just installed shortly before i posted my response. Come to think of it, it was working fine up until that point. Thing is, it never did that before, even with PC companion installed.

    Uninstall?
  7. Josh-SonyXperia

    Josh-SonyXperia Well-Known Member

    Yes I'd suggest to uninstall PC Companion, reboot the PC and re-install PC Companion again. If possible try using a different USB port on the PC. This might help for example I have a Neo and my PC has 2 USB ports on the front (desktop PC) and if I connect on the top one my phone charges but is not recognized but if I use the lower one my PC recognizes it right away, weird if you ask me though but try it and lets see if it works out for you.
  8. joemonkey

    joemonkey Well-Known Member

    i found an app Samba, it uses wifi to connect to your laptop (i have a mac) and all the directories show up in the finder. not sure if this works for PC users.
  9. Pottertons

    Pottertons Active Member

    PC companion has this feature included in it's latest edition. However, i prefer to connect via USB becasuse it kills two birds with one stone. Charge/view SD card.
  10. velcis

    velcis Member

    Dont kill animals please :p

    Look, you tried to Uninstall Arc UMS Drivers? Take a look at Devices in PC, when you connect the USB Cell. Than click right click mouse, in the Device connected than tape Uninstall Driver. Reboot windows and plug in your device, or try another.

    You can download too and app callled USB Widget.

    Take a look :)
Loading...

Share This Page