ARM Cortex A9 Android TV box stuck on Android logo

Last Updated:

  1. HentaiGami

    HentaiGami Member

    So I am in possession of an Android 4.0 OS Internet ARM Cortex A9 3D HDMI Full HD 1080P TV Box Media Player. It's actually this one ht tp:/ /

    This device has no reset hole at the back. The player will not boot. Whenever I turn it on it just shows the Android logo and nothing happens. The blue light doesn't blink, and nothing is responsive. I've tried leaving it on for hours and hours and turned it off and on many times, but it will never go past the Android logo. It has been like this from the beginning.

    Is there any way I can get this device unstuck or reinstall it? I've read the firmware upgrade has to be done from within a menu on the device, so this is impossible for me.

    Any help would be much appreciated, thanks!

  2. Dual_HD

    Dual_HD Well-Known Member

    Buy a good one! many **********, alibaba sellers are selling troublesome boxes. even they are using same chipset as good android tv box like Geniatech, linx, pivos. but software and rom are really unstable.
  3. heat57

    heat57 Well-Known Member

    Need more info about the box.

    1. Make/manufacturer
    2. ROM it came with 4.0.4 etc.
    3. Model RAM i.e. 512MB or 1GB
    4. Exact chipset and processor description

    As the first reply says, there are several brands being marketed with the ARM Cortex A9 chip in the boxes we need to know which one as each have slightly different ROMs. However, pretty much all of them have their origin in the Geniatech equivalent as they are the main manufacturer of all boxes except those based on Rockchips. So you might find your box xyz brand is actually a Geniatech M1 or M3 based box.

    The Geniatech based boxes can also have a reset hole at the bottom of the box, which you need to press something like a paper clip into (until it clicks) and hold in position whilst you plug the power cable into the box then it should start the recovery. Usually you would download the latest firmware for your box, which comes in a .zip file that you extract and then rename the .img file found in the unzipped folder and rename it to update.img. Put this file on a USB stick (formatted in FAT32) and insert it prior to putting the box into recovery. When discovered follow the onscreen instructions.
  4. HentaiGami

    HentaiGami Member

    I understand this info would come in handy but there is no name or mark on it. It just says "android tv box". It's the same as in the picture. I don't know which android version it has since it never booted. The ad said "Android 4.0 OS Internet ARM Cortex A9 3D HDMI Full HD 1080P TV Box Media Player". I've searched the device all over but can't find any reset hole where a paperclip would fit.
  5. HentaiGami

    HentaiGami Member

    So I've opened the device up. On the chipset it says "A9- REV1.3 2012-04-10". On the motherboard it says "HD18 REV1.0". Hope this helps.
  6. stane1983

    stane1983 Well-Known Member Developer


    I think this can be useful info for you. Don't know who is manufacturer, but seems you have really old version of f16ref device mentioned on j1nx's site...
  7. Lawlost

    Lawlost Member

    I have exactly the same issue, have you worked out how to resolve it yet? If I ever get mine working I will post up how, it is so frustrating.
  8. HentaiGami

    HentaiGami Member

    Nope :( Still the same.
  9. colchiro

    colchiro Well-Known Member

    THIS. ^^^^^^^

    Consider the cheap Chinese knock-offs disposable. :D (You get what you pay for.)

    Look at all the posts with no replies in this forum where people have no-name junk that won't boot.
  10. Lawlost

    Lawlost Member

    Opened my one up and found the reset button, not that it has helped so far, pressed in whilst powered up no change. Held the reset button whilst powering up still no difference. Anyone able to help :confused:
  11. Lawlost

    Lawlost Member

    Hentai think I have figured this out and got mine working this evening. I have been powering mine via the mini usb as it came with a European power plug. I live in the UK and could not use it. Today I bought from poundland a socket converter for those visiting the uk. The power supply plugged into the converter I plugged it in and the device booted up :D

    Really hope this helps
  12. HentaiGami

    HentaiGami Member

    Nope... I've been using a normal power cable since the start :( Thanks for the reply though, and good luck with your device :)
  13. Lawlost

    Lawlost Member

    Darn really thought yours might have had the same issue :confused:
  14. blutch

    blutch New Member

    I had the same issue with my TV box(with logo MX on top). The reset button is inside the AV connector on my box. I powered the box on while holding a pin inside the AV connector. In the recovery menu I chose for wipe data with factory reset. Rebooted, issue solved...
  15. HentaiGami

    HentaiGami Member

    So I have the perfect solution. I bought a Raspberry PI, installed it with Raspbmc and it works like a charm. This A9 android box will be smashed against the wall, which is the best use I can make of it I think.
  16. Mike8519

    Mike8519 New Member

    Coworker brought in one of these knockoff boxes for me to take a look at that will not boot. Opened it up and the board is labeled as "HD18 v2.2" Hardware specs and board layout are an exact match for the Midnight MX2.

    I can get into recovery via the switch on the board but even wiping to factory defaults does not work and selecting reboot in recovery causes it to hang permanently. I also cannot connect to it via ADB over network.

    Any ideas?
  17. moergie

    moergie New Member

    Guys any luck on this? I too have the same problem.

    When i put (something like) an toothpick into the AV port, i get into the recovery menu.
    But wipe data/cache and select factory default doesn't help...
  18. craigm

    craigm New Member

    mine is a 4.2.1 an im having the same problem?
  19. Animal_King

    Animal_King New Member

    Just go to XDA forum and check this post, download the Matricom image and you are set. Its for HD 18 v2.21 (Generic MX tv box 1gb / 8gb, also known as g18ref box or mx2ref box or an android TV Box or a generic MX Droid TV etc.

    The image is ROOTED and flashing it UNBRICKS a device in case it is bricked.


    replace ; with :
    replace , with .

    Can't post links yet.
  20. InsuranceLiable

    InsuranceLiable New Member

    Did you get anywhere with this. I am in the same situation and have no way of resetting or getting into recovery mode.

    Any ideas?
  21. lowboi87

    lowboi87 Member

    Did u fix it u have to do a firmware update if u didnt fix it by now ill repost a link to do it
  22. Leandrogoe

    Leandrogoe New Member

    I had a similar issue with another tv box I bought at dx (Tayun Android 4.2 Dual Core Google TV Box).

    I played with some developer settings and then the box stopped booting (got stuck in the andriod logo image).

    To my frustration it had no reset button.

    In the end I found that I could boot it into safe mode using an USB wireless keyboard with volume options. Press and hold volume up button during boot is apparently the standard to enter in safe mode for most android tablets.

    In my case, the volume up command is get by pressing Fn + F2. So I pressed and hold Fn + F2 during boot and bingo!, the device boots into safe mode correctly. I then undo the setting causing the problem and the device now boots perfectly.

    Please note this did not worked with the remote control that comes with the box (only with the keyboard). Apparently the drivers for that device gets loaded somewhat later in the boot process.

    I guess safe mode may do the trick for you, but I suspect something similar could be done to put the device into recovery mode also.
  23. mrrod

    mrrod New Member

    I bought one if these mx boxes about 6 months ago, didn't get past turning it on due to the remote not working. Bought a minix x7 2 weeks ago so this shite mx box is going in the bin.
  24. james1089

    james1089 New Member

    I had problems also, however since a new firmware release it has been rock solid. Hasn't froze or failed to boot it's dated 29 May 2014. Had to do some searching but its quite easy to install once in recovery.

    I just extracted and copied just the zip file to usb, booted into recovery, factory reset and flashed at last the box it should be.
    Removed link better find it yourselves,
  25. napster100

    napster100 Member

    Please post a link.... I've googled so much my fingertips are actually aching :'(

Share This Page