ASUS coupon > Register device > incorrect serial no!!Support


Last Updated: 2013-03-29 11:27:47
  1. shaneydroid

    shaneydroid Well-Known Member

    Thought I would take advantage of the ASUS early adopter coupon offer but when I go to register the device, it tells me the serial number is wrong.

    I have checked in about tablet and on the box and both show exactly the same serial.

    I have checked and quadruple checked both the box and the tablet and what I have typed and they all match up perfectly.

    What's going on?

    Advertisement
  2. mistertonmick

    mistertonmick Member

    Where did you buy your Nexus 7,you have to buy it from Google or Asus direct to qualify,the number 0 and the letter o can be a problem,but what baffles me is that I thought you would have registered the device in the initial setup.
  3. shaneydroid

    shaneydroid Well-Known Member

    I bought it from Google Play.
    Never thought to register it to be honest.

    Tried different variations of the letters and numbers to no avail.

    I do notice that if I start the page again and enter the serial number then the make and model boxes automatically fill themselves in (EEEpad/Nexus7) but if I change any of the letters or numbers then it doesn't fill in.
    So it appears to be recognizing the serial number but not.
  4. neilgarr

    neilgarr Active Member

    same here, i bought mine from ebuyer tho
  5. JanComputerman

    JanComputerman Well-Known Member

    Watch out for leading and trailing spaces
  6. GingerRob

    GingerRob Well-Known Member

    I have had the same issue. Bought mine direct from Google, but does not recognise the serial number. I did read somewhere, that the email you send proof of purchase too was just bouncing back. Sounds like ASUS have been inundated.
  7. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    Try calling the below number, to see if they can help you with your issues.

    Call 855-83-NEXUS for support
  8. CarsnGadgets

    CarsnGadgets Well-Known Member

    I have the exact same problem, I have tried caps on and off and 0 instead of O etc.

    I have sent a ticket to support and emailed them.

    Twitter said that there was a problem with the site they were aware of, so I'll try again in a day or 2.
  9. shaneydroid

    shaneydroid Well-Known Member

    Yea I have seen plenty of reports from people with the same problem now.
    Tried emailing but no reply so far but I'll give it a couple of days.
  10. M81162

    M81162 Active Member

    The serial number in the Nexus is not the one to register with. There is a SSN number on the box which is different. Mine begins with C.

    I didn't see anything about an early adopter coupon, do you have a link?
  11. shaneydroid

    shaneydroid Well-Known Member

    I have tried that number also which failed.
    The serial number shown in "About tablet" shows the same number as on the box.

    The coupon has been mentioned in several articles on techradar and similar sites but here is the ASUS page: ASUSTeK Computer Inc.

    It can also be done through Google Play but theirs is only valid for N7s bought in the last couple of weeks I think.
  12. 8Ball

    8Ball Well-Known Member

    The serial number is the one that starts C7OK and it's the letter O at the start not a zero. Took me a few tries to find it
  13. shaneydroid

    shaneydroid Well-Known Member

    Although I have now tried that code 3 times, at the 4th attempt it worked!!

    However, my registration email has only told me I can get 10% off all orders and says nothing about
  14. M81162

    M81162 Active Member

    I got a 10% off code as well.
  15. srikar

    srikar New Member


    It worked very well thanks a lottttttttttttttttttttt for this.:)

Share This Page