[AT&T] Can't seem to succesfully root my s4 active

Last Updated:

  1. Just got a new phone. So far I have tried 2 ways to root my Galaxy S4 Active. I tried using geohots activeroot method, and yes I enabled "unkown sources" in settings but after installing it doesnt say that its rooted like it should. When I start the activeroot program It crashes and I get a message saying something like "unfortunatly this program has stopped working". So I uninstalled that. The second method I tried was using kingo, and yes I enabled usb debugging. When I connect my phone to the computer kingo starts to look for my phone but never finds it, just says "not connected". Are there any other methods? Im pretty sure I followed geohots instructions to a T. And I'm not sure why kingo won't find my phone...any help would be greatly appreciated. Thank you. Heres all my phone info.

    Model number-SGH-I537
    Android version-4.3
    Baseband version-I537UCUBML2
    Build Number-JSS15J.I537UCUBML2

  2. Mr. Lucky

    Mr. Lucky Well-Known Member Contributor

    Both of those methods are usually quick, easy, and foolproof. It sounds like a communication problem with your computer. Are you using a pc (i.e., not a Mac), and are you using the OEM's USB cable?
  3. I am using a pc with windows xp 64 bit. I read that I need the kies3 from samsung before i can use the kingo method, but there is no compatible version of kies3 for xp 64 bit. So I went on my grandmas laptop which has regular xp, I got kies3 on the laptop, then tried kingo, it did recognize my phone and i was able to go through the rooting process, however in the middle of rooting, a message appears at the top of the phone saying that it has blocked an unauthorized program or something like that, but kingo continues the proccess and then the phone restarts, then kingo finally says checking root status, and then says root failed device not supported. Is it because my phone blocked an important step? Can I disable any kind of built in protection that could be causing this? I dont have any apps that would do that, no virus protection or anything. Any ideas? And yes i am using the oem usb cable
  4. I tried geohots activeroot again. This time when I start the app, it says Only the galaxy S4 active is currently supported. Which is funny because thats what I have =P anyways is it possible that I just have a newer version of this phone, or software, and the current root methods wont work for me? I was so close to getting the kingo method to work except for the phone blocking something that may be important.
  5. I think it's because I'm running 4.3 I am seeing people with the same problem rooting the I537 while running 4.3 hopefully a working method will emerge soon.
  6. Mr. Lucky

    Mr. Lucky Well-Known Member Contributor

    Kingo definitely works with 4.3 (I used it, and that's what I have). Also, you definitely do not need kies3 (I never had it). The "blocking" message is probably the computer's anti-virus/malware program kicking in. Try Kingo again with it disabled. All root processes lwork via OS exploits, so it's not surprising this is happening.
  7. It's not my computer that is the problem. When trying to root with kingo, the phone itself says that it blocked unauthorized access displayed at the top of the screen. The phone restarts and then kingo checks root status, and says that it failed and that it's not compatible. What is the model of your phone? Is it exactly the same model as mine? I gave the exact model om my first post.
  8. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Did u download all s4 drivers and reboot your PC/laptop this will kill any background process running on your PC/laptop and what windows you are using
  9. Yes I restarted several times. My pc is xp 64 bit and I can't even get kingo to find my phone on that. The laptop is 32 bit xp with service pack 3 which kingo will see my phone and go through the rooting process, but is not successful. When it's trying to root a message pops up on my phone saying it blocked unauthorized access. Then kingo says root failed cause my device is incompatible.
  10. Unauthorized access to a secure area has been blocked. That's the exact message on the top of my phones screen when trying to root with kingo. Kingo then says "Root failed. Not support"
  11. Mr. Lucky

    Mr. Lucky Well-Known Member Contributor

    Verify that you have "USB debugging" (under Settings > More/Developer options) and "Unknown sources" (under Settings > More/Security) enabled.

    Not necessary; Kingo detects the device and downloads any needed drivers automatically.
  12. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    You can't use kingo to root it doesn't install any recovery on the android device and you have to have the drivers on your computer cause it configure them so the root option will appear . and far as I know Twrp is used with Samsung but once u root how will you enter a recovery if it isn't one :eek::screwy::what:

    Was your phone a i337 or i337m
  13. Brainz...My phone is I537 I gave all my specs in my first post. So u are saying I can't use kingo to root? I can get kingo to start rooting, the problem is my phone blocking something during the rooting proccess. Says that it blocked unauthorized access on the top of my phone.
  14. JimStinson

    JimStinson New Member

    Model number-SGH-I537 (ATT S4 Active)
    Android version-4.3
    Baseband version-I537UCUBML2
    Build Number-JSS15J.I537UCUBML2

    Followed instructions to the T. Dotted all the I's. Went to geohot.com/active. Clicked on the lambda. Got a screen full of computer gibberish.

    Any ideas?

    I appreciate the help!

  15. I have come to find that there is currently no working root method for the Ml2 build. I hear there is one in the making, if you go to Xda-developers.com in the forums you can find the thread about it.
  16. JimStinson

    JimStinson New Member

    I am beginning to like my S4 Active more and more!

    Hope they come up with a root soon.
  17. Yeah I like mine too, it's durable and poweful. Can't wait to be able to overclock it.
  18. BadDroid007

    BadDroid007 New Member

    I also have an i537 running 4.3 JSS15J.i537UCUBML2, and having the same problem. When I click activeroot, I get a message
    "Only the Galaxy S4 Active is currently supported. If you see this error and think you have the right phone, email geohot+activeroot@gmail.com"
    Anyone know how I can get root access with an app???

Share This Page