[AT&T] Experts, Please help with rooting Android 4.4.2 on Galaxy S4


Last Updated:

  1. rebel2401

    rebel2401 Member This Topic's Starter

    Joined:
    Mar 18, 2014
    Messages:
    5
    Likes Received:
    0
    Hi there, I am a pretty tech savy guy, I dont know why I am having so much trouble rooting my galaxy S4,

    I have tried 2 methods so far, and followed the instructions carefully, I dont know why its not.
    The first method are the instructions in this video here:
    https://www.youtube.com/watch?v=eLHt_HCWwr0

    The second method is using Kingo, the error I got there is:
    It said "Root Failed! Flash Failed"

    any ideas why its doing this or more importantly, how to fix it? It's a pretty fresh phone so I can't imagine I could have done much to cause it difficulty.

    Here is a pic of the error I'm getting
    [​IMG]
    picture share

    I appreciate your help really need to root it as soon as possible
    Thank you
     

    Advertisement
  2. mana0216

    mana0216 New Member

    Joined:
    Mar 18, 2014
    Messages:
    2
    Likes Received:
    0
    i am having the same problem, tried 4 different ways all failed
     
  3. windsorclarenc

    windsorclarenc Well-Known Member

    Joined:
    Nov 6, 2011
    Messages:
    719
    Likes Received:
    629
    4.4.2 isn't rootable yet. I'm sure in time it will be though.
     
    kevp75 likes this.
  4. rebel2401

    rebel2401 Member This Topic's Starter

    Joined:
    Mar 18, 2014
    Messages:
    5
    Likes Received:
    0
    I do believe it is rootable.. thats what all the guides I followed said
     
  5. g0lden

    g0lden Well-Known Member

    Joined:
    Oct 20, 2012
    Messages:
    202
    Likes Received:
    39
    At this time, the only way to root on 4.4 is to downgrade to mk2 and flash a rooted 4.4 rom with safestrap. http://forum.xda-developers.com/show....php?t=2680868
     
    kevp75 likes this.
  6. rebel2401

    rebel2401 Member This Topic's Starter

    Joined:
    Mar 18, 2014
    Messages:
    5
    Likes Received:
    0
  7. windsorclarenc

    windsorclarenc Well-Known Member

    Joined:
    Nov 6, 2011
    Messages:
    719
    Likes Received:
    629
    Because it's YouTube. People put up fake stuff like that all the time. Especially if they can lead you away from YouTube with a download link for their software.
     
    g0lden likes this.
  8. OrKo

    OrKo Well-Known Member

    Joined:
    Feb 20, 2011
    Messages:
    1,059
    Likes Received:
    108
    The G2's 4.4.2 update just got root, I'm sure you guys aren't far behind.


    By the way my fiance has one of these, I'll be around..
     
  9. mrao

    mrao Well-Known Member

    Joined:
    Sep 30, 2010
    Messages:
    82
    Likes Received:
    22
    There is no root yet for the AT&T S4 on 4.4.2. There is a way though to flash Safestrap recovery, and get a custom rom on, though supported roms are limited. Like @windsorclarenc said, it should be rootable soon.. I feel it will be rootable the day the 4.4.2 bootloader is cracked..
     
    kevp75 likes this.
  10. rebel2401

    rebel2401 Member This Topic's Starter

    Joined:
    Mar 18, 2014
    Messages:
    5
    Likes Received:
    0

    Any word if 4.4.2 has been rooted yet?
     
  11. kevp75

    kevp75 Member

    Joined:
    Apr 20, 2014
    Messages:
    6
    Likes Received:
    1
    no. and now that the nc1 update is out I doubt there will be.

    Developers arw concentrating more on roms flashable thru the work arounds... which wirk great btw...
     
  12. rebel2401

    rebel2401 Member This Topic's Starter

    Joined:
    Mar 18, 2014
    Messages:
    5
    Likes Received:
    0
    well can you tell me how to do this?
     
  13. kevp75

    kevp75 Member

    Joined:
    Apr 20, 2014
    Messages:
    6
    Likes Received:
    1
    bill.g likes this.
  14. HugoR

    HugoR Active Member

    Joined:
    Oct 12, 2012
    Messages:
    31
    Likes Received:
    3
    so how can I flash kitkat on my rooted mk2?
     
  15. kevp75

    kevp75 Member

    Joined:
    Apr 20, 2014
    Messages:
    6
    Likes Received:
    1
    Look above
     
  16. jerryag

    jerryag Well-Known Member

    Joined:
    Feb 7, 2012
    Messages:
    194
    Likes Received:
    47
    Is there anyone actively working on a root method for this phone?
     
  17. kevp75

    kevp75 Member

    Joined:
    Apr 20, 2014
    Messages:
    6
    Likes Received:
    1
    No.
    #1 the bootloader is locked
    #2 there are workaround methods that work extremely well, so devs are concentrating more on roms
     
  18. KupKrazy

    KupKrazy Well-Known Member

    Joined:
    Jun 26, 2010
    Messages:
    387
    Likes Received:
    113
    I just wanted to add my 2 cents - that video above is for the International version and not AT&T.

    I was looking to upgrade to the GS5 but they never came out with a 32GB version, so I got tired of waiting and decided to do the workaround with my GS4 and it so far works great. I was on the NB1 firmware and I had to downgrade to MK2 to root and flash a custom ROM with the safestrap recovery. There are some decent ROMs out there and like kevp75 said, it works really well. It takes a bit of patience and following instructions, but this gave my GS4 a new lease on life and I probably will hold off until the GS6.
     
  19. speedlever

    speedlever Well-Known Member

    Joined:
    Jun 17, 2012
    Messages:
    602
    Likes Received:
    69
    And as of 6/15, the GS5 and GS4 Active running 4.4.2 have been rooted by geohot over at XDA. I haven't heard about the regular GS4. But I believe the GN3 is also invited. It doesn't trip the Knox detector either.
     
  20. g0lden

    g0lden Well-Known Member

    Joined:
    Oct 20, 2012
    Messages:
    202
    Likes Received:
    39
    It works on the regular S4, but only on NC1.
     
  21. Can0dope

    Can0dope Well-Known Member

    Joined:
    Jun 3, 2011
    Messages:
    511
    Likes Received:
    112
    Can we get a link? I need to root this beast ASAP. I just got the phone and already had to update around 20 apps. That's a lot of bloat!

    Edit: I found a root method on xda by geohot. Easiest root ever. Now to find a recovery that works...
     
  22. Marc_G

    Marc_G Well-Known Member

    Joined:
    Feb 5, 2011
    Messages:
    160
    Likes Received:
    7
    Could you please post the link to the one you are using (root thread at xda)... I want to make sure to use the right one. Thanks
     
  23. speedlever

    speedlever Well-Known Member

    Joined:
    Jun 17, 2012
    Messages:
    602
    Likes Received:
    69
  24. Can0dope

    Can0dope Well-Known Member

    Joined:
    Jun 3, 2011
    Messages:
    511
    Likes Received:
    112
  25. mrao

    mrao Well-Known Member

    Joined:
    Sep 30, 2010
    Messages:
    82
    Likes Received:
    22
    Towelroot won't unlock the boot loader. So no custom ROMs for the ATT or VZW devices yet.. I'm not sure if safestrap works.. You might want to check it out
     

Share This Page

Loading...