1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[AT&T] [guide]How to get Google Wallet working on AT&T GS3

Last Updated:

  1. nesto1

    nesto1 Well-Known Member

    Ok, I have done this and it works perfectly. All you do is follow the instructions from the post and it will work.

    Before heading over to the thread, download Root Explorer if you do not already have it(needed for the editing of your build.prop)


    For NEW attempts - stop at step 10.

    If you've done this mod already, focus on steps 11-16

    Google wallet fix for SGS3 US variants AT&T, T-MOBILE, US Cellular, VERIZON, etc - xda-developers

    Screen shot confirming it is working (already spent some at local Mcdonalds - I have my Credit/Debit card linked already but can't show screen shots because it lists my name in the app.



    JJLuchiano and kool kat2 like this.
  2. nesto1

    nesto1 Well-Known Member

    Tried out the new functionatily today where you can use ANY debit/credit card.

    Added my debit card, and it worked perfectly.

    bradhoschar likes this.
  3. ryandelman

    ryandelman Well-Known Member

    Did this, and while I'm happy to say it works perfectly (used my phone at a local convenience store yesterday to buy my lunch!), the install of Wallet seems to have broken my phone's NFC tag reading abilities.

    In short, it appears as though Wallet has essentially commandeered the entire NFC function capability of the phone, and I tested this to confirm.

    What I did was (after multiple times of swiping over my TechTile tags without success, then resetting NFC in the Settings menu, then rebooting, etc.etc.), I decided to look in the Wallet settings and noticed the default app timeout was set for 5min. So, for Sh*ts and giggles, I thought I'd try and move that to 30 min. I then waited 20min to try and scan one of my NFC tags and what do you know? It worked, but then when I waited another 15min, like clockwork, I had to go into Settings in the phone's main setting menu and turn off NFC and then back on again, and the tags again became readable.

    I have also run into at least one other person on XDA with same exact issue, but to date, no devs have weighed in, I'm guessing because so few people have experienced this problem (realistically, there are probably no more than a handful of people who actually run Google Wallet on their AT&T S3 and use NFC tags too).

    At any rate, if anyone else runs into this issue, know you're not alone. lol

  4. nesto1

    nesto1 Well-Known Member

    Try Flashing one of these NFC options. I have no issues with my NFC not reading tags, but I use NFC Task Launcher to read/write my tags(with task launcher you can create Tag switches so the same tag can do different things depending on how many times you tap it)

    [MOD] NFC With the Screen Locked/Off - xda-developers

    I run the lockscreen one since I have a tag in my car right under where my phone sits.
  5. ryandelman

    ryandelman Well-Known Member

    I have Task Launcher too for virtually same reason.

    I installed the lockscreen zip prior to Google Wallet install, so maybe I'll wipe cache, wipe dalvik and then reinstall lockscreen zip over top of current Wallet install.

    I'll report back.

  6. ryandelman

    ryandelman Well-Known Member

    Still not working reliably, so I'm flashing NFC back to stock using deodexed NFC stock zip file.

    Will then re-flash NFC lock-screen-off zip file and see where that gets me.


    About an hour post-reflash and all is working well. I guess a "rinse and repeat" was all it took.


Share This Page