1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[AT&T] HTC One X Factory Reset Problem

Last Updated:

  1. samoyedpuppy

    samoyedpuppy Member

    I have an HTC One X. I purchased it from a third party. The device is rooted and unlocked.

    My phone's battery died. Once I went home to recharge it, the device was unable to get past the white HTC quietly brilliant screen. I would reboot it by pressing the volume down button + power button to reboot it and factory reset it. However, it continued to do this action. Then, I chose to reboot it under some setting. After I rebooted it, the device went to a "teamwins" screen. I erased everything, including the rom. Once I did this, it re-booted the device and continued to be on the same screen. Since this action happened, I connected it to my Windows 7 PC. I noticed that my HTC One X could not be identified as an external hard drive, it was identified as a CD rom drive.

    I tried to fix this problem by looking at other forums containing this topic. Here is what I tried:
    - I tried to go to HTC X support. I downloaded the current system, and tried to use it. When I tried to use it, it kept saying error.
    - I uninstalled the driver and tried to re-install it, it came back as a CD rom drive.
    - I restarted my computer, pressed f8, and put disable driver signature.
    - The driver re-installed as a CD rom drive.

    Can anybody help me identify my problem, and a solution for it?!? Thank you so much :).

  2. mikedt

    mikedt 你好 Guide

    Hi and welcome samoyedpuppy to Android Forums.

    I've moved your post into the HTC One X support forum. See if we can get some help for you.
  3. samoyedpuppy

    samoyedpuppy Member

    This phone is an AT&T phone, and it's Evita if that helps with anything.
  4. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Go back in to TWRP, connect the phone to your PC, head to the Storage or Mounts menu, then click on Mount USB Storage/Mount SD Card, does your phone now appear as a drive on your PC?

    If yes, we can take things from there.
    scotty85 likes this.
  5. samoyedpuppy

    samoyedpuppy Member

    When trying to mount it, I got these options:

    - mount system, mount data, mount cache, mount sd card

    For some reason, I was only able to mount system, data, and cache. I could not mount the SD card until I did all three other steps first. I did the three steps, unplugged the device from the PC because it said 'please remove device from pc before mounting.' It didn't show up as a drive on my computer. Next, I did the other three steps, connected it to my PC and it said I had to reformat it. I did reformat it, and it came out to be an external hard drive.

    I unplugged it, and re-plugged it back in to see if it would come as an external hard drive again. It didn't. I went back to the TWRP menu, tried to mount it, and I was able to mount the SDCard. I did all four options, and it still didn't show up as a drive though.

    I did the steps you told me to do, which was only Mount the SD card. I did that, and now it appears as an external hard drive.

    What do I do next? Sorry for explaining every detail, but I really want my phone to get fixed and just to make sure what actions I was doing could have triggered something else.
    scotty85 likes this.
  6. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    scotty85 likes this.
  7. samoyedpuppy

    samoyedpuppy Member

    I wanted to restore it back to HTC's original settings because I believe it's rooted, since the bootloader screen says it has been tampered with. Which route would be best recommended for me?
  8. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Because your bootloader says "tampered", I'm not entirely sure what options are available to you re reverting back to stock (I'm not sure RUUs will run if that's the case, although I could be very wrong there). If you want to go for a custom ROM, that's relatively easy.

    Let me speak to someone and I'll let you know. :)
    scotty85 likes this.
  9. samoyedpuppy

    samoyedpuppy Member

    Custom ROM? What kind of custom ROMs are there... ? I'm really new to this stuff =\. I just wanted to have something that could make it easy for me to constantly reset to factory settings.
    scotty85 likes this.
  10. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    My response not good enough? :p

    I kid, let me drop someone a PM and see what they say.
    scotty85 likes this.
  11. samoyedpuppy

    samoyedpuppy Member

    Hahhaa, no! It's not that that, I'm just relatively new to all this stuff. I had iphone before, so it was easier for me to fix it. As for Androids, it takes a couple more steps or I'm just complicating more things than I should :eek:

    But thank you! I really appreciate your help because no one has been able to help me yet x_x
    scotty85 likes this.
  12. samoyedpuppy

    samoyedpuppy Member

    If a custom rom like Viper XL or others is easier to fix the phone, I'd prefer to go this route. How do I do this?
  13. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Yeah? If you're rooted, that's the option I'd go for anyway.

    Can you tell me if your boot loader says S-OFF or S-ON somewhere along the top?
    scotty85 likes this.
  14. samoyedpuppy

    samoyedpuppy Member

    It says S-On
    scotty85 likes this.
  15. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Gimme 5 mins, just writing up some instructions for you. :)
    scotty85 likes this.
  16. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Ok, Post 2 of this thread: http://forum.xda-developers.com/showthread.php?t=1868236

    There's a downloads section, you want the top file (the 649MB one), download that. Also, download the mini SDK from here: http://androidforums.com/faqs/443072-adb-guide-updated-12-05-2011-a.html (it's only a small file, much better than the full SDK).

    1. Install the Mini SDK using the instructions in the above link.
    2. Open (don't extract), the ROM zip file and look for a file called boot.img, place that in the folder you've extracted the mini SDK too.
    3. Boot your phone into Teamwin, mount it as USB Storage as you did before and copy the rom zip file to the root of your SD Card.
    4. Unmount the phone, and reboot to the bootloader, selecting fastboot once there. It should say Fastboot USB about a 3rd of the way down the screen.
    5. With the phone still connected, open a command prompt on your PC and navigate to the folder you've installed the SDK. Ensure it contains files called boot.img and fastboot.exe
    6. On your PC, type the command fastboot flash boot boot.img, press enter
    7. Once done, type fastboot erase cache, press enter
    8. Once done, using the volume keys on your phone select bootloader, confirm with power, then select recovery
    9. In recovery, select Install zip from SD Card, then Choose zip, then select the rom zip file.
    10. If it asks for a full wipe, say yes. After that, just follow the install process through to completion. If there's a default install option, you want to go for that. If it also asks about a custom kernel, you're not running one so you just need whatever the stock option is.

    I can't be sure about the exact install process once in TWRP as the ViperXL install differs slightly to the version for my phone. If you just select the default for everything for now, that should be good enough. We can start with messing about with settings and other options if we get you back up and running.

    Anyway, once completed, it will give you the option to reboot your phone which is what you want to do. Bear in mind, first boot can take 10 minutes or so.

    Hopefully that should work. It's quite late here so I'm heading to bed so I've asked someone much wiser than I to keep an eye on this thread so if it doesn't work, just let us know and someone should be able to help. :)
    scotty85 likes this.
  17. samoyedpuppy

    samoyedpuppy Member

    I have downloaded the mini-SDK and the Viper-Rom. I opened the command prompt. I extracted the SDK file to my local disk drive C:/ ... I typed in this:

    ^^ I opened the command prompt on my desktop, so it was entirely this command: C:\Users\_______\Desktop\cd c:\sdk-tools

    The response to my command was: The system cannot find the path that is specified.

    Could this be because Viper-Rom hasn't completed downloading yet?

    Sorry for the late response, I was without a computer :c
  18. samoyedpuppy

    samoyedpuppy Member

    Never mind, I see my mistake! Haha :p
  19. samoyedpuppy

    samoyedpuppy Member

    I have been stuck at the command prompt. The command prompt has stayed at ' <waiting for device> ' for 30 minutes. Is this normal?

    This is what the command prompt looked like:
    c:\Users\_____\Desktop\sdk-tools> fastboot flash boot boot.img
    <waiting for device>

    I'm going to leave the device over night, if the process takes much longer than that. Please let me know if there was some sort of error in my step, or this is normal! Thank you :)
  20. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    That command should be instant. Are you definitely in fastboot? Does it say Fastboot USB anywhere on screen?
  21. samoyedpuppy

    samoyedpuppy Member

    It says Fastboot USB.

    This is what I did:
    - I pressed Fastboot, and went to the third option
    - The third option says: Factory Reset

    It does say Fastboot USB, but it's at the top and highlighted in red. It's not an option, it is where Hboot or Fastboot would usually say where it is.

    I tried to access TWRP, and I mounted the SD card. I was unable to, I had to reformat the disk. The storage is completely empty now, and I'm going to try to re-do my steps again.

    I did these steps to get to the command prompt:
    - Download mini-SDK
    - Extracted mini-SDK to my desktop
    - Opened viper rom, but did not extract it
    - Put the rom's boot.img into the mini-SDK folder
    - I moved the viper rom zip into my phone, but it was in the TWRP folder. In the TWRP folder, it contained nothing and I just put the viper rom zip
    - Then, I used the command prompt, and got stuck
  22. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    That's spot on, is HTC Sync or anything running that could be talking to the phone (even something like iTunes might cause issues)?
  23. samoyedpuppy

    samoyedpuppy Member

    No, I don't believe so. I don't have itunes or htc sync drive installed on my computer. Could it be because I have other flashboots and roms on my computer although I command prompted on the SDK-tools folder?
  24. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

  25. samoyedpuppy

    samoyedpuppy Member

    I inserted the information into the HTCdev (htc one xl, at&t, usa, android phone), and it said no files were found? Unless the carrier I have to put in telstra or htc one x? The only files I got were: evita-ics-crc-3.0.9-f87e40f.tar.gz

Share This Page