AT&T HTC One X+ - WiFi "dropping" connectionSupport


Last Updated: 2013-02-18 02:17:07
  1. sjvirchow

    sjvirchow Well-Known Member

    Hello friends!

    I have the United States HTC One X+ running on AT&T.

    I'm having a problem where my phone will stay connected to my access point (Cisco AE4500), however after a while, my phone just won't transmit data anymore. It says its still connected, and I don't lose my IP Address lease, but whenever I try to use data after a period of about 20-30 minutes of idling, it just stop transmitting data. Toggling the connection resolves the issue, for a while at least.

    This happens on both the 2.4Ghz band, and the 5Ghz band.

    My phone is not rooted, running stock Jelly Bean (4.1.1).

    Any ideas?

    Thanks again.

    Advertisement
  2. willibda1

    willibda1 New Member

    i have read many reviews saying that once the phone gos into sleep mode, WiFi connection is lost, it's know and i hope it get fixed soon plus the Bluetooth quality issue.
  3. sjvirchow

    sjvirchow Well-Known Member

    You're right! Once I put my phone to sleep, then wake it back up, boom, no more WiFi! Stays connected, but no data transmission!

    Well, at least I know what's causing it now.
  4. greatsnoring

    greatsnoring Well-Known Member

    Try a fixed ip address, worked very well for me. Several postings on this forum and one X forum saying how to do this. Having done this I now have excellent wifi connection whereas before it just kept losing it then cycling between seeing it, saying connection was poor then disconnecting.
  5. sjvirchow

    sjvirchow Well-Known Member

    I'll try that, and let you know what happens, thank you! :)

    EDIT: Is there a way to see if any updates are going to be pushed in the future? Seems HTC/AT&T would issue an update for this rather soon, the phone hasn't been out here in the U.S. very long...
  6. hts4215

    hts4215 New Member

    Same situation here with mine, which is also AT&T - tried the static ip approach and dont have the power saver enabled. No luck, as I still lose my data though it remains connected.

Share This Page