[AT&T] I'm stuck in TWRP!! Help

Last Updated:

  1. JustinR1

    JustinR1 Member

    Okay so I've been experimenting and reading forums all day to try and figure out how to fix this! I'm fairly new at rooting and flashing and all the lingo I see going on I try to piece it together but still having an issue here.

    So a week ago I unlocked bootloader and i rooted my phone which was a success. Afterwards I installed the google edition rom onto my phone which was a success. So after about a week I wanted to update my phone to see what other cool things i could do. I tried installing this mod that turns the htc logo into a button. When I installed it my screen went black and that was the end of it. In panic I went back to bootloader and wiped everything like an idiot so now i have nothing saved and there with no recovery... except what I saved on my mac.

    Now, for all the solutions i've read were for PC's and I could not find anything for a MAC. I feel like the solutions I see are simple if I had a PC. I could re-lock my bootloader and re-install (flash?) my stock ROM correct? However, I have a t-mobile htc one and I haven't seen any RUU for it.

    Basically I need help and i need to know how could I restore my phone using a mac because I apparently have no OS installed on my phone and cannot do anything. It wont read my android file transfer and it's stuck in TWRP and adb sideload doesn't actually load.......

  2. Hadron

    Hadron Well-Known Member Contributor

    I guess you didn't keep the Google ROM zip on your phone, and didn't take a nandroid (recovery backup) at any point?

    If you took a backup in recovery, restore that and the phone is working again. And please, don't modify your system in future without taking one first :)

    Otherwise, in the absence of an RUU the simplest fix is probably to just flash the ROM again. If sideload isn't working, can you not just adb push the ROM file(s) onto the phone while in TWRP, then flash them from recovery?

    Or if you have a USB OTG cable you could copy the files onto a flash drive, then connect that via the OTG cable and flash the files from usb storage using TWRP.
    JustinR1, scotty85 and Brian706 like this.
  3. Brian706

    Brian706 Moderator Moderator

    It sounds like you didn't make a backup that you can restore correct? And you wiped your /system so there is no rom to boot into?

    It sounds like you need to just flash your rom again while in the recovery. I am assuming your phone is not s-off? If so you will probably need to flash the boot.img that goes with your rom as well.

    Pardon me if I say something incorrectly as I am not a mac user. But the directions for flashing the boot.img should be similar I would assume.

    So you will need a copy of the rom on your mac. Browse the .zip and extract the boot.img from it. After flashing the rom, put the phone into fastboot mode and use fastboot command: fastboot flash boot boot.img to flash the boot.img to the phone. Basically just like you flashed the unlock token.

    Now reading back, I am unsure if you still have the rom available in your storage to re-flash? Did you wipe everything off the internal storage? If you choose install zip in recovery, can you browse to the rom file??
    scotty85 and JustinR1 like this.
  4. JustinR1

    JustinR1 Member

    Thanks for your responses.

    I made a backup on my mac it's called "backup.ab" but I think it was a data backup only lol..... I didn't back-up my rom if that's what you're asking!!

    I did have the rom installed on my phone which i accidentally deleted. That would have saved a heartache but I did indeed wipe everything without realizing what I've done now I cannot even start up my phone because it doesn't have an "OS" or i guess ROM installed onto it.

    I don't really know how to use adb and let alone on a mac, I would need some guidance through it because when I shoot adb sideload it lever actually does anything...how would I get the rom from the mac onto my phone so I can push it I guess is what I'm asking

    Thank you for your response. I must say I am sort of new to all this but I can learn as instructed. How exactly would I get the boot.img for my rom installed? When I tried doing commands in terminal it said device not connected and my file android transfer doesn't read it. My phone is stuck in TWRP mode.. maybe I'm just doing something incorrectly.

    EDIT: Also, how do I find if my phone is s-off? Because i don't even know what that means
  5. Hadron

    Hadron Well-Known Member Contributor

    How did you install the ROM in the first place?

    I've never used the Google Edition ROM, but the general approach would be that you download the zip files to the phone's storage, boot into recovery and install from there. As Brian says, you may have to install the kernel (boot) separately from the ROM, but as you've installed the ROM before I'll guess you know what you need to do in that regard, and Brian's already said how to do it. If you've unlocked your bootloader you must have fastboot (or fastboot-mac) installed on your computer, so I assume that bit isn't a problem. Indeed you must have done something like this to install the Google Edition ROM in the first place.

    Since you can't download directly to the ROM, download to the mac instead. You have got adb installed on the Mac? If so, you just boot into recovery, connect the phone to the Mac via usb and "adb push rom.zip /sdcard/rom.zip". Repeat for any other files you need to install, then disconnect from usb and use TWRP to install the zips you've now copied to your phone.

    If you've not got adb on the mac, look here, and in particular the "mini-SDK" is probably the simplest way of doing it.
    scotty85 likes this.
  6. Hadron

    Hadron Well-Known Member Contributor

    If all you did was unlock the bootloader, you are S-On. If you used revone or moonshine to take the phone S-Off you'd know you'd done it ;)
    scotty85 likes this.
  7. JustinR1

    JustinR1 Member

    You're totally right about installing the ROM onto the phone storage. What I did was when the phone was working, I just plugged in my usb cable to the mac and my Android File Transfer would read my phone then I could copy the ROM. However, the issue I have here is much deeper. My OS is completely wiped and I cannot move beyond the TWRP screen thus making it impossible for my MAC to read my phone so I can properly copy the ROM to my phone's storage :/

    So lemme try what you suggested because I'm not really sure how to type it in the MAC Terminal because sometimes it'll say "adb command not found" or something so I'm not 100% how to put my terminal in the right path location if that makes any sense. Again, thanks for your patience and help
  8. Hadron

    Hadron Well-Known Member Contributor

    OK, I've got to go in a second, but yeah, if you've not put the adb executable into your $PATH on the Mac then you'll have to cd to the directory it's in before you can use the command (and hence copy the files you want to transfer to that directory, or include their full addresses). Oh, and to get to the directory, just type "cd " followed by the path to the directory adb is in (Mac command line is basically the same as linux command line).

    you can always test adb by typing "adb devices". Should return the phone's serial number.

    Android File Transfer won't work unless you can run android, but the phone should respond to adb when in TWRP, so "adb push" is an alternate way of getting the files onto the phone.
    scotty85 likes this.
  9. JustinR1

    JustinR1 Member

    :sdk-tools admin$ ./adb-mac devices
    adb server is out of date. killing...
    * daemon started successfully *
    List of devices attached

    doesn't show any serial #
  10. JustinR1

    JustinR1 Member

    Ok I think I get how to push a file but when I finally have the path set up and I did as you requested this it what it says

    sdk-tools admin$ ./adb-mac push rom.zip /sdcard/rom.zip
    error: device not found
  11. JustinR1

    JustinR1 Member

    Am I doing something wrong or is there a step I missed?

    So basically I have the adb fastboot installed with the files I need inside the folder including the rom.zip and the boot.img. However, with the commands ./fastboot-mac push rom.zip /sdcard/rom.zip it says waiting for devices and nothing happens and when I try ./adb-mac push rom.zip /sdcard/rom.zip it just says device not found or "closed" so I guess my first task is trying to figure out how can I get the rom to my phone so I can flash it?

    EDIT: Do I have to have the original stock ROM or something or can I just reuse the newest one I had which was the google play edition
  12. JustinR1

    JustinR1 Member

    ok progress update... I somehow got my rom.zip onto my phone but when I try to flash it, it says error.. any idea what to do next?
  13. clsA

    clsA Well-Known Member

    Hold on I'll get the links you need.
    Here is the tmobile RUU - http://forum.xda-developers.com/showpost.php?p=44017891&postcount=202

    download that then you can install it from fastbootRUU mode
    I'll post the commands

    after you have the file (check the md5 it's on the download link) make sure it's in the same directory as fastboot
    then run the following commands:

    fastboot oem rebootRUU
    fastboot flash zip rom_decrypted.zip
    fastboot flash zip rom_decrypted.zip
    fastboot reboot

    you should have a new phone when it's done
    scotty85 likes this.
  14. JustinR1

    JustinR1 Member

    Thanks a bunch!! I actually miraculously got it to work with the google play edition but I'm definitely going to install those that you recommended as back ups just-in-case of any future screw ups lol...

    Thanks everyone!
    scotty85 likes this.
  15. clsA

    clsA Well-Known Member

    Good deal... you should make a backup in twrp and look into s-off for the future. (it's easier to recover if your s-off)
    scotty85 likes this.
  16. JustinR1

    JustinR1 Member

    ok cool but what is s-off and s-on and the difference between the two? Also, how do I look into that?
  17. clsA

    clsA Well-Known Member

    S-off means security off, it allows you to flash a RUU that you normally couldn't.
    just google Revone and follow the instructions from the download site at XDA
    scotty85 and JustinR1 like this.
  18. JustinR1

    JustinR1 Member

    I guess s-off must be the case for me then right :) since I was able to flash mine when I had no OS or ROM installed on my phone? That I take as a good thing

    EDIT: Ah nevermind I see i'm S-On on the bootloader page.... ok I'm gonna make a back-up then I'm gonna do the s-off approach with the instructions on that page you gave me, thanks a bunch. you guys are awesome.. im learning so much so fast
    scotty85 likes this.
  19. JustinR1

    JustinR1 Member

    Tried executing the revone and everytime i follow the instructions to ./revone -P it says "cannot execute binary file"

    am I supposed to do that from bootloader screen? Cause I've been doing it from the android screen when the phone is regularly on

    EDIT: Fixed this as well... a really good tutorial from this youtube channel helped greatly. "http://www.youtube.com/watch?v=U2qHzqTqdvY"

    So what exactly are the perks now for having s-off lol... i see tampered is gone and that's all i really know
    scotty85 likes this.
  20. scotty85

    scotty85 Guides Guide

    these are in the rezound section,but the info applies. check out this post for perks and info,and this post for a general disclaimer.

    im of the opinion s off is better,but with it comes new responsability to know what your flashing and why,as with no security checks it is possible to brick your device unrecoverably by flashing a wrong,or corrupt file.

    there is info here on returning to stock if you need to: http://androidforums.com/internatio...-return-100-stock-revone-moonshine-s-off.html but dont turn s on unless you need to for a legitimate warranty repair,as exploits get patched and you may not be able to get it back.

    just holler if you have any other questions :)
    Hadron likes this.
  21. Happymak

    Happymak New Member

    Hi. I think I am having the same issue Justin had. I have wiped my os from my htc one. I have instaled twrp and I am only able to get to the recovery. Also I think I erased everything on my sd card also haha. I have tried your step but my terminal says:

    "MacBook-Air-de-Simon:fastboot SAM$ ./fastboot-mac flash zip ruu.zip
    sending 'zip' (1037376 KB)... ERROR: usb_write failed with status e00002be
    FAILED (data transfer failure (No such file or directory))"

    Please help me out. I would be of greater help.. I am in a mess here
  22. clsA

    clsA Well-Known Member

    make sure the file your flashing is in the same directory as fastboot and don't leave out the first command that puts the phone in RUU flashing mode
    scotty85 likes this.

Share This Page