[AT&T] Need help resetting my phone I messed up badly


Last Updated:

  1. tumi

    tumi New Member

    Ok so I used to have a Samsung Captivate and knew how to root and flash ROMs, was pretty used to it.


    I tried to do the same on my HOX, but ran into a bootloop and subsequently I think I've deleted everything on my phone. I used Hasoon2000's All in one kit during this whole proces. I unlocked my bootloader/rooted and flashed TWRP v 2.3.3.0, but my problem arose after I tried to flash the kernel for a custom ROM. It stayed in bootloop so I figured I'd back out and just restore back to the backup I made before flashing the kernel. However, after "successfully" restoring back I was still stuck in bootloop somehow. I know this isn't supposed to happen, it's supposed to restore back to the exact state of your phone at the time.

    Anyways, I thought maybe I just needed to wipe things. I looked around and found a source that said to wipe cache, dalvik, factory reset, and system. Wipe those 4, but not external storage or android secure. So I wiped those 4 and I intended to try the backup again but it turns out that cleared everything on my phone. Now when I hit "restore" there is nothing to select. I also used to have a custom rom on the virtual sdcard, but that's gone too. My TWRP now says I have no OS.

    When in TWRP and I go into "install" the only thing in /sdcard is now TWRP. After looking around, it looks like my only option is to mount the phone to my computer via TWRP and somehow download the standard OS for my One X again. Also in the Mount menu it lists "mount system, mount data, mount cache, mount sd card" I can only check the first 3 options and when I do my computer asks me if I want to format it. I guess I can't mount the sd card because I deleted everything?


    If anyone has the time to help me out that would be AMAZING. Right now I don't even care about being able to flash my custom ROM, I just want to get my phone back to functionality. I would love a conversation and would be willing to gmail chat if willing.

    Also my phone is the ATT version, 2.20 (or I guess it was before I deleted everything).

    Thank you in advance for any help.

    Advertisement
  2. geewhiz

    geewhiz Well-Known Member

    You need to run the RUU for 2.20.
    That will reset your phone back to the stock operating system.

    http://forum.xda-developers.com/showthread.php?t=1814217

    Be sure that you re-lock your bootloader before flashing the RUU.
    Here is a link to a all you need to know guide for doing this whole RUU and re-lock and then re-unlocking your bootloader.

    http://forum.xda-developers.com/showthread.php?t=1678308

    Good Luck! :)

    Also.... as far as I know, you still might not be able to flash a new kernel with a 2.20 bootloader via recovery!
    Did you flash the boot.img file for your particular rom??
    You have to flash that file via fastboot which in effect forces you to use the kernel baked into the ROM. Unless things have changed within the last couple of months.
    Flashing another kernel would most certainly cause the bootloop you experienced.
  3. tumi

    tumi New Member

    All fixed. Thanks!

Share This Page