[AT&T] Need some help

Last Updated:

  1. geewhiz

    geewhiz Well-Known Member

    Hello all.

    I just rooted my 2.20 bootloader. Installed TWRP 2.3.1. Downloaded the CleanRom v5.0. I extracted the boot.img file and flashed it via fastboot. And then I installed the .zip rom within recovery.

    When the phone booted, the error "phone.andriod" has closed kept popping up 3 or 4 times and then it would restart the UI and the clean rom load screen. It kept doing this continuously.

    So I went back into recovery. Flashed back to my nandriod. Tried everything again. Same thing.

    However now, when I go into recovery it does not mount the SD card anymore. I'm about to reflash recovery. I thought I read somewhere that I should use TWRP version 2.1?

    Any thoughts?

  2. geewhiz

    geewhiz Well-Known Member

    So what do I do if recovery does not want to mount my sdcard anymore?

    I wipped my system before finding out that my sdcard was gone, so now I can just sit in fastboot or recovery and nothing else.
  3. razvan06

    razvan06 Well-Known Member

    You could first get a ROM that has a newer recovery, not sure exactly what ver. you get on the AT&T CWM recovery... install the boot.img [it contains the recovery.img as well] and try again.
    If all fails, look for a AT&T HOX RUU file and flash the stock firmware, and you can eventually try again with that new ROM you wanted :)
    geewhiz likes this.
  4. geewhiz

    geewhiz Well-Known Member

    Can anyone direct me to the nearest ruu's? I don't see any mention of them in the all root section
  5. razvan06

    razvan06 Well-Known Member

    Hope this one is good for you , RUU HTX ONE X AT&T - 2.20

    Read it carefully if it's your first time doing this...
    geewhiz likes this.
  6. geewhiz

    geewhiz Well-Known Member

    I'm still having issues.

    Do I go into usb fastboot to do the ruu?

    I run the .exe, it goes through and shows "From Image version: 2.20.502.7" "To Image version: 2.20.502.7". It says checking... Reboots the bootloader. Says Erasing User Data. Then Sending. Reboots bootloader.

    Says Sending and then I get a Error[155]: Unknown Error.
    The Rom Update Utility cannot update your Android phone.
    Please get the correct ROM Update Utility and try again.

    It is version :(
  7. geewhiz

    geewhiz Well-Known Member

    Woot woot.

    The hangover from yesterday's game finally wore off.
    Earlier my brain just didn't register steps 1 & 2. After I relocked my bootloader everything worked like a champ! :D:D

    Many thanks for the help.
  8. razvan06

    razvan06 Well-Known Member

    Glad to hear everything is working.
    If you want to re-Root your phone, unlock bootloader using htcdev.com and follow steps to root !

Share This Page