[AT&T] No data after CM-10.1 nightly

Last Updated:

  1. BadTA

    BadTA Well-Known Member

    I don't know if it too early to expect custom ROMs to be available and working, but I found that CM-10.1 has some out there.

    Anyway, I used motochopper to root and then GooManager to install TWRP.

    I did a full backup, then wipe cache, dalvic cache and wipe factory in TWRP. Then flashed the latest nightly from CM.

    No issues were noticed during the above steps, but I do not get a data connection once booted. No 4G, 3G....nothin.

    Any thoughts?

  2. Atma

    Atma Well-Known Member

    You might try a factory reset and see if that helps. Or turn airplane mode off and on a couple times. Also, check your apn settings to see if they are correct.
  3. BadTA

    BadTA Well-Known Member

    Thank you. I have tried factory reset and toggling airplane mode. I have done those things many times. I am not sure about the apn settings. What are those?
  4. Atma

    Atma Well-Known Member

    The apn is what you need for data to work.

    Go to settings > connections > more networks > mobile networks > access point names. You should see an apn for AT&T. If you don't you will need to add it. I have the T-Mobile S4 so I'm not sure what the settings would be for AT&T.

    I found these for the AT&T S4. You can see if they work if you don't have it. Press your menu button and select New APN.

    Name: ATT Phone
    APN: phone
    Proxy: Not set
    Port : Not set
    User name: Not set
    Password: Not set
    Server: Not set
    MMSC: http://mmsc.mobile.att.net
    MMS proxy: proxy.mobile.att.net
    MMS port: 80
    MCC: 300
    MNC: 410
    Authentication type: None
    APN type: default,mms,supl,hipri
    APN protocol: IPv4
    APN roaming protocol: IPv4
    Enable/disable APN: APN enabled
    Bearer: Unspecified
  5. BadTA

    BadTA Well-Known Member

    Thank you!

    I had that apn, but did not have 'hipri' listed in 'APN Type'

    Seems to work now.

    Atma likes this.
  6. Atma

    Atma Well-Known Member

    You're welcome. Glad it worked. :)

Share This Page