1. Tablet future looks bright! Read more about: Alcatel Xess | Samsung Galaxy View
    New Forums: Alcatel Xess | Samsung Galaxy View
    Dismiss Notice

[AT&T] Returning to stock take 2


Last Updated:

  1. LoyalServant

    LoyalServant Well-Known Member

    Got another one I have to return to stock...
    Trying to get an RUU to run.. but it refuses.

    Phone has the following displayed in bootloader:
    - tamered
    - unlocked
    - s-on

    Trying to revone to s-off i get the following with several roms
    that I have tried in an attempt to get back to s-off:

    root@android:/data/local/tmp # ./revone -P
    ./revone -P
    revone v0.2.1

    revone failed (error code = -6)

    Any ideas?
    I just cannot seem to get this phone back to s-off to RUU it.

    Advertisement
  2. scotty85

    scotty85 Guides Guide

    What firmware are you on? You can unlock the bootloader,install a stock rom with an insecure kernel and use rumrunner,or you can use firewater.

    A couple of ways to skin the cat now :)
  3. LoyalServant

    LoyalServant Well-Known Member

    Hmmm not familiar with those.

    The last rom i stuffed on it trying to get revone working is MaximusHD 11.0.0

    What do you suggest?
  4. scotty85

    scotty85 Guides Guide

    That rom likely is fine for either. Rumrunner is a bit easier on the user but a bit trickier to get running on a windows pc.

    http://rumrunner.us

    http://firewater-soff.com/

    I personally would use firewater... It's a bit more like revone
  5. clsA

    clsA Well-Known Member

    did you take the 4.4.2 update ? if not the old 4.2.2 RUU should work without s-off. If you need links to the RUU let me know
    scotty85 likes this.
  6. scotty85

    scotty85 Guides Guide


    Without s off,he cannot eliminate the relocked watermark... For what that's worth. ;)
  7. LoyalServant

    LoyalServant Well-Known Member

    Got a little bit of time this evening to play around with this phone.
    Will give these things a go this evening.

    @clsA I may not have the older 4.2.2 RUU but I will look around.

    Edit: firewater wont s-off it either.

    Been here just shy of 10 times now:
    The first bottle is open
    chugging..........
    nasty, need a chaser
    this skunk has some real funk, force (FORCE!!!!) reboot your device and try again!

    :(
  8. scotty85

    scotty85 Guides Guide

    Did you re-unlock and install superuser? Firewater or rumrunner should work. If you're using windows,disable your firewall and securities temporarily,or try using an ubuntu live cd.
  9. LoyalServant

    LoyalServant Well-Known Member

    Edit:
    Rum Runner worked...
    These guys have a sense of humour....

    I love it.

  10. LoyalServant

    LoyalServant Well-Known Member

    And..... now my question is gents...

    I have the following RUUs downloaded already.

    RUU_M7_UL_JB43_SENSE50_MR_Cingular_US_3.17.502.3_Radio_4A.19.3263.13_10.38j.1157.04_release_334235_signed_2

    RUU_M7_UL_JB_50_Cingular

    Now sure about this second one... but I downloaded it around the end of May last year and it's smaller than the first one.

    This is where I am now...
    - Tampered
    - Unlocked
    - S-OFF

    If I run one of these RUUs will it be able to accept OTAs and stay S-OFF?
    I would like to make it stock again but keep the S-OFF.
  11. scotty85

    scotty85 Guides Guide

    Yup,3.17.502.3 is a release build that will ota. That second one,I am unsure of. Glad the rum was good :D
    LoyalServant likes this.
  12. LoyalServant

    LoyalServant Well-Known Member

    Thanks Scotty...

    This is why I ask about stuff here... less noise and more down to earth people :D

    It's been on the RUU for what seems like a really long time.
    I don't remember an RUU taking as long as this one has.. will give it a while longer but I don't think it's working.

    It's just sitting at the silver HTC logo on the phone and on the computer it's sitting at the sending progressbar with streams of dots.

    I think it's hosed.... but we will see.
    scotty85 likes this.
  13. scotty85

    scotty85 Guides Guide

    The .exe files can be a terrible PITA. Don't feel too bad if it won't run. You can always extract rom.zip from the .exe utility and flash it in ruu mode. I can get you directions for that if you need them. If you get stuck in ruu mode,

    Fastboot reboot-bootloader

    Shoud get you out
  14. LoyalServant

    LoyalServant Well-Known Member

    I ran the older one and it ran successfully.
    Its on 4.1.2 now with the AT&T stock firmware I suspect the phone came with when it was released.

    Does the phone need to be relocked for some of these RUUs to run?
    Tampering is gone, but it is unlocked and S-OFF.

    I am re-downloading the RUU from a link I saw you give to someone else in another thread

    (http://dl3.htc.com/application/RUU_...13_10.38j.1157.04_release_334235_signed_2.exe)

    Be done in about 15 more minutes so I will give that one a go.

    May try to let it OTA... it's probably a case of no sim... no OTA.

    Edit:
    Yep... sim card in... and it grabbed an OTA just like that.

    Edit 2:
    And... OTA failed.
    Just rebooted and now it's in that check again in 23 hours and 55 minutes kick.

    My re-downloaded OTA won't work either.

    Oh well... who ever thought making a phone stock would be such a PITA. :eek:
    scotty85 likes this.
  15. scotty85

    scotty85 Guides Guide

    id say you are close enuff ;) if youre on a stock firmware,locked and not displaying tampered you should be good to go.

    you could try manually applying the OTA package with the stock recovery if its still on the phone. when my phone gets an update(running dev edition software) i make a copy and transfer the OTA to the pc,then install the stock recovery and let the phone apply it.

    you have not changed your cid or mid,correct?
  16. LoyalServant

    LoyalServant Well-Known Member

    It is displaying unlocked. Does it need to be relocked for the ota or ruu to work?
    I have not changed the Cid or mid on this one.. No.

    Edit:
    I relocked it and it took the first OTA without failing... so I guess it does not like
    being unlocked.
    It's getting another OTA now thats ~565 megs in size.

    Turns out the wife is having trouble with hers now so I will give her this one and get hers swapped under warranty once I get it up to date.
    scotty85 likes this.
  17. scotty85

    scotty85 Guides Guide


    That's odd... I've never relocked to OTA. But I've seen stranger things ;) glad you're getting things sorted :)
  18. LoyalServant

    LoyalServant Well-Known Member

    I thought so too..
    It just would not do it unless it was relocked.
    Once I relocked it.. it worked.

    I did this on another one of these and I never had so much trouble getting it returned to stock.. this one wiped the walls with me.

    It is now stock and up to date....

    Could not have managed to get it done without you guys.
    Thanks again.
    scotty85 likes this.

Share This Page