1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[AT&T] S4 Constantly Freezing & Can't Login to Google Account

Last Updated:

  1. Aim006

    Aim006 Member

    So I got my S4 a few days ago and when I got it, I was easily able to set it up and connect to my google, samsung, and email accounts. I also rooted it. But one day, I was trying to figure out how to make the Freedom app work since it is longer compatible with the new Google Play Store, I think. I'm not exactly sure what I did, but I think I force stopped/cleared data for the Google Play Store and the Framework. Then I tried to open the app, and it just froze/lagged. I tapped another app, and after a minute it opened the other app and then froze on that until I rebooted. After that, everytime I tried to use the phone, it froze after 2 minutes and I had to reboot it.

    I've factory reset it about 5 times and it seems all right until after I root it. The first time I rooted it when I got my phone, it was fine until I started messing around with stuff like that. I'm not sure why this is happening. Is there some sort of program I can use to diagnose it or whatever?

    But that's not my only problem, aside from freezing every 2 minutes after rooting, I can't login to my Google account since I factory reset it. I've been able to login when I got my phone, but now it says something like, "Couldn't establish a reliable connection. Could be a problem with Android or your data... Please call customer service if this continues to happen." I've looked it up and the only solutions are to factory reset (already done that) or edit/delete the hosts, which I'm not really sure how to do, but when I go to the system/etc/hosts file and try to edit it, it just freezes after a couple seconds because it's rooted.

    Please help me, I just got this brand new phone and I'm really upset. Thanks!

    Edit: Also one other thing, when I boot up the phone, even after I factory reset it, instead of saying Samsung Galaxy S4, it says Samsung and then under it it says Custom with an unlocked lock under it. Why is this?

    Edit: It also freezing sometimes without root. Is there any thing more powerful/extreme than a factory reset? My phone is really screwed up!! Help!

  2. Atma

    Atma Well-Known Member

    Hi Aim. I moved your thread to the AT&T All Things Root forum for you.

    I'm not very familiar with rooting the AT&T S4. I'm fairly sure it has a locked bootloader and that is probably why you are seeing unlocked. The bootloader has to be unlocked to root it.

    The best thing to do at this point I think is to load the stock firmware back on it. Check this thread and look at #3 where it says "How to Prepare Your Phone to Return to the Store or for Warranty Replacement. Or how to set your Back To Stock."
  3. Aim006

    Aim006 Member

    I checked the thread and it's for the S2. Although it doesn't tell me in Download mode, I'm pretty sure my flash counter is zero since I've never flashed before, but it does say "Custom," even though it's the regular Jellybean/Touchwiz or whatever.

    So if I flash to the stock kernel, will the one in that thread work or will I need a different one for the S4? And do you know where I could find one. Couldn't find one when I googled it.
  4. Atma

    Atma Well-Known Member

    Aim006 likes this.
  5. Aim006

    Aim006 Member

    Thanks Atma! I'm downloading the stock ROM right now. After it's done, I'll let you know if it worked, but I think it will. Do you think it would be safe to root it again after it's done?
    Atma likes this.
  6. Atma

    Atma Well-Known Member

    I would read through that thread and maybe a few others there and see how other owners phones are doing after rooting. I have the Tmobile, not the at&t so I can't say for sure.

Share This Page