[AT&T] SU Binary Update Error

Last Updated:

  1. mariop64

    mariop64 New Member

    Hey guys! I'm brand new to the forums!

    Anyway, my problem is that after trying to root my At&t GS4 SGH i337 model, I continue getting a request to update the new Superuser app. it says the Superuser binary (su) must be updated and gives me the choice of either "recovery install" or "install".
    After pressing either i then receive an error telling me to send a log of the error to the developer.

    I read on galaxys4root.com in the comments under the section for GS4 i337 that many other people have been experiencing this same issue.

    Any help rooting would be greatly appreciated! Thanks for taking the time to read and respond to me!!

    Information that you may need:

    Andriod Version: 4.2.2
    Baseband version: i337UCUAMF3
    Kernel Version: 3.4.0-812098
    Build Number: JDQ39.i337UCUAMF3

    Please if i left something out let me know what and where i can get to it. Thanks again!

  2. Mr. Lucky

    Mr. Lucky Well-Known Member Contributor

    If you tried to root using the motochopper exploit, the su binary update is failing because you aren't really rooted. AT&T S4s running 4.2.2 have a locked bootloader which causes everything but the ADB push of superuser to fail. Prove it to yourself by downloading and running the Root Checker app.

    I don't know of anyway around this currently, but I'm sure it's just a matter of time. Interestingly, there is a 1-click method (ar.apk) for rooting the AT&T S4 Active, which also has locked bootloader.
  3. Shotgun84

    Shotgun84 Well-Known Member

    Hello and welcome to the forum:wavey:

    I've moved this over to all things root:)
  4. mariop64

    mariop64 New Member

    Yes I did use the Motochopper method and the root checker app says I'm not rooted. I tried downloading root apps like Titanium Backup which of course didn't work.

    Thanks for the help, I will keep an eye out for a workaround.

    And thanks for moving the thread! (=

    Good day gentlemen.:)
  5. warrenb779

    warrenb779 New Member

    i have the same phone and problem... is this still the case currently? thanks
  6. Mr. Lucky

    Mr. Lucky Well-Known Member Contributor

  7. warrenb779

    warrenb779 New Member

    When I enter cd/mnt/extsdcard. .it says not found
  8. Mr. Lucky

    Mr. Lucky Well-Known Member Contributor

    It's: "cd /mnt/extSdCard"
    Note the space after "cd" and the upper-case characters. Windows doesn't care about case but linux (which Android is based on) does.
  9. warrenb779

    warrenb779 New Member

    Wow! Don't know how I missed that...thanks for the help. ..its working fine now!:thumbup::thumbup:

Share This Page