[AT&T] TWRP Backup


Last Updated:

  1. gpup

    gpup Active Member

    Hi all,

    I have a Galaxy S4 AT&T (USA) running OS 4.3, rooted.

    I am trying to install TWRP Recovery so that I can backup my phone. I tried once using Recovery Tools Flasher and that failed, so badly that I was stuck in "Download Mode" for 5 hours.

    Can someone confirm that GooManager should work for me? I am trying to avoid bricking my pone (again). I started the steps from here:

    TeamWin Projects - TWRP 2.7 - Samsung Galaxy S4 (AT&T) | TeamWin

    In Goo Manager I went to "Install OpenRecovery Script" and clicked "Yes." However, the filename is says it will install is openrecover-twrp-2.6.3.1-jflteatt.img

    I stopped it there because I want to be sure this is the correct procedure and file for my phone before continuing.

    Does anyone know why this wouldn't be the latest version, 2.7.0.1? Do you think there's any harm in using the 2.6.3.1 version?

    Thanks for the help.

    Advertisement
  2. gpup

    gpup Active Member

    Update: I tried installing from both Goo Manager and TWRP Manager. Both tools wanted to install version 2.6.3.1 so I let them. They both said the custom ROM was successfully installed. However, when I restart into recovery mode, my phone goes back to that screen with the Android Robot that says "Downloading...Do not turn off target!!" The only way I have found to get out of this is to reboot into download mode, where I get the following screen:

    "Warning!!

    A custom OS can cause critical problems in your phone and installed applications. Installing a custom OS on your device may cause it to shut down as a result. Please see manual for details.

    If you want to download a custom OS, press the volume up key. Otherwise, press the volume down key to cancel.

    Volume up: Continue
    Volume down: Cancel (restart phone)"

    I press down because I'm not trying to install a custom OS, just the TWRP custom recovery. However, I can't seem to get to any kind of recovery screen. Should I be choosing "Continue" on this warning screen about the custom OS??

    Could this be because I previously tried to use Recovery Tools Flasher to install version 2.7.0.1? If so, what can I do about it?
  3. gpup

    gpup Active Member

    Additional info: On the "Downloading...Do not turn off target!!" screen, in the top right it shows:

    Could not do normal boot. [in red]
    ODIN MODE [in red]
    PRODUCT NAME: SSH-I337 [in white]
    CURRENT BINARY: Samsung Official [in white]
    SYSTEM STATUS: Custom [in white]
    KNOX KERNEL: 0x0 [in white]
    KNOX WARRANTY VOID: 0x0 [in white]
    CSB-CONFIG-LSB: 0x30 [in white]
    WRITE PROTECTION: Enable [in grey]
    eMMC BURST MODE enabled [in grey]
  4. gpup

    gpup Active Member

    Pressing continue just brings me to that same screen "Downloading....Do Not turn off target!!" So still can't get into recovery mode. My build number is MK2. Not sure if that's older or newer than MK3 and if TWRP (or CWM for that matter) should work with MK2.

    I read one place that safestrap is the only recovery that works with MK2 and MF3. But it also seems like I need to install a custom ROM in order to use safestrap. Has anyone used safestrap and do you know the answer? Will safestrap allow me to back up my phone? That was the whole reason I went down this road to begin with. Otherwise, does anyone know how to reinstall the stock recovery without wiping the phone? It seems that's what I need to do. Then, still not sure how I'll back up. Perhaps if I pay for TWRP Manager, their live backup tool will work for me?? No idea really! I wish Google didn't make it this hard to create a backup.
  5. g0lden

    g0lden Well-Known Member

    You can install safestrap on stock rooted MK2, just install version 3.71
  6. electricpete

    electricpete Well-Known Member

    What he said. Safe strap will give you a modified Twrp recovery. Don't try installing any other recoveries into stock rooted 4.3

Share This Page