1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[AT&T] Unable to mount sd card

Last Updated:

  1. Hi all! I know this was a complicated problem and I hate to bring it up again but I am having the same issue of not being able to mount \SDcard. I will follow the same steps as outlined above but I have a different base band. I don't know how to find the proper RUU. (my "main version" slot is also blank). Here is my baseband information-

    c:\Fastboot>fastboot getvar all
    (bootloader) version: 0.5
    (bootloader) version-bootloader: 1.09.0000
    (bootloader) version-baseband:
    (bootloader) version-cpld: None
    (bootloader) version-microp: None
    (bootloader) version-main:
    (bootloader) serialno: ********* edited out
    (bootloader) imei: ******* edited out
    (bootloader) product: evita
    (bootloader) platform: HBOOT-8960
    (bootloader) modelid: PJ8310000

    (bootloader) cidnum: 11111111
    (bootloader) battery-status: good
    (bootloader) battery-voltage: 4055mV
    (bootloader) partition-layout: Generic
    (bootloader) security: on
    (bootloader) build-mode: SHIP
    (bootloader) boot-mode: FASTBOOT
    (bootloader) commitno-bootloader: e964c535
    (bootloader) hbootpreupdate: 11
    (bootloader) gencheckpt: 0
    all: Done!
    finished. total time: 0.071s

    Also I have a AT&T One x
    I found a complicated way to bypass HTCdev noticing that I have an AT@T phone and therefore able to unlock my bootloader. I had it rooted and was running AT@T's Icecream Sandwich default rom. I was trying to load the Android Revolution HD rom when I ran into the problem.

    The only software I found that I can use with my phone is recovery-clockwork-touch-

    Thanks guys I appreciate the help!

  2. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Welcome to AF, diabloraptor22! :)

    Is that the latest version of CWM for your device? I know there have been issues with older versions of CWM on the international One X, but they were fixed in Is there a higher version than that for the S4 model?
    scotty85 likes this.
  3. Thanks.

    For some reason my HOX will only accept the CWM I tried flashing the CWM but it goes into a boot loop and won't load. I also tried flashing, but that wouldn't flash properly either. I guess the -evita-modaco.img file has been added onto to support my phone. I think I found a CWM file and I'm downloading it now. I'll report back if it worked.

    PS. This is the link to the thread I was referring to when I stated that I would "follow the steps outlined above" in my first post.

  4. So I tried the different CWM file but it didn't work. I read elsewhere that TWRP is the way to go for AT&T HOX. I am using that now as my recovery software but it cant mount \SDcard either. I think I'm forced to install an RUU.

    There might be one other option though. With TWRP I can mount my phone using "mount USB storage". When I do my computer recognizes that I have a disk drive but in order for me explore any files Win 7 says that I need to format it. I wasn't sure if fastboot was on the drive or located somewhere on the system board like a computers bios, so I didn't format. Can I format the disk and not brick my phone?
  5. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Have you tried cancelling the format prompt? One of my external HD's gives that error message quite a bit, but cancelling the format box allows me to view the contents normally.
    scotty85 likes this.
  6. Yep nothing. It's pretty locked down.
  7. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    I just saw the thread you linked to, I'll have a read through that and see what the deal to give me an idea where you are.

    I'm not entirely up to speed with the AT&T root/install a ROM method so I'll need to read up on that too, see what your options are.
    scotty85 and diabloraptor22 like this.
  8. scotty85

    scotty85 Guides Guide

    as far as the proper RUUs,there are 2 in footballs folder that match your baseband:

    this one: RUU_Evita_UL_Cingular_US_1.68.502.1_Rado_0.

    and this one: RUU_Evita_UL_Cingular_US_1.73.502.1_Radio_0.

    without downloading,we dont know wich one might contain your same hboot. if it comes down to a point that you need to relock and run an ruu,id try the first one(1.68.502.1) first. if it fails,run the second. i am downloading them now,also,so ill see if one or the other contains hboot 1.09

    we never really did figure out how to get the sd card being seen again in the one s thread,adb commands failed,as did the new recovery. in that thread we ended up just relocking and runing the RUU :(

    may want to wait for EP to read thru things and see if hes got any other advice before pulling the trigger,tho :)

    it is peculiar how your main version# is blank... just like the one s guy. hmm. maybe they come without a main version? one is not set until an ruu is run? :confused: not that it has anything to do with the situation,just wondering aloud ;)

    they have both downloaded for me,and i looked at rom.zip... looks like the 2nd link(1.73.502.1) contains 1.09 hboot.

    1.68.502.1 contains 1.08

    you can relock and run the full ruu if you need to,or i can upload the factory system and boot images for you,if you want to try flashing just those.
    El Presidente and diabloraptor22 like this.
  9. I appreciate the quick responses from both of you. Thanks. I believe that I will do a little more research on RUU's which should give EP some time to figure a work around. If I don't hear anything in a few days then I'll just run the RUU. I really appreciate both of y'alls help.
    scotty85 likes this.
  10. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Apologies, I had meant to respond sooner, but I've had a pretty busy week. :eek:

    Having looked at what's about, I think your best bet is to relock the bootloader and run the RUU unfortunately. Do you recall what S/W version your phone shipped with?

    Re the main version being blank, doesn't the root method for the One XL involve changing the main version/CID?
    scotty85 likes this.
  11. scotty85

    scotty85 Guides Guide

    newer phones are checking more than just CID and main version these days,im afraid... an s-on phone is also checking the baseband and the hboot for the correct,signed versions before it will allow an ruu to flash,and even before it will allow it to boot(hence the need for radio s-off,rather than a simple patched hboot).

    from his hboot and baseband in the getvar output,if it comes to running an ruu,i belive he needs to run this one:
    RUU_Evita_UL_Cingular_US_1.73.502.1_Radio_0. - download now for free. File sharing. Software file sharing. Free file hosting. File upload. FileFactory.com

    this one is a higher build number,hboot,and baseband,and as such should flash also...
    RUU_Evita_UL_Cingular_US_1.85.502.3_R2_Radio_0. - download now for free. File sharing. Software file sharing. Free file hosting. File upload. FileFactory.com
    but i personally would think twice about running that one since you cant go backwards on an s-on phone. you never know what doors you may be closing with new firmware :eek:
  12. I'm downloading the first RUU. I'll let y'all know how it goes.
  13. Awesome! I ran the RUU and I'm back to stock install. Thanks guys. I think CWM messed me up and so now I'm using TWRP recovery. I will pay more attention to the instructions when roming, and if I mess up again I have an easy fix. Thanks again!
    El Presidente and scotty85 like this.
  14. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Good stuff, keep us posted on how you get on. :)
    scotty85 likes this.

Share This Page