[AT&T] Update Problem

Last Updated:

  1. Aim006

    Aim006 Member

    Hey so I know the latest OTA update from att was released a while ago but I haven't found a solution to this yet so here's what happening. I have a SGH-1337 Galaxy s4 rooted on stock rom. I wanted to update to get the app to sd feature and I don't mind losing root access so I tried updating and it said Update Failed at 26% every single time. I know this is probably has something to do with the fact that I am rooted but I have heard that a lot of people that had root before updated perfectly but then lost root which I am fine with. So I am looking for a solution to this problem. I want to be able to update to the latest OTA manual or automatic install. It would be great if I didn't have to factory reset or wipe, thanks!

  2. Mr. Lucky

    Mr. Lucky Well-Known Member Contributor

    Did you use root to freeze or delete system apps? If so, you'll need to restore them before OTA will work.
  3. Aim006

    Aim006 Member

    I had 2 system apps disabled so I enabled them and tried the update, no luck.
    I don't remember ever freezing any apps, and even though I did a factory reset before, is there any way of knowing if I deleted any system apps and if so, which ones?

    Is there anything else that could prevent me from installing the OTA?
  4. Mr. Lucky

    Mr. Lucky Well-Known Member Contributor

    Disabled apps wouldn't cause a problem. You do realize that you have to unroot first, and you won't be able to regain it, right? The update locks the bootloader and there are not currently any exploits to get around it. Curiously, there is a workaround for the updated S4 Active though. I guess it's just a matter of time for the S4.

    To answer your question about how to tell whether you deleted system apps, you'd have to look at the manifest file and compare it to what you have in your system folder. There might be an easier way, but I don't know it.
  5. Aim006

    Aim006 Member

    I thought that the update would automatically unroot my device? If I have to manually unroot in this case, what would be the easiest way to do so without wiping my data? And yeah I know I won't be able to root again which is fine I just want the new app 2 SD feature.

    I don't think the problem are the system apps, more because I'm rooted, but just for future reference, what and where is this manifest file? Thanks!
  6. Mr. Lucky

    Mr. Lucky Well-Known Member Contributor

    I don't want to give you bad info, and I've never had reason to unroot without a factory reset. I think your best bet might be to research over at XDA. For sure someone has already found the least intrusive method. And if you are just running rooted stock ROM, forget what I said about the manifest.

    BTW, the app2sd feature only moves app data. You'll still need root to move the actual apps.
  7. Aim006

    Aim006 Member

    Do you think using an app to temporarily unroot and do the software update then would work?

    How about using an app to unroot completely like an app I've heard called One Click or something? Would those work?

    For the app2sd, I actually thought it was the opposite. Moving the app data is great for me as I can get more games like Real racing 3,gta,etc. But how Do you move apps with root? I've only found a way to move the data with Folder mount which is kind of complicated for me so that's why I want this update so badly.

    Edit: I just found out you can install the Super SU app from Google play and do a complete unroot from that app. Is this safe and will it work on the s4? And will it erase data?

    Edit: I just did the cleanup unroot thing from the Super SU app and it has disappeared and I cannot use any of my root apps anymore. It seems like it worked, but then my device status is still custom and bootloader is still custom/unlocked. I'll try the OTA and see what happens.

    We'll, after that it still unfortunately did not update successfully. Once again, it said Update Failed at 26%. What do I do? I'm so upset. And after I booted up after the update fail, it said "No firmware" in a message at the bottom of my screen similar to when it says Superuser granted to...
    Does this mean anything?

Share This Page