[AT&T] Wifi Tether - Rooted

Last Updated:

  1. jconway23

    jconway23 Well-Known Member

    Hey All,
    Samsung Galaxy S3 (i747) user here. Rooted my phone to use Wifi Tether. Installs no problem followed all the directions. Even launches fine. However I tried connecting me Nexus 7 to my phone and nothing. Even tried a laptop. It would appear that the SSID isn't broadcasting but I don't see any option to turn it off or on.

    Anyone get this to work? I'm on At&T as well.

  2. mrhomiec

    mrhomiec Well-Known Member

    what ROM are you using?

    some custom ROMs have a built in WiFi tether, and an app isn't necessary.
  3. jconway23

    jconway23 Well-Known Member

    All stock still. Just ran the root this morning while here at work. To be honest I am new to Android(root). Was an Iphone user for a long time. However I am a PC tech and have knowledge about technology. LoL But I'm guessing I did something wrong or it simply does not work on AT&T. I have an unlimited plan as well. Grandfather'd in.

    My plan was to read up on the different roms and such today. But I got busy here at work. Any help is greatly appreciated.
  4. beerdrinker

    beerdrinker Member

    I am having the exact same problem.

    I did a search and posted in the Sprint subforum (didn't realize I was in that subforum), so I'll repost here since it is the AT&T subforum:


    I am in the same boat as the OP. I rooted my phone specifically to use wifi tether and it doesn't work. I rooted the phone using InfernoByrd1's YouTube video instructions (here: How to Root Samsung Galaxy S3 AT&T/Sprint/T-Mobile/Rogers - YouTube).

    I then downloaded the wifi tether app from the Play Store. It installed fine. I then changed it to the recommended settings that qbking77 recommended. It appeared like everything was working fine, except that the wireless network doesn't show up on my tablet or laptop. I then went back and noticed they added the Galaxy S3 in the list of devices for the tether app (which wasn't on the video). I selected the Galaxy S3, but the same problem persisted. I have since restarted my phone twice, restarted the app several times, and even uninstalled and reinstalled the app... But it still doesn't work.

    I have the android operating system 4.1.1 and the wifi tether version 3.2beta2. I have an AT&T phone.

    Any help would be appreciated.
  5. jconway23

    jconway23 Well-Known Member

    Yup thats what it was doing for me. Even tried different versions of Wifi tether. I was on a different forum last night (Nissan Xterra Forums) and a guy was posting about how he put a Nexus 7 in his dash....Anyway...I PM'ed him about his setup and he gave me the foxfi program. It was a .apk file so I was actually able to install it. I can get my phone and Nexus 7 to tether but on the Nexus i can doing anything internet related. We're gonna chat more about it today. If I get anywhere with it I will let you know.

  6. shelliewnj

    shelliewnj Well-Known Member

    What I found is I can tether with bluetooth but not wifi. But I have the mobile share
  7. beerdrinker

    beerdrinker Member

    Okay, after some searching it seems others are having this problem and the solution for many of them was to get a deodexed ROM.

    I am so over my head with this right now. I'm not very technically savvy with this stuff. I was able to easily follow a YouTube instructional video to root it. But, I don't know where to even start with this deodexed ROM stuff. I've found a bunch of reading material on it, but I don't know most of the terms that are used in describing it. From what I gather, deodexing the phone basically just changes the way in which the phone organizes things?

    Is there an easy and trusted way to do this?

    Sorry jconway, I don't mean to take over your thread, but hopefully this can help us both out.
  8. jconway23

    jconway23 Well-Known Member

    Whatever helps to fix the issue is fine with me. I'm sure I can do the ROMS. I just don't know much about them yet. New to the Android world so I'm still learning a few things. LoL
  9. mrhomiec

    mrhomiec Well-Known Member

    i actually never tried to tether on the stock ROM. i went straight into using custom ROMs, and with just the built-in settings, i was able to tether with almost everyone i tried.

    be careful about the custom TouchWiz ROMs that are ports from another carrier, those have been hit or miss on my tries. and even some AT&T based TouchWiz ROMs didn't work.

    but if you use an AOSP-based ROM, then it should almost always work, i've never had an issue with one. tried with ParanoidAndroid (PA), CyanogenMod (CM), and AOKP.

    anyways, i don't use any app for WiFi tethering anymore. if it's in the settings, it should just work.
  10. jconway23

    jconway23 Well-Known Member

    Guess I have to research the ROM installs now. Its about the only thing I don't know about so far when it comes to Android. Must be good since I see alot of people talking about them on youtube and of course on these forums.
  11. mrhomiec

    mrhomiec Well-Known Member

    XDA Developers will become your go-to place for any custom ROM. as well as support for those ROMs too.

Share This Page