Auto Forward SMS to another phoneSupport


  1. iskortch

    iskortch Well-Known Member

    There is an option in the stock messaging app which allows you to forward incoming sms to another phone#. When I activate it, it does not forward any messages. I have ensured to phone# entered is correct and the static icon is shown in the status bar showing the function is active. I have tried different prefixes of the phone # - i.e. ###-###-####, 1###-###-####, +1###-###-####. I have also tried entering the number with and without the dashes. I contacted AT&T via chat and they have no clue about the funtion. The HTC support website gives instructions on how/where to activate the function. Has anyone had any luck activating the function?

    Advertisement
    :
  2. sharksfan7

    sharksfan7 Well-Known Member

    Never tried using this feature but decided to test it out after reading your post. At first it didn't work but I was able figure it out and got it working. Are you by chance also using a third-party messaging app? I use GOSMS and there's an option in the Settings to "Disable other message notification", which prevents duplicate notifications from other messaging apps. I normally have that checked. With that checked, the forwarding didn't work. I unchecked that and forwarding did work. I also enabled/disabled different notification options in both the stock app and GOSMS and the forwarding worked in all of them as long as the "Disable other message notification" option was not checked. As long as I had notifications in the stock app disabled, I didn't get duplicate notifications.

    If you are using a third party messaging app, dig through the settings to see if there is a similar option. In GOSMS it is under Advanced>Receive Settings. Not exactly sure of the technical reason why that option prevents the forwarding. If you don't have a third-party app installed then I don't know why it's not working.

    I tested entering the forwarding number in different ways, ########## and 1-###-###-####, as well as creating a contact for the number and selecting that in the forwarding configuration. In each case the forwarding worked. So I don't think that matters.

    Hope this helps put you on the path to getting it to work for you. If so, hit the Thanks button.
    iskortch likes this.
  3. iskortch

    iskortch Well-Known Member

    Thanks for your help. I do use GOSMS and I had thought I disabled the notifications as well in the stock app. I will take a look again. I bet I missed a step.

    Glad you were curious and fiddled around. I was fearful AT&T was somehow blocking the function since they dont offer it themselves....
  4. PVS

    PVS Well-Known Member

    GoSMS is a great app, but not sure why they don't make that setting more friendly to other apps by default (rather than the other way around). I am a dev of an SMS forwarding app btw (PhoneLeash), and it would be nice if you can take a look at it. See here.

    PVS
Loading...

Share This Page