auto-rotate not working


Last Updated:

  1. DBHALL

    DBHALL Active Member

    My auto-rotation stopped working stopped working when I was on Midnight ROM, thought when I updated to GB28 it would be fixed. Have read in forums that this is fairly common, but tried many different things to fix, none of which worked? Any suggestions would be greatly appreciated! Midnight didn't cause this. Didn't mean to make it sound like that

    Advertisement
  2. christiansoto

    christiansoto Well-Known Member

    did you calibrate your device before it happen
  3. DBHALL

    DBHALL Active Member

    Before and after
  4. neo_lithic3k

    neo_lithic3k Active Member

    I ran into that issue in one of the roms as well. In that rom there was a checkbox to use calibrated values, or something to that effect. When I unchecked it, auto-rotate started working again. (I did calibrate my phone but for some reason I still had to uncheck it)
    DBHALL likes this.
  5. christiansoto

    christiansoto Well-Known Member

    It happened to me before so i ordered a replacement
  6. BGOszman

    BGOszman Member

    Had the exact same problem. Took a bit of messing with it but I finally figured out that the sensor was reading upside down and at a 45
    DBHALL likes this.
  7. bronder

    bronder Member

  8. DBHALL

    DBHALL Active Member

    Calibration is done in settings-motion-sensitivity
    TheBritton likes this.
  9. bronder

    bronder Member

    thanks, but that did nothing.
  10. Prey521

    Prey521 Well-Known Member

    I'm having the same problem on Midnight Rom. Calibrating doesn't fix it.
  11. DBHALL

    DBHALL Active Member

    I ended up having to order a new device as I wasn't sure what exactly caused the problem. Narrowed it to a problem in script, possibly from deodex? Finally gave up! Sorry I'm not able to provide more help.
  12. dueltothedeath

    dueltothedeath Well-Known Member

    My auto rotate also stopped working.. if anyone finds a fix without having to go back to older version of cm10.1 to calibrate let me know
  13. cpk

    cpk Member

    I had the some problem. I wiped, cleared, and reinstalled. Autorotate works perfectly now.
  14. Prey521

    Prey521 Well-Known Member

    Gonna give that a try, thanks
  15. DBHALL

    DBHALL Active Member

    Try updating your profile: settings-updates-update profile:p
  16. bronder

    bronder Member

    Tried this, still nothing... thx for the suggestion. Will putting cm10.1 on, and using the calibrate from it help? It seems like this is a fix.
  17. Prey521

    Prey521 Well-Known Member

    CM10 is a completely diff ROM. So yes, it will fix the auto rotate issue, but you won't be running MidnightRom anymore.
  18. DBHALL

    DBHALL Active Member

    Try *#0*# This is the only option I didn't try before I ordered new phone!
  19. Prey521

    Prey521 Well-Known Member

    Resolved the issue with the rotation. With the help of an XDA member (dev for Magic Unicorn ROM), he had me flash an old version of CM10 which has the gyro sensor calibration tool. I flashed it, enabled the Use calibration values, calibrated the Gyro, then confirmed that it's working in the apps, then disabled the "Use Calibration Values", factory wiped and flashed the ROM of my choice and voila, rotation is working!
  20. steeljack99

    steeljack99 Well-Known Member

    good to know incase it happens to us, you may want to post a link to said rom incase it happens to others :D
    Prey521 likes this.

Share This Page