Autocomplete weirdness (user dictionary discussion)Support

Last Updated:

  1. answerman

    answerman Well-Known Member

    My HTC One (Verizon) has started to get wonky as far as autocomplete. It's gotten so weird that I've actually turned it off as it takes longer to fix the wrong autocomplete words than it does to just type and then proof.

    I will try to explain this as best as I can. There is a definite pattern to it, it seems to assume that I want the letter to the left of the key I press. So, for example, if I type "I", what comes up first in the autocomplete box is "U". If I type "M" it comes up "N". You get the idea. So, when I want "my", it assumes I mean "NY", etc. The behavior is to change what I am typing as soon as I hit the second letter. Where it gets really frustrating is when I type a longer word. Let's use the word "observe: as an example: I type the O, then the B, and autocomplete changes it to "IB" which of course freaks it out as there are no words starting with "IB" and therefore I just get completely unrelated words in the autocomplete suggestion box.

    The only way it's usable is to (using "my" as an example) is to type the M, then in the autocomplete suggestions tap the "M" (which is the second choice as "N" is the first), then continue on.

    I've recalibrated a couple of times, and I've checked and none of this is referenced in the personal dictionary, so it's not like I saved the words or anything.

    Anyone else seen anything like this? I can post a screenshot showing this behavior if this wasn't clear enough.

  2. marctronixx

    marctronixx Moderator Moderator

    Clear your personal dictionary.
    Try a different keyboard (swype, SwiftKey, etc) and verify behavior with other keyboards.

    Are you rooted?
  3. answerman

    answerman Well-Known Member

    No, not rooted yet. I've cleared the personal dictionary and reset the calibration again. Still happening. Oddly enough, trying it again, the behavior I described only happens on landscape... the portrait keyboard doesn't do the "letter to the left" thing. Downloading SwiftKey now to try it.

    Wow. SwiftKey is way better. And it's not doing the funky autocomplete thing. Problem solved, though I would still like to know what was causing it in the first place.
  4. Phydeaux

    Phydeaux Well-Known Member

    I'm having the exact same problem with mine, the auto-complete is complete rubbish.
  5. Realrhyno

    Realrhyno New Member

    I'm having this dictionary problem I can't seem to fix. Before I get into it I want to say I've checked the personal dictionary area of the phone and deleted everything. My problem is that whenever I type a certain word it gets written in all capital letters. The word is 'know'. More specifically only after it is written after a word that is capitalized also. I.e. the letter I. So say someone tells me I need to see a movie, my phone will respond with I KNOW. I don't want people to think I'm yelling at them. And I do not know how to solve this problem.
  6. marctronixx

    marctronixx Moderator Moderator


    did you delete the word from your dictionary?

    are you using 3rd party keyboards? if not, try swiftkey (free) and test.

    are you using swype? if so, use the stock configuration and see if the word pops up.
  7. Realrhyno

    Realrhyno New Member

    The word isn't actually in my personal dictionary. I'm assuming because it's already a word in the phones dictionary. Only difference is that it's in all caps. I'm not using anything except the stock qwerty keyboard.
    marctronixx likes this.
  8. marctronixx

    marctronixx Moderator Moderator

    ive not seen that behavior in the stock dictionary, so something local to your device is causing the issue.

    did you delete your "learned" dictionary? did you try a different keyboard (swype, swiftkey, etc)?

    if this just started happening, it sounds like its due to the phone "learning" a certain phrase, etc.
  9. Realrhyno

    Realrhyno New Member

    Yeah I agree. I think it learned a certain phrase. I'll try a new keyboard eventually. If I figure out how to correct the issue I'll post again.
    marctronixx likes this.
  10. andrew79

    andrew79 Member

    I recently got a HTC one. When typing text messages sometimes I get the message that
  11. marctronixx

    marctronixx Moderator Moderator

    settings, language and keyboard.

    adjust settings to taste....
  12. rinch

    rinch Member

    From the HTC ONE manual - Verizon
    Editing or deleting words and phrases in the word prediction dictionary 1. Go to Settings, and then tap Language & keyboard. 2.Tap HTC Sense Input. 3.Tap Personal dictionary.
  13. dgrobe2112

    dgrobe2112 Well-Known Member Contributor

    just to add to this..

    i am not rooted.. and very miticulous about my autocorrect.. but im the same way.. this ONLY happens in landscape. the same issue.. when i type I, it will auto fill with U. LOL, will turn into KIK.. or LIL. keep turns to jeep.. only in landscape.. this does NOT happen in portrait mode..
  14. marctronixx

    marctronixx Moderator Moderator

    if this is seen as a bug, open up a ticket with HTC. we all know the OS branding varies slightly from carrier to carrier, so what may work on one may not work on another.

Share This Page