Autocorrect Passwords on Microsoft RD ClientSupport

Last Updated:

  1. eStormIT

    eStormIT New Member

    We're trying to implement the Microsoft Remote Desktop Android app to over 100 employees. Devices being used: Samsung Galaxy S4 & Samsung Galaxy Tab 2. The intention is for us to remotely log into a terminal server farm.

    The problem:
    We have password complexity requirements that involve variations of capital & lowercase letters, numbers and symbols. The issue is that some of the users' Android devices are forcing an auto correct when they enter their password to log into our terminal server farm. And they're unable to see which characters are actually being used because all they see is ********.

    Someone had a password similar to "Microsoft!123" and if you're familiar with the Auto Correct on a Samsung Galaxy S4, you know that it will force a space after an exclamation point. It's too hard for the typical end user to know whether or not to backspace in this instance and forcing users to reset their passwords to something of a different format is a work around that defeats the purpose of making something unique. One solution would be to disable Auto Correct or Auto Spacing, etc. But then that would affect text messages and emails as well unless the user changes the setting back and forth (again, too much for most end users).

    I would just like to know if there are others out there who are having this same experience and whether or not you have a simple, sustainable solution. Thanks in advance.

  2. Rukbat

    Rukbat Well-Known Member

    It sounds as if the keyboard being used for he app is defective - autocorrect should be inactive in a password field. (Or the app is using a text field and manually masking the input, which is making more work for the developer and not using the correct function for the job, which is a password field, not a text field.)

    About the only thing you can do, until the app is fixed, is to disable autocorrection on the devices. It's not that much more work to use manual autocorrection unless you're a really terrible speller (or really old like I am and type in about 90% typo - but I still have autocorrection turned off in my phone, because it gets things wrong too often).
    eStormIT likes this.
  3. eStormIT

    eStormIT New Member

    Thanks for your response. I do think the issue lies in the way that Microsoft (of all companies) coded this part of the program. I guess I'll have no choice but to either disable autocorrect entirely or just disable the auto spacing. It's just unfortunate. The point of switching some 100 people from PocketCloud to this RD Client was an attempt to eliminate some minor issues and work arounds. But we'll have to use a work around just to get into the app. And to stay consistant, we might have to have everyone use the workaround even though only a few are affected, because who knows what new password they'll reset to and whether or not it would be an issue? Either the user would need to disable auto correct, save the password in the app and then enable autocorrect again and repeat potentially every 90 days (workaround). Or I can disable autocorrect from the get-go for them. It's not that hard to work without Autocorrect but we all know what happens we people get used to doing things a certain way, it becomes ingrained.

    I'm going to give myself an extremely complex password and test it out, disabling certain options and trying to log on with it. If anyone reading this has the same issue or is interested, I'll post results.

Share This Page