Support Autocorrect / word Replace BUG! Anyone else seeing this?

Discussion in 'Android Devices' started by DonClark, Dec 6, 2011.

  1. DonClark

    DonClark New Member
    6

    Dec 1, 2011
    2
    1
    6
    I've found that on my Galaxy Nexus if I replace a word it will revert back to the original word upon sending the text/IM.

    Try this out! I fix a word with a red line under it, or press and hold on another world and replace it with the correct word and then message looks perfect. Then I press send and the message that is sent doesn't include any of the corrections! Like the words revert back to what they were when I first typed them!

    Is there any way to submit a bug report to google?
     

    Advertisement
  2. WeeJockPooPong

    WeeJockPooPong New Member
    6

    Dec 16, 2011
    3
    1
    6
    Falkirk, Central Scotland
    Confirmed, I get this too. Subscribing to the thread to see if there is a Bug Report page for Google.

    Great phone still though.

    WJPPMP
     
  3. WideFive

    WideFive Member
    5

    Dec 24, 2009
    8
    0
    5
    VW Suspension Fabrication
    Strongsville, OH
    Same problem here, while texting anyhow. It will correct the word, but the red line is still there. If I keep typing sometimes it will revert back, other times not until after sending.
     
  4. eyc

    eyc Well-Known Member
    53

    May 2, 2010
    177
    97
    53
    Chicago, IL
    In what context? Gtalk? SMS? Emails? I just tested it in Gtalk, and I could not duplicate the bug.
     
  5. WideFive

    WideFive Member
    5

    Dec 24, 2009
    8
    0
    5
    VW Suspension Fabrication
    Strongsville, OH
  6. ocean1

    ocean1 Well-Known Member
    36

    Nov 6, 2009
    126
    9
    36
    confirmed
     
  7. The_Chief

    The_Chief Accept no imitations!
    Moderator
    1,933

    Nov 17, 2009
    12,503
    12,151
    1,933
    Male
    I'm retired: every day's a Monday :P
    Manchester, TN
    Not sure if it helps, but Android 4.0.3 is on the way and offers the following changes:

    "Spell-checking

    For apps that accessing spell-checker services, a new cancel() method cancels any pending and running spell-checker tasks in a session.
    For spell-checker services, a new suggestions flag, RESULT_ATTR_HAS_RECOMMENDED_SUGGESTIONS, lets the services distinguish higher-confidence suggestions from lower-confidence ones. For example, a spell-checker could set the flag if an input word is not in the user dictionary but has likely suggestions, or not set the flag if an input word is not in the dictionary and has suggestions that are likely to be less useful.

    Apps connected to the spell-checker can use the RESULT_ATTR_HAS_RECOMMENDED_SUGGESTIONS flag in combination with other suggestion attributes, as well as the getSuggestionsAttributes() and getSuggestionsCount() methods, to determine whether to mark input words as typos and offer suggestions.

    A new FLAG_AUTO_CORRECTION style for text spans indicates that auto correction is about to be applied to a word/text that the user is typing/composing. This type of suggestion is rendered differently, to indicate the auto correction is happening."

    I have searched all over Google and can't yet find a place to report bugs :(
    I'll keep looking, as this is pretty serious stuff!
     
  8. cggorman

    cggorman Well-Known Member
    163

    Mar 25, 2010
    676
    664
    163
    Yeah, I've been getting this. Assumed a fix was either incoming or due to app incompatibility (needing ICS update).
     
  9. jimmypop13

    jimmypop13 Well-Known Member
    43

    Oct 18, 2011
    187
    48
    43
    Spring, TX
    I have this too. Also major lag when typing in landscape after the first few words
     
  10. wickets

    wickets Member
    16

    Dec 20, 2011
    24
    2
    16
    took the phone to vzw, tech there did a 'soft' reset which helped for a few hours and then back to strangeness....sometimes it lets you correct a word, sometimes it doesnt and then sometimes it lets you correct, but two typed words later it reverts back :eek: Im going back there today.....the guy said a factory reset might help....total pita
     
  11. SuperNova725

    SuperNova725 New Member
    5

    Dec 22, 2011
    4
    0
    5
    I also have the same bug and a lag when texting where it gets 5-6 words behind. I took my phone to vzw all they did was a hard reset which didn't fix anything. I was also able to replicate the bug on their display phone proving to them it wasn't just me.

    A friend of mine rooted his phone and doesn't have this bug, could rooting the phone some how solve the problem?
     
  12. Joe Schmuck

    Joe Schmuck Well-Known Member
    16

    Dec 4, 2011
    50
    7
    16
  13. SuperNova725

    SuperNova725 New Member
    5

    Dec 22, 2011
    4
    0
    5
    Just noticed the spell check/auto correct bug only happens when the phone is used in landscape orientation.
     
  14. mikepic

    mikepic Well-Known Member
    53

    Jul 17, 2010
    220
    53
    53
    Analyst
    CT
    I was getting this too but I assumed it was because I'm using a different keyboard with autocorrect and they were clashing.
     
  15. LoBatt

    LoBatt Well-Known Member
    43

    Mar 4, 2010
    275
    42
    43
    Try turning off spelling correction in the language and keyboard settings but leave it on in the settings for the keyboard you're using and see if that solves the problem. I saw a tip in another thread that said this would fix the keyboard lag and it worked for me. Maybe this will fix the sms bug too.
     
  16. SuperNova725

    SuperNova725 New Member
    5

    Dec 22, 2011
    4
    0
    5
    I am using the ICS default keyboard, the only settings I see for it are under Language & input. I don't see a settings or menu when the keyboard is on screen for its own settings. I actually quite like the stock keyboard in ICS so had no need to download an app to replace it, but if it fixes the spell check and lag problem It might be worth it.
     
  17. LoBatt

    LoBatt Well-Known Member
    43

    Mar 4, 2010
    275
    42
    43
    Settings>language and input. Just under "language," uncheck "spelling correction." Then go down to "android keyboard," click the settings icon next to it. Go down to auto correction and select "off," "modest," "aggressive," or "very aggressive." I have mine on "modest."

    Don't know if this will fix the sms bug people are seeing but it does fix the keyboard lag in landscape mode. I stumbled upon this tip in the "tips" thread early and have never seen the sms bug.

    I also don't know why there would be a "master" auto correct option then additional auto correct options for each keyboard.
     
  18. SuperNova725

    SuperNova725 New Member
    5

    Dec 22, 2011
    4
    0
    5
    Turning off spell check does fix the lag, and since spell check is off the spell check bug won't be an issue. I hope they push out a fix for the spell checker because I do like it a lot, its a great feature, if it worked right. it works great in portrait mode. For now I'll just leave spell check off auto correct set to modest does a great job fixing my basic typo's.
     
  19. Andrew5225

    Andrew5225 New Member
    5

    Jun 4, 2012
    2
    0
    5
    I'm having the same problem! Only when in landscape as well. If I switch to portrait to make the correction and then switch back the correction will stay. But do I really need to flip my phone back and forth to make a simple correction? My phone has also been reset and that did not fix it!
     
Tags:

Share This Page

Loading...